06-07-2015 12:20 AM
31 12
tools
  1. DroidN3WB's Avatar
    Hi there,

    I am finding when I put something into the Google calendar app on my phone, the time is completely different when I go online and login into google to see what I scheduled. For example, I'll put 10:30-1 Doctors appointment on my phone but when I go on google calendar online it'll say 6-9PM.

    The same thing happens if I enter information online - so say I put 2-4PM school, if I look on my phone it'll appear at some random time like 5-7 or something.

    Is there any way to fix this? I like using Google calendar because it's clean and simple and I got a widget that displays all my appointments nicely on the front screen. Is there any other calendar app that can do the same thing if this is unfixable? I was looking forward to being able to edit my calendar online and having it go right to my phone but this is ridiculous.

    Thanks for all your help
    04-11-2013 08:28 AM
  2. Golfdriver97's Avatar
    Hi there,

    I am finding when I put something into the Google calendar app on my phone, the time is completely different when I go online and login into google to see what I scheduled. For example, I'll put 10:30-1 Doctors appointment on my phone but when I go on google calendar online it'll say 6-9PM.

    The same thing happens if I enter information online - so say I put 2-4PM school, if I look on my phone it'll appear at some random time like 5-7 or something.

    Is there any way to fix this? I like using Google calendar because it's clean and simple and I got a widget that displays all my appointments nicely on the front screen. Is there any other calendar app that can do the same thing if this is unfixable? I was looking forward to being able to edit my calendar online and having it go right to my phone but this is ridiculous.

    Thanks for all your help
    Try going into Settings>Application Manager>swipe over to All Apps>Calendar>then tap clear cache. Then resync to Google. If that doesn't work, go through the same steps to Application Manager and delete data, and re sync.
    Sophia Liu and coachpelkey like this.
    04-11-2013 09:08 AM
  3. tabletnovice's Avatar
    I'm no expert by any means so take what I have to say with a grain of salt.

    I had similar problems with Google Calendar: I'd post an appointment via my computer but it wouldn't appear on the GS3 calendar app that was pre-installed on the S3 even though they were synched. So I downloaded and installed the Goog Calendar App from the playstore (blue & white icon). Now everything is working perfectly and problem-free; I have no idea why it works or if this is the best approach. I only know it does work and without any problems.

    I have two GC apps on my phone, but only click the original, pre-installed (Green and White) icon to access the calendar on my phone.

    04-11-2013 03:50 PM
  4. gnr_2's Avatar
    Sounds like it's as simple as changing your time zones. I'm guessing it is saying one time zone on your phone but UTC on your online calendar as that is the default.

    Sent from my totally awesome Sprint Galaxy Nexus, even if I don't know all its secrets yet.
    04-11-2013 06:32 PM
  5. Jemcne7's Avatar
    I have a similar but different issue. Things I put into my calendar on my Samsung calendar app appear correctly in my on-line Google Calendar. However things I put into my on-line calendar do not show up on my Samsung cell phone. Any help would be appreciated
    05-06-2013 12:40 PM
  6. meyerweb#CB's Avatar
    That's a new one on me. Usually it's the other way around. Do you possibly have multiple on-line calendars that are linked together, but only one of them is linked to the phone?
    05-06-2013 01:58 PM
  7. Goyo Goyong's Avatar
    Thanks tabletnovice. I had deleted the blue calendar as I thought it was duplicating what the green one was doing. Then my calendar stopped syncing. Reinstalled the blue calendar and all works well. Thanks again for the tip.
    Michael Porto likes this.
    05-13-2013 06:36 PM
  8. tlwmomof3's Avatar
    When adding something to my google calendar, it would show up on my Galaxy S3, but not vise versa. I downloaded the google calendar app and now it works! Thank you so much for the tip! I am a mobile notary & doc signing agent so my calendar is extremely important. Thanks again!
    05-14-2013 11:26 AM
  9. Michael Porto's Avatar
    Yes, I thought the same and deleted the "Blue" calendar app...then started to notice a few days later my calendar did not sync. I re-installed the "Blue" calendar and now all calendars are syncing.
    05-17-2013 06:30 PM
  10. firedogee7's Avatar
    Thanks GOLFDRIVER97! This is very helpful and cleared up my problem (had to delete data in addition to cache)! Also, I wanted to note that the Samsung stock calendar and the Google Calendar app do not coexist very well. I eventually had to uninstall Google Calendar app because of all the problems the conflict was causing. In some ways I do like the Samsung Calendar app a little better, like the month view with daily preview. Anyways, all the conflicts are gone based on your suggestions (and uninstalling Google Calendar app). Thanks!
    Golfdriver97 likes this.
    05-21-2013 10:36 AM
  11. Golfdriver97's Avatar
    To anyone reading this thread, at least on the S3, when you create an new event the default is ALWAYS on My calendar, meaning the Samsung calendar. You have to tap that to switch it to Google, but that switch does not stay. I have tried many times to try to change the default to Google but to no avail. I have had no problems running two apps at once. It sucks....but what can you do? Other than us starting a petition to Samsung...lol.
    05-21-2013 11:35 AM
  12. ansextra's Avatar
    I have found the same issue and had to install the Google calendar on my S3 to successfully sync with Google. Problem is that turning off notifications on either calendar doesn't stick and I keep getting duplicate notifications. I like the Samsung calendar better in one respect. It allows me to see participant availability when scheduling a meeting (on Exchange) and I can't find a way to do this with Google Calendar. I'd be fine with Google Calendar if it weren't for this feature. Does anyone know of any way to turn notifications off on one of the calendars and make them stay off permanently?
    07-23-2013 11:27 AM
  13. meyerweb#CB's Avatar
    I have found the same issue and had to install the Google calendar on my S3 to successfully sync with Google. Problem is that turning off notifications on either calendar doesn't stick and I keep getting duplicate notifications. I like the Samsung calendar better in one respect. It allows me to see participant availability when scheduling a meeting (on Exchange) and I can't find a way to do this with Google Calendar. I'd be fine with Google Calendar if it weren't for this feature. Does anyone know of any way to turn notifications off on one of the calendars and make them stay off permanently?
    You don't need to install a different calendar. When creating an appointment, you just need to tell the phone you want the even stored as a Google calendar event, rather than a "My Calendar" event. Once you've done that once, the phone should default to Google for all subsequent events, unless you change it manually again.
    BroJohnGee likes this.
    07-23-2013 02:36 PM
  14. ansextra's Avatar
    You don't need to install a different calendar. When creating an appointment, you just need to tell the phone you want the even stored as a Google calendar event, rather than a "My Calendar" event. Once you've done that once, the phone should default to Google for all subsequent events, unless you change it manually again.
    That wasn't my issue. I'm trying to disable notifications permanently from the Google Calendar. Even though I turn them off they seem to turn themselves back on again. Samsung calendar does the same thing so I'm getting two notifications for every appointment.
    07-23-2013 03:12 PM
  15. meyerweb#CB's Avatar
    I would suggest clearing cache for the calendar apps, and see if that helps.
    07-23-2013 03:38 PM
  16. ansextra's Avatar
    I would suggest clearing cache for the calendar apps, and see if that helps.
    I'll try that. Thanks.
    07-23-2013 03:50 PM
  17. Shay D. Life's Avatar
    I ran into this issue today after flashing a ROM, and did have to delete data for the calendar, calendar widget, and calendar storage.
    phillysdon04 likes this.
    10-09-2013 07:36 PM
  18. mjohansing's Avatar
    I just had this error myself. i went to the calendar app, and it had no cache to clear. so i went to the calendar storage, and cleared data. Then re-synced. That worked like a charm.
    Thanks
    phillysdon04 likes this.
    10-14-2013 09:11 AM
  19. TimBoch's Avatar
    I just had this error myself. i went to the calendar app, and it had no cache to clear. so i went to the calendar storage, and cleared data. Then re-synced. That worked like a charm.
    Thanks
    This worked for me too. Thanks for the help. I hope I don't have to do this often to keep Google calendar synced to my Android phone.

    Sent from my SCH-I535 using AC Forums mobile app
    11-06-2013 02:05 PM
  20. PM Lim's Avatar
    Hi there - I had the same problem and just discovered the reason why! My phone is set to UK (where I am), but when I registered for google account I was living in Malaysia, so the datetime setting was Malaysian time zone.

    When I changed it to GMT, the time synced properly.

    Hope that helps!
    11-06-2013 07:40 PM
  21. Sophia Liu's Avatar
    Thanks for your suggestion. After following your tip to clear the data under Calendar settings, all works well. The calendar syncs nicely. Really appreciate your help. You make my life easier.. A lot!!! Thanks!!
    12-01-2013 05:48 AM
  22. Sophia Liu's Avatar
    Really helpful suggestion. Calendar syncs perfectly. All goes well.Thanks a million, Golfdriver97!
    12-01-2013 05:50 AM
  23. Golfdriver97's Avatar
    Really helpful suggestion. Calendar syncs perfectly. All goes well.Thanks a million, Golfdriver97!
    Welcome to the forums.
    Since you are new, have you created an intro thread and said Hi to the community?
    Introductions - Android Forums at AndroidCentral.com
    12-01-2013 09:02 AM
  24. fred95901's Avatar
    I have a calendar set up on my gs3, many events and want to sync with Google calendar on my pc. After I loaded the google cal. app on my phone everything synced then I looked at the calendar on the pc and nothing was there. Then I made a new entry and it synced fine across all calendars. How do I get the previous events to sync???
    Thanks
    02-01-2014 03:12 PM
  25. meyerweb#CB's Avatar
    I don't know if this will work. I kind of doubt it, but it's easy enough to try. Go into the Application manager (in setings), and clear cache for the calendar app. If you have multiple calendar apps, clear cache for all of them. Then go to Settings / Accounts, and manually sync your google account.

    If that doesn't work, I know of at least one pay-for Calendar app that will let you change the calendar appointments sync to on appt by appt basis, one at a time: https://play.google.com/store/apps/d...ware.PimlicalA

    There may be free calendar apps that would allow this to, but you'll just have to try them and see.

    The only other option would be to create new duplicate appointments, then delete the old ones.
    02-01-2014 10:17 PM
31 12

Similar Threads

  1. razr maxx calendar will not sync with google calendar
    By barrycinti in forum Droid RAZR MAXX
    Replies: 9
    Last Post: 04-27-2013, 10:21 PM
  2. Recurring Google Calendar appointments not syncing to Android Calendar
    By knightstac in forum General Help and How To
    Replies: 3
    Last Post: 07-09-2012, 12:42 PM
  3. Calendar Apps not syncing new events
    By jlewis in forum Sprint Photon
    Replies: 6
    Last Post: 03-22-2012, 05:23 PM
  4. Calendar reminders not syncing to phone.
    By Vance14 in forum Android Apps
    Replies: 0
    Last Post: 06-10-2011, 12:22 PM
  5. Recurring calendar appointments not syncing from Google Calendar?
    By knightstac in forum General Help and How To
    Replies: 0
    Last Post: 12-29-2010, 10:26 AM
LINK TO POST COPIED TO CLIPBOARD