1. clovesandcinnamon's Avatar
    I never was an iPhone user to begin with. I have a Galaxy S3 which I used in France for 5 months and didn't have any problem, but as soon as I switched to T-mobile in the US, I started not receiving any texts from iPhone users, unless they switch iMessage off. It's a bummer, because they don't always remember to do that. They do receive my texts, so it's just the other way round. Is there something I can do on my end? Basically all my contacts have iPhones, so having them switching iMessage on and off continuously isn't the most reliable solution. Thank you!
    07-04-2013 10:04 AM
  2. GSDer's Avatar
    Move back to France? Get an iPhone? Try a different carrier?
    What does T-Mobile have to say about the issue?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 4
    07-04-2013 12:00 PM
  3. rhl2's Avatar
    I think it is a technical problem and hope soon everything will be fine.
    07-04-2013 05:05 PM
  4. mssca's Avatar
    Contact T-Mobile and let them know... They probably can look into this and fix for you.

    Posted using Samsung GS III
    07-04-2013 09:57 PM
  5. clovesandcinnamon's Avatar
    i already checked with them. twice. they told me to delete my message threads and any 3rd party messaging apps. did that. nothing. they mainly blame it on the iPhone users. but I'm not having trouble with one or two. it's all of them! any other ideas?
    07-06-2013 09:35 AM
  6. grunt0300's Avatar
    Try thisTap on msg app>settings>check mark on these boxes:delete old msgs, delivery reports, group messaging, delivery reports, read reports, auto-retrieve, roaming auto retrieve, notifications, emoji support, softbank emoji. That's my set up, and it works. I have iPhone users, Android users, and even BB users in my family, and i get every sms & mms that they send me. I'm using the stock msg app, but i've used others in the past. GoSMS Pro used to "double" my msg sound, but even with that, i always received my msgs. If what i told you doesn't work, then take the phone back to your carrier, and demand another one. Good luck.
    P.S. IMHO, T-Mobile sucks. I've always been with AT&T.
    lormajoh likes this.
    07-06-2013 09:59 AM
  7. aestrada225's Avatar
    You need to have your friends edit their contacts list and change your phone number from iPhone to cell phone.
    07-19-2013 06:29 PM
  8. Jerry Smith2's Avatar
    I have found a solution!!!!! (At least with the Iphone/ S3 combination)
    Please pass this along to any other bulletin boards or people with Iphone.
    It seems that the Iphone's settings have a lot to do with it.
    After WEEKS of not getting my wife's texts from her IPhone, I changed my Galaxy S3's Sim card, have done powerdowns, soft and hard resets, I looked at my wife's Iphone - and did the following:
    On her IPhone:
    1. Do a hard reset (Press and hold top button on IPhone until it shuts down) then turn it on.
    Upon powering up, Hers said something like "add text phone number" when it powered up. I opened the error message box, and even though it showed the correct number, I went ahead and deleted the last digit on that screen, and keyed it back in, and saved that as her text phone number. (Im not sure what effect that had, but I did it anyway).
    But then I noticed: a. Her IMessage was set to "ON" which I left alone. But...
    b. Her "Send as SMS" setting was turned "OFF". Which I turned to "ON".
    Immediately her text messages started popping up on my Galaxy S3.
    I'm not sure if the changing the phone number for texts and re-saving it fixed the issue, or the "Send as SMS" did it, but so far, the texts are coming through.
    I'm not sure if it's a cure-all for all of the "Fail to receive text" problem, but it seems to be one solution.
    NOTE: In spite of what the bulletin boards on the internet say, It is not a problem unique to any one carrier. It seems to be an IPHONE settings issue with the way it sends texts.
    08-19-2013 07:19 AM
  9. STARGATE's Avatar
    Crapy iphone!
    My niece had this problem with her iPhone but don't know how she fixed it. Still, good to know about your findings. :thumbup:

    Sent From a Galaxy S4 Away!
    08-19-2013 08:13 AM
  10. GadgetMomma's Avatar
    I *think* another solution if the person with the galaxy has any other ios device, and how they have iMessages set up. My brother switched to an S3, and when I tried to text him it wouldn't go through on his phone, but they still went through as iMessage on my phone - because they were going through on his ipad! So he had to change the settings on his ipad to only send and receive imessage through his email address, which wasn't a huge deal to him. But we figure that my iPhone couldn't push a SMS on through to his phone because it was showing as sent and received on his iMessage account, just not on the device he wanted! But now that he's done that, my phone still tries to send it as iMessage first, then switches over to SMS. I have several other friends who have switched to android and this has happened with them as well.
    08-22-2013 08:00 AM
  11. Patrick Roberson's Avatar
    Fixed:
    Here was my issue. i have a galaxy 4, wife has an iphone 4s. all of a sudden i stopped getting her texts. She could still get mine. Apparently sometime in there my 7 digit number was typed in to send a text to instead of 10 digit. Iphone didnt know any better. The contact still appeared the same. The text thread still appeared together under my name with the 7 digit and 10 digit. couldnt tell which message was which. However, I could manually input my number and it would work, she could send me a text. To fix I went back and looked on my phone to where the last text i received from her was. I deleted on her iphone all texts between now and when it might have changed. This fixed it!
    08-25-2013 07:19 PM
  12. STARGATE's Avatar
    Wow! Well, the good thing is that it worked out for you. :thumbup:

    Sent From a Galaxy S4 Away!
    08-25-2013 10:35 PM
  13. Smorz's Avatar
    I think it's simply a matter of having an iPhone user turn off iMessages under Settings / Messages. It's crazy that they are not compatible, but apparently iMessages is a proprietary form of texting for iPhones - what a shock.
    10-12-2013 01:10 PM
  14. azamjamil's Avatar
    The solution is simple. The iphone user that has switched to Android needs to go the Apple site. Go to support and "unregister" his Iphone. Thats it.
    10-14-2013 06:17 AM
  15. azamjamil's Avatar
    Its very simple. The Iphone user that has switched to Android needs to go the Apple website. Select support and then "edit device" and unregister his Iphone. Thats it.

    I have found a solution!!!!! (At least with the Iphone/ S3 combination)
    Please pass this along to any other bulletin boards or people with Iphone.
    It seems that the Iphone's settings have a lot to do with it.
    After WEEKS of not getting my wife's texts from her IPhone, I changed my Galaxy S3's Sim card, have done powerdowns, soft and hard resets, I looked at my wife's Iphone - and did the following:
    On her IPhone:
    1. Do a hard reset (Press and hold top button on IPhone until it shuts down) then turn it on.
    Upon powering up, Hers said something like "add text phone number" when it powered up. I opened the error message box, and even though it showed the correct number, I went ahead and deleted the last digit on that screen, and keyed it back in, and saved that as her text phone number. (Im not sure what effect that had, but I did it anyway).
    But then I noticed: a. Her IMessage was set to "ON" which I left alone. But...
    b. Her "Send as SMS" setting was turned "OFF". Which I turned to "ON".
    Immediately her text messages started popping up on my Galaxy S3.
    I'm not sure if the changing the phone number for texts and re-saving it fixed the issue, or the "Send as SMS" did it, but so far, the texts are coming through.
    I'm not sure if it's a cure-all for all of the "Fail to receive text" problem, but it seems to be one solution.
    NOTE: In spite of what the bulletin boards on the internet say, It is not a problem unique to any one carrier. It seems to be an IPHONE settings issue with the way it sends texts.
    10-14-2013 06:18 AM
  16. azamjamil's Avatar
    Its very simple. The Iphone user that has switched to Android needs to go the Apple website. Select support and then "edit device" and unregister his Iphone. Thats it.

    I *think* another solution if the person with the galaxy has any other ios device, and how they have iMessages set up. My brother switched to an S3, and when I tried to text him it wouldn't go through on his phone, but they still went through as iMessage on my phone - because they were going through on his ipad! So he had to change the settings on his ipad to only send and receive imessage through his email address, which wasn't a huge deal to him. But we figure that my iPhone couldn't push a SMS on through to his phone because it was showing as sent and received on his iMessage account, just not on the device he wanted! But now that he's done that, my phone still tries to send it as iMessage first, then switches over to SMS. I have several other friends who have switched to android and this has happened with them as well.
    - - - Updated - - -

    Its very simple. The Iphone user that has switched to Android needs to go the Apple website. Select support and then "edit device" and unregister his Iphone. Thats it.


    Wow! Well, the good thing is that it worked out for you. :thumbup:

    Sent From a Galaxy S4 Away!
    10-14-2013 06:20 AM
  17. Rick Stacey's Avatar
    Switching my wifes iphone 5s sms to ON fixed the problem! I wonder if this is a setting error in their latest update? I havent got a text from any of my iphone people for a week (about the time the update rolled out)???
    11-09-2013 12:22 AM
  18. 1husband2sons's Avatar
    My husband has a Galaxy S3 and I have an iPhone 4s. We started having this problem just a couple of days ago. The problem is only with my husband's phone. My son has the same phone as he and he receives all of my messages. The carriers have absolutely no idea why (don't expect them to ever figure it out either). We decided we would use the app "viber." The messages are free between members...no data usage...no drain on the battery...it's a very good app!
    11-14-2013 07:27 AM
  19. lormajoh's Avatar
    Thank You Darth Vader!!!!
    08-22-2014 08:11 AM

Similar Threads

  1. Please help... My Galaxy S4 won't let me enable Wi-Fi
    By scatteredmac in forum Samsung Galaxy S4 Active
    Replies: 302
    Last Post: 02-20-2017, 02:21 PM
  2. Samsung Galaxy S4 music crackle sound
    By dave25A in forum Samsung Galaxy S4
    Replies: 16
    Last Post: 03-20-2014, 02:01 PM
  3. Some of us are multiplatform users would like options.
    By Farish in forum Site Feedback & Help
    Replies: 13
    Last Post: 07-19-2013, 12:23 AM
  4. Replies: 2
    Last Post: 07-04-2013, 02:02 PM
LINK TO POST COPIED TO CLIPBOARD