Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. Thread Author  Thread Author    #1  

    Default Can't turn off Google Calendar Notifications

    The built in Samsung calendar allows me to check meeting participant schedules online so I want to use that app vs the Google Calendar app. Problem is that appointments don't sync with my normal gmail account unless I have Google Calendar installed. I keep turning off Google Calendar notifications but they magically turn themselves back on after a while. Is there any way to turn them off completely and have them stay that way? I'm now getting two reminders for every appointment.
  2. #2  

    Default Re: Can't turn off Google Calendar Notifications

    So are you saying that you've gone to the Google Calendar settings and unchecked Notifications, and it keeps checking itself back on after a while?

    You could also go to Settings/Apps/All, select Calendar, and uncheck "Show notifications."
  3. #3  

    Default Re: Can't turn off Google Calendar Notifications

    Quote Originally Posted by ansextra View Post
    The built in Samsung calendar allows me to check meeting participant schedules online so I want to use that app vs the Google Calendar app. Problem is that appointments don't sync with my normal gmail account unless I have Google Calendar installed. I keep turning off Google Calendar notifications but they magically turn themselves back on after a while. Is there any way to turn them off completely and have them stay that way? I'm now getting two reminders for every appointment.
    You do NOT need the Google calendar installed to sync with Google. This must be explained in at least a dozen different posts.

    In the Samsung calendar, press the + sign to create a new event. It doesn't matter what the event is or when you schedule it for. You can call it "Dummy" and delete it when finished. After you press the + sign, the Samsung calendar shows the new event screen. Look at the row above where you enter the Title of the event. Notice the word "Calendar." Underneath it probably says "My calendar."

    Tap that row. Check the radio button next to your google account. Now, under the word "Calendar," it should show your google account. Enter a title, and tap "Save." Wait a few minutes, and check your Google calendar online. Your new appointment just synced with Google, right?

    Now click the + sign again. Does it still show your Google account under the word "Calendar"? If so, any new events you add will be synced with Google, too. You can delete the Google calendar now, and you'll have no more duplicate notifications.
    B. Diddy and GSDer like this.
  4. Thread Author  Thread Author    #4  

    Default Re: Can't turn off Google Calendar Notifications

    Quote Originally Posted by meyerweb View Post
    You do NOT need the Google calendar installed to sync with Google. This must be explained in at least a dozen different posts.

    In the Samsung calendar, press the + sign to create a new event. It doesn't matter what the event is or when you schedule it for. You can call it "Dummy" and delete it when finished. After you press the + sign, the Samsung calendar shows the new event screen. Look at the row above where you enter the Title of the event. Notice the word "Calendar." Underneath it probably says "My calendar."

    Tap that row. Check the radio button next to your google account. Now, under the word "Calendar," it should show your google account. Enter a title, and tap "Save." Wait a few minutes, and check your Google calendar online. Your new appointment just synced with Google, right?

    Now click the + sign again. Does it still show your Google account under the word "Calendar"? If so, any new events you add will be synced with Google, too. You can delete the Google calendar now, and you'll have no more duplicate notifications.
    I am well aware of how to choose a calendar. The problem is that the phone shows a "sync error" if I don't have Google calendar installed. It's that little exclamation mark next to the sync status. It is there until I install Google calendar. If you can tell me how to fix that problem I'll be grateful.
  5. #5  

    Default Re: Can't turn off Google Calendar Notifications

    Well, you didn't SAY that.

    That is an odd little bug, and it's happened to me on occasion, too. Let me see if I remember this right. In the Google account sync settings, try unchecking the Sync Contacts option (or maybe all the other options, and then resync. If the calendar syncs correctly, recheck the other sync options, and you should be OK. You might have to repeat this occasionally.

    It's happened to me in the reverse, too. I've gotten the exclamation point on contacts, and had to uncheck the calendar to get contacts to sync. Let me know if that works.
  6. Thread Author  Thread Author    #6  

    Default Re: Can't turn off Google Calendar Notifications

    Quote Originally Posted by meyerweb View Post
    Well, you didn't SAY that.

    That is an odd little bug, and it's happened to me on occasion, too. Let me see if I remember this right. In the Google account sync settings, try unchecking the Sync Contacts option (or maybe all the other options, and then resync. If the calendar syncs correctly, recheck the other sync options, and you should be OK. You might have to repeat this occasionally.

    It's happened to me in the reverse, too. I've gotten the exclamation point on contacts, and had to uncheck the calendar to get contacts to sync. Let me know if that works.
    Just tried enabling / disabling a huge list of Google items but nothing made a difference until I reinstalled calendar. I have tried unchecking notifications in the Manage Apps section rather than the app itself. Maybe THAT will make a difference...Funny thing is other than getting meeting participants availability status (from Exchange server) I'd be fine with the Google calendar. If they would add that functionality I'd just disable the Samsung calendar app and be done with it...
  7. #7  

    Default Re: Can't turn off Google Calendar Notifications

    I had a similar (same) problem. Any new calendar event showed up just fine until my device synced with google. Upon syncing notifications (alert + email) were added. Found the solution in the online calendar settings under (free translation from the Swedish calendar settings): Settings - calendars messages notifications next to the account name, were for my google account two auto-notifications were added by default. Removed them and problem is now solved.
  8. #8  

    Thumbs up Re: Can't turn off Google Calendar Notifications

    Thank you so much! That was the most annoying thing ever! Especially getting the emails before every event even though I didn't set it to send me one. Can't thank you enough!
  9. #9  

    Default Re: Can't turn off Google Calendar Notifications

    How do you get to the calendar online settings?

    I have S planner with a Note3 and S4- we have gmail so we can share calendars, there are 3 gmail accounts and 3 calendars synced. Unless otherwise stated the problem occurs regardless of which phone/account is used to enter the event. It changes colour depending on who is entering the event- we have our own accounts to enter from and it wont let you swap which one you are using to make the entry so the problem isn't changing each other's entries.

    Problem 1: Sometimes we want just an alarm but it defaults an email alert also. I changed the gmail settings in the phone main settings and unchecked syncing with gmail (since we only have the gmail so we can sync calendars across phones) and it hasnt stopped the email alert.

    Problem 2: Other times I simply want the event in the calendar with no alarm - If I close (minus sign) the default notification so there is no alarm then save the event it defaults to putting in an alarm, and it varies between on time and 15min before. I cant figure out when it defaults because even now if I put in an event and turn off notifications - when I go to check it even after closing the calendar and returning, or turning off the screen then logging back in- the notifications are definitely off. But occasionally when I check one after I put it in it has put the reminder back on for 15min prior - I can turn it off again but it makes no difference. Then 15 min before the event that should have no notifications (I even checked 16 min before it was due and made sure there were no notifications) the alarm goes off and the event has a notification set for 15min before and on time.

    Problem 3: It also duplicates daily repeat events, putting them 10 min apart - I delete them and all future events, this works for a while then 3-9 days later they duplicate again. So my reminder to do exercise at 8 am is input with an alarm 15 min before and set to repeat daily. The next day I have it go off as usual but also have a duplicate set 10 min later with notifications at 30min before, 15 min before, 5 min before and on time. Obviously I get at least 5 reminders for it when all I wanted was one. Ill delete the duplicate but it will keep reappearing and I cant find a pattern. It only does this to events entered on the S4.

    BTW I just did a firmware and software upgrade (requested by the phone) and the problem is still the same. I also changed widget but that didnt help either.
  10. #10  

    Default Re: Can't turn off Google Calendar Notifications

    I have the opposite problem, I keep on checking the notifications box (in the native android calendar app) and it keeps on turning itself off so I no longer get the pop off notifications. I think it is because I had the Google Calendar installed too (it's a different app) - now I have uninstalled it the problem has gone away even though I wasn't using the Google Calendar app.
  11. #11  

    Default Re: Can't turn off Google Calendar Notifications

    i do have wiko highway signs and got double notifications from calender+ app from playstore and android natives calender app.
    Resetting the native android calender cache helped!

Similar Threads

  1. How About Some Comparo Photos--Stock Moto Cam vs. Google APK Cam
    By PowrDroid in forum Droid RAZR MAXX HD
    Replies: 11
    Last Post: 07-31-2013, 08:35 AM
  2. Force native SMS application to use Google Voice?
    By PhobicCarrot in forum Samsung Galaxy S4
    Replies: 4
    Last Post: 07-27-2013, 09:11 AM
  3. No notification light?
    By Snareman in forum Motorola Droid MAXX
    Replies: 22
    Last Post: 07-25-2013, 10:24 PM
  4. What can rooting do for me?
    By mntwins7 in forum General Help and How To
    Replies: 5
    Last Post: 07-24-2013, 06:19 AM
  5. Google Play Music Home Screen Playback Control Widget?
    By biggbrother2 in forum General Help and How To
    Replies: 3
    Last Post: 07-23-2013, 02:27 PM

Posting Permissions