Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
  1. Thread Author  Thread Author    #1  

    Default How to stop keyboard language identifier from showing up

    Hello...

    I have a Samsung Galaxy S3 I just bought used on Verizon and while typing on the on-screen keyboard or a bluetooth one, most of the time when I type the letter I (capital i) then space, it pops up with the system language "English(US)" and eats the space. It's not that big a deal, but it throws me off and serves no purpose and I don't know if it's a "feature" of the family, or this model or the carrier or what. Is there anything that can be done about it?
  2. #2  
    Scott Kenyon's Avatar

    Posts
    2,156 Posts
    Global Posts
    2,204 Global Posts
    Carrier
    MoDaCo Switch Beta 8

    Default Re: How to stop keyboard language identifier from showing up

    Quote Originally Posted by mattrix007 View Post
    Hello...

    I have a Samsung Galaxy S3 I just bought used on Verizon and while typing on the on-screen keyboard or a bluetooth one, most of the time when I type the letter I (capital i) then space, it pops up with the system language "English(US)" and eats the space. It's not that big a deal, but it throws me off and serves no purpose and I don't know if it's a "feature" of the family, or this model or the carrier or what. Is there anything that can be done about it?
    Do you have more than one language enabled? Sometimes this can be accidentally done. If so, try to disable all languages but English(US).
  3. #3  

    Default Re: How to stop keyboard language identifier from showing up

    I really hate it when keyboards start eating spaces, but once they get started they can't stop (those spaces are so plentiful, but hardly fill you up). :rolleyes:

    I gather that you're using the stock Samsung keyboard?
    Are you saying that the keyboard has "English(US)" shown on the spacebar, or that after typing the letter 'I' the item highlighted in blue on the far left is "English(US)"?
    Unfortunately, with the stock keyboard, it doesn't automatically insert the blue text when you press the spacebar (which seems really lame).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  4. Thread Author  Thread Author    #4  

    Default Re: How to stop keyboard language identifier from showing up

    Scott, thanks for the reply. No, just one language enabled (system, english us).
  5. Thread Author  Thread Author    #5  

    Default Re: How to stop keyboard language identifier from showing up

    GSDer, thanks for the reply.

    Yes, it finds my spaces delicious, though the lack of pixels does leave the phone unsatisfied.

    I am using the stock Samsung keyboard.

    The keyboard does have English(US) on the space bar, but what happens is when I type an I and then type a space, a popup shows up saying "english(US)", it pauses a bit and eats the space.

    It's almost like I'm triggering a language id popup.

    I did see a thing that said you can swipe over the space bar to change language, but i only have the one language. If I uncheck the "use system language" and uncheck all language choices, it does the same thing. Or, if I have "use system language" unchecked but check "english(US)", it does the same thing.
  6. Thread Author  Thread Author    #6  

    Default Re: How to stop keyboard language identifier from showing up

    One thing I noted is a lower case i followed by space doesn't trigger it but a capital i does. And it's not 100% of the time. Great!
  7. Thread Author  Thread Author    #7  

    Default Re: How to stop keyboard language identifier from showing up

    On my Logitech bluetooth keyboard, I can make the language pop up appear by typing shift + space ....
  8. #8  

    Default Re: How to stop keyboard language identifier from showing up

    That's really weird. You could try Settings -> Application manager -> Menu button -> Reset app preferences
    That'll reset all of your default apps, but might fix this.
    Does your phone have the latest firmware (MF1)? Check Settings -> About phone.How to stop keyboard language identifier from showing up-uploadfromtaptalk1377045708630.jpg
    Since it was used, you could try clearing the cache in Recovery mode. (This is grasping at straws.)

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  9. #9  
    Scott Kenyon's Avatar

    Posts
    2,156 Posts
    Global Posts
    2,204 Global Posts
    Carrier
    MoDaCo Switch Beta 8

    Default Re: How to stop keyboard language identifier from showing up

    Quote Originally Posted by GSDer View Post
    That's really weird. You could try Settings -> Application manager -> Menu button -> Reset app preferences
    That'll reset all of your default apps, but might fix this.
    Does your phone have the latest firmware (MF1)? Check Settings -> About phone.Click image for larger version. 

Name:	uploadfromtaptalk1377045708630.jpg 
Views:	15 
Size:	48.2 KB 
ID:	77232
    Since it was used, you could try clearing the cache in Recovery mode. (This is grasping at straws.)

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
    Yeah, I'm at a loss here. Try the above and report back.

    Sent from my HTC One using Mobile Nations mobile app
  10. Thread Author  Thread Author    #10  

    Default Re: How to stop keyboard language identifier from showing up

    Yes, has that firmware.

    Wiping default app prefs didn't help.

    How do I get into recovery on this phone?

    THanks!
  11. #11  

    Default Re: How to stop keyboard language identifier from showing up

    To boot into Recovery mode, with the phone completely off, press and hold the Volume Up and Home and Power buttons simultaneously and when you see the splash screen release them all.
    Use the Volume rockers to navigate the menu and the Power button to select.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk 2
  12. #12  
    JGroj's Avatar

    Posts
    1 Posts
    Global Posts
    2 Global Posts

    Default Re: How to stop keyboard language identifier from showing up

    I have been messing with this for a couple of hours, too, and it's been driving me crazy. But I figured something out. The space bar only "eats" your space when you're depressing both the shift key and the space bar at the same time. It reads that as a "Swipe," I guess. That's why if you type "I (space) like," it comes out "Ilike;" because your finger is still holding down the shift key from the capital letter "I" when you tap the space bar. Same with trying to type a space after " or ? -- any character that requires the shift key -- it gets confused and thinks you're trying to type Shift+Space.

    I don't know how to fix it, other than typing very carefully.

    Yet another reason why it drives me INSANE that samsung defaults to their own QWERTY keyboard when you're using bluetooth, rather than letting you use SwiftKey, which doesn't have this problem. At least have a GOOD keyboard, if they're going to make you use it! It's infuriating.
  13. #13  

    Default Re: How to stop keyboard language identifier from showing up

    I was able to fix this by changing the default keyboard to Swype. I hope this works for others.
  14. #14  

    Default Re: How to stop keyboard language identifier from showing up

    A heartfelt thank you, MGM5685. I have sent one keyboard back only to get a new and it still did this. Your fix worked great. I do have to make sure though that I type a bit slower, but it works.
  15. #15  

    Default Re: How to stop keyboard language identifier from showing up

    Guys:
    I have the same issue with a Galaxy Note 2, I need to write in English and Spanish but the keyboard just shows English, any idea of how to change the keyboard to Spanish? It's annoying to correct every word when I start writing in Spanish.
  16. #16  

    Default Re: How to stop keyboard language identifier from showing up

    Quote Originally Posted by jorgedom61 View Post
    I need to write in English and Spanish but the keyboard just shows English
    Have you downloaded the language pack for Spanish for whichever keyboard you're using? Settings -> My device (if using the Tab view) -> Language and input -> press the gear icon next to the keyboard you're using -> select '+ Select input languages' (if using the stock Samsung keyboard).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
  17. #17  

    Default Re: How to stop keyboard language identifier from showing up

    I downloaded the language pack and is working perfectly now. Thanks a lot
  18. #18  

    Default Re: How to stop keyboard language identifier from showing up

    MGM5685, thanks for the suggestion. I had the same problem as other users on my Galaxy Note 3 + Logitech K810 and on reading your post changed my default keyboard to SwiftKey. The Shift-Space behavior of eating spaces is now gone. Thanks again!

Similar Threads

  1. Replies: 9
    Last Post: 05-26-2015, 11:19 AM
  2. "Unfortunately, Google Play Store has stopped"
    By CharlieK581 in forum Google Nexus 7 Tablet (2013)
    Replies: 27
    Last Post: 01-05-2014, 05:58 AM
  3. "Battery Disconnected" after upgrade to JellyBean
    By acejavelin in forum Samsung Galaxy S II Skyrocket
    Replies: 3
    Last Post: 08-26-2013, 05:39 PM
  4. Apps not showing in "My Apps"
    By dmlowery41 in forum Google Nexus 7 (2012) Rooting, ROMs, & Hacks
    Replies: 1
    Last Post: 08-26-2013, 11:29 AM
  5. how can i solve it?
    By android problem in forum Samsung Galaxy Note 2
    Replies: 3
    Last Post: 08-22-2013, 07:04 PM

Posting Permissions