Results 1 to 21 of 21
  1. Thread Author  Thread Author    #1  

    Exclamation S3 charging issue

    Hello everyone ..
    I am new here and this is my first post so pardon me if I am posting in the wrong section. I searched for this problem but could find an answer to it I hope this time it helps.
    I was using my s3 which was working perfectly normal until one day i noticed the charging time had reduced significantly and I was shocked because I hadnt dropped the phone or anything so I went and checked my friend's s3 charger on it and it showed the same issue, i checked his battery as well still same issue, i checked my charger on his phone and it worked fine, I then went to the customer care center and they checked my phone and told me that nothing is wrong with my hardware or software (4.1.2) of the phone . I bought a new charger and it worked for a day but the next day it again started to create the same problem, I then bought a charger without this usb cable ( a direct charger i mean ) and it worked great for a day and again i am encountering the same issue again, I factory resetted the phone , blew air into the charging socket , I pretty much tried everything available online but nothing worked.
    Please guys help me I am desperately waiting for your reply..
    Thanks..
  2. #2  

    Default Re: S3 charging issue

    The phone won't charge at all or it charges very slowly?
    Have you tried turning it completely off and charging it that way? (Not suggesting this is a permanent solution; just for troubleshooting.)

    Very strange that new chargers will work for a day and then have the same problem. Either there's something wrong with the micro-USB port or the actual charging circuit in the phone. Only way to find out would be to try a wireless charging solution - if that works then you know that something is wrong with the port; if it doesn't then the charging circuit is culprit.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
  3. Thread Author  Thread Author    #3  

    Default Re: S3 charging issue

    @GSDer
    It charges very very slowly like 10% in 3hours..
    Yesterday I turned it off and started charging it so it worked fine but when I switched it on it again gave me the same problem.
    I showed it to the customer care center guys and they told me that nothing is wrong with the hardware of my phone, the strange thing is that a new charger works fine for a day and then it gives the same issue as well, I am more inclined towards the software issue problem because when I switch off my phone the charging becomes normal (like for eg yesterday night the charge was stuck at 36% I switched it off for a minute so the charge increased to 38% and then it was working fine for a while and then suddenly the problem arised again)
    I am really confused and stuck guys please help me out..
  4. Thread Author  Thread Author    #4  

    Default Re: S3 charging issue

    I installed the app known as "galaxy charging current *lite*" and its values are fluctuating , sometimes it shows max as 1000 sometimes 200 sometimes 400. Sometimes the charging time is fine while sometimes it just slows down, what do you guys think is the problem? hardware or software? considering the fact that a new charger works fine for a day or two.
    Please reply I am desperately waiting.
  5. #5  

    Default Re: S3 charging issue

    Did you change anything on your phone around the time this started happening? New apps, etc
  6. Thread Author  Thread Author    #6  

    Default Re: S3 charging issue

    No nothing at all, I even factory reseted it twice
  7. #7  

    Default Re: S3 charging issue

    Unfortunately that app (and several others like it) doesn't work on my Verizon S3, so I can't compare any data with you. I'm not sure how the customer care center folks can determine that it's not a hardware problem by a cursory examination, but whatever.

    We've at least established that it charges normally if the phone is completely off, so that's one thing in your favor. The phone should take less than 2 hours to charge if it's completely off so in the short term that's what you should do.

    If the problem is some kind of software issue there are two things for you to try (there'd normally be three, but you said you already tried a Factory Reset):
    1. Wipe the system cache in Recovery mode
    - with the phone completely off, press and hold the Volume Up and Home and Power buttons simultaneously, and release them all when you see the splash screen. Use the Volume rockers to navigate through the menu and the Power button to select an item.
    2. Use the Kies software on your PC to reload the current firmware.
    - Install Kies, run it once (it'll automatically update to the latest version), then connect the phone (while it's running normally) and use Kies to backup your pictures/videos, SMS/MMS, Call Logs, etc.
    - Disconnect the phone, turn it completely off, then boot up in Download mode (just like Recovery mode but use the Volume Down key instead). Then connect it to the PC and in the Kies software select Tools -> Firmware Upgrade and Initialisation. Follow the prompts - if it asks for your model number and IMEI you can find that information under the battery (it's OK to pull the battery out once the phone is plugged in; be sure to enter the model number in CAPS). It should take around 10 minutes or so to reload the firmware (depending on your Internet connection - it'll automatically download the correct firmware for your model/carrier).
    - This performs a Factory Reset as well, so you'll have to go through the normal phone setup, after which you can use Kies to restore your pictures/videos, etc.

    Let us know what happens.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
  8. Thread Author  Thread Author    #8  

    Default Re: S3 charging issue

    @GSDer
    Keeping in mind what you said I think the second option means reinstalling my current OS again (forgive me for my less knowledge in this case) so do you think this tutorial can help me do that?
    If its a software problem then reinstalling the software might help, does the above mentioned link help me do that?
  9. Thread Author  Thread Author    #9  

    Default Re: S3 charging issue

    The other thing i wanted to ask was that would it completely install my OS 4.1.2 again? like I mean from the scratch right because in my view there seems to be some problem with the OS and it needs to be completely freshly installed.
    And one more thing that the charger app shows me sometimes full 1000 current while sometimes 700 , 400 etc so what do you think if it was hardware problem wouldn't the rating be always down than 1000? but what I have seen is it is constantly fluctuating ..
  10. #10  

    Default Re: S3 charging issue

    Yes, you can follow the steps at that link - that's essentially what I listed. And it reminded me that you don't have to put the phone in Download mode in order to reload the firmware. During those steps you can also perform a backup, rather than having to do it separately.

    I'd still recommend that you try clearing the system cache in Recovery mode first - it only takes a minute to do, and if it doesn't make any difference you've only lost a minute. Plus that it's good training knowing how to get into Recovery mode.

    Yes, using Kies to reload the stock firmware completely reloads the OS.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
  11. Thread Author  Thread Author    #11  

    Default Re: S3 charging issue

    Alright I'm going to give it a day or two and after that would go ahead with refreshing my OS.
    I'll let you guys know, hoping it works *fingers crossed*.
  12. Thread Author  Thread Author    #12  

    Default Re: S3 charging issue

    @GSDer I tried what you said and it gave me some error and then a code and then it ran an emergency recovery, i dont exacltly remember what the error was but it was round about in the time the upgrading went to 40% .. now what to do? I mean the phone is working after the emergency recovery but the OS is still the older one and the charging problem still remains, now what?
  13. #13  

    Default Re: S3 charging issue

    Quote Originally Posted by Fakhr E Alam View Post
    it gave me some error and then a code
    ...
    the OS is still the older one
    You don't remember what the error was, or whether it actually completed the firmware reload?

    When you say that the OS is the older one, you mean that it's still at 4.1.2? That may be the latest version for your model/carrier - when you run Kies with the phone connected it shows you the version on the phone and the latest version.

    Without knowing what the error was or if it actually reloaded the firmware we're still at square one. Did you have to go through the phone setup once it was done?

    Sorry, other than putting the phone in Download mode and trying it again (and making note of any errors - do a Shift + PrtSc to take a snapshot of the screen and then open Paint and paste the result into it [CTRL + V]) I don't have any suggestions.

    You could try using Odin to reload the OS if Kies doesn't cooperate - need to know the model number/carrier to look that up.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
  14. Thread Author  Thread Author    #14  

    Default Re: S3 charging issue

    I did it again and this time the method was successful but the strange thing is that the OS should be refreshed but it isn't. I mean if its reloaded the data etc should have been gone but phone OS is exactly like what it was before , same data wallpapers apps etc. And the worst thing is the problem still remains, I dont think the OS got refreshed at all, I mean think about it if you refresh your windows the old data should be completely gone but if it still remains that means the windows has not been refreshed, so same is the case here
  15. Thread Author  Thread Author    #15  

    Default Re: S3 charging issue

    Update:
    I managed to downgrade my OS from the ODIN method and even that failed to help, what to do now?
  16. #16  

    Default Re: S3 charging issue

    Samsung Galaxy S3 charging problem
    (Samsung Galaxy S3 charging problem)

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
  17. #17  

    Default Re: S3 charging issue

    About 9 months ago i bought 2 S3's (one for me one for my wife).
    They both charged fine to start with.
    Then one of the chargers seemed to be slower thatn the other so we used the better one.
    Recently the 2nd charger slowed so that either phone only went from 10% to 20% after an overnight charge.
    I then went to Maplin and bought a generic USB charger and now I can fully charge either phone within 3 hours.
    My conclusion is that the phones and cables are good but the chargers are poor quality and liable to fail.

    Try a new charger is my advice
  18. Thread Author  Thread Author    #18  

    Default Re: S3 charging issue

    @peterjmills
    Thank you for your advice
    I tried all sorts of chargers, cables etc but nothing worked, I recently found a charger in my market (they say it's imported and has the tag of "lc power electronics co. ltd" on it along with lots of Chinese or Japanese) and since a couple of days it's working really well, I still am a bit worried but fingers crossed I hope this one works well for the long run
  19. Thread Author  Thread Author    #19  

    Default Re: S3 charging issue

    Update:
    The problem became too severe to the limit that my phone started connecting and disconnecting by itself along with the slow charging issue. I could bear it no longer and decided to take it to the customer care center again. This time they opened the phone in front of me and what we all noticed was that the charging port of my s3 had been damaged by water (sweat actually, where we live it's usually very very hot and I sweat more than normal as well LOL). They initially refused to repair it under the warranty condition because water damage is not included in their "terms and conditions" but then they sent it for repair to another city as a favor. It will be back in 15days minimum and then I will update you guys further. Fingers crossed hoped everything turns out to be well.
  20. #20  

    Default Re: S3 charging issue

    FYI - you can buy the little micro-USB port covers (like used to come on older phones) and put one on to keep stuff (debris, sweat, etc) from getting in the port.

    And as was noted before, if the problem is with the micro-USB port, you could purchase a wireless charging solution to work around that issue.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
  21. Thread Author  Thread Author    #21  

    Default Re: S3 charging issue

    Thank you GSDer , I was thinking about purchasing a port cover but didn't know if S3 has one or not. Well for now it's with the repair guys as it still in the warranty time period so for now it is their headache

Similar Threads

  1. change only charge mode
    By Matis588 in forum Samsung Galaxy Tab 2
    Replies: 30
    Last Post: 09-18-2013, 07:24 AM
  2. att galaxy s3 rooting help pleaseee
    By rohrbaugh26 in forum AT&T Galaxy S3 Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 09-17-2013, 06:49 AM
  3. Screen issue
    By hotshot8148 in forum Verizon Galaxy S3
    Replies: 3
    Last Post: 09-16-2013, 03:47 PM
  4. Rooting the S3 without a custom recover?
    By mssca in forum Samsung Galaxy S3
    Replies: 4
    Last Post: 09-15-2013, 04:08 AM
  5. my biggest issue with the phone
    By Ualrdynodo in forum Moto X
    Replies: 4
    Last Post: 09-14-2013, 05:07 PM

Posting Permissions

B