1. anon(8220015)'s Avatar
    Hi All,

    My home screen has Phone | Contacts | Chrome | Messaging | Apps on the bottom row. And for some reason for the past 2 weeks I have an symbol on the messaging icon indicating 2 unread messages. I have been unsuccessful in getting this indicator to be removed.

    Please see attached image to see what I'm talking about.

    I have restarted the phone several times, I have deleted ALL messages and threads, including Drafts, Spam etc.
    I have also removed the icon from the home page and reinstated it from the apps list using the drag and drop method, but it just keeps re-appearing. Is there any suggestions anyone can give me? Its driving me nuts!

    I am hesitant to reset my phone as I do not really want to re install all my apps and setup emails etc.
    Galaxy S3: Messaging Icon on home screen shows unread messages, there definitely is none-2013-11-06-11.29.50.png

    Cheers
    11-06-2013 04:27 AM
  2. GSDer's Avatar
    Go to Settings -> Application manager -> ALL, scroll down until you find BadgeProvider, select it and Clear cache and Clear data.

    Are you using a 3rd party launcher?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM 10.2 using Tapatalk 4
    msndrstood and Arun Kumar S like this.
    11-06-2013 05:02 PM
  3. anon(8220015)'s Avatar
    Hi,

    No I'm not using any 3rd party launchers, and I have just had a crack at Clearing Data, and Clearing Cache as per instructions, then done a reboot and now its all clear!!!

    I would like to thank you for your help, it has been driving me nuts!

    Case Closed
    msndrstood likes this.
    11-06-2013 05:17 PM
  4. Arun Kumar S's Avatar
    Even this worked out for my phone
    Great and thanks a lot for your troubleshooting steps
    so helpful. Awesome
    12-25-2013 03:07 PM
  5. guitarmantyler's Avatar
    I was having the same issue. Under developer options, I had to uncheck "do not keep activities." And that fixed my problem.

    Posted via Android Central App
    12-25-2013 09:53 PM
  6. GSDer's Avatar
    I had to uncheck "do not keep activities."
    That option should not be checked by default, and it's not a good idea to check it. Some of the items in that sub-menu really ARE for developers and shouldn't be changed arbitrarily.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    12-26-2013 01:40 AM
  7. castoff13's Avatar
    Have same problem and it's driving me nuts....my droid mini doesn't have an "applications manager". Any thoughts?
    03-17-2014 11:40 AM
  8. GSDer's Avatar
    my droid mini doesn't have an "applications manager"
    That would be very unusual - you're looking in Settings -> More (if using the Tab view) -> under the 'System manager' grouping and there's no Application manager?
    What firmware is on your phone?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-18-2014 12:27 AM
  9. nooji123's Avatar
    How do I get that to appear. I can't seem to get it to work. When I first got my s3 mini it had the symbol but now it is not there.

    Cheers
    03-19-2014 02:36 PM
  10. castoff13's Avatar
    Yes sir, I am looking at "settings" right now...no "Application Manager" and no "system manager"...
    apologies for the rookie question, but how do I find out what "firmware" is on my phone?
    03-19-2014 04:15 PM
  11. GSDer's Avatar
    how do I find out what "firmware" is on my phone?
    Settings -> About phone; 'Android version' gives you the major version (ex. 4.3) and 'Build number' tells you which carrier build you have (we usually refer to them by the last three characters - ex. ML1).

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-19-2014 08:47 PM
  12. castoff13's Avatar
    Thank you for your patience with me.....the major version is 4.4and the 'build number" is SU2-3
    03-20-2014 09:45 AM
  13. GSDer's Avatar
    the major version is 4.4
    There has to be an Application manager hiding somewhere. You are accessing Settings by pressing the Menu button from a Home screen, right?
    Is your Settings view set to the Tab view as in this screenshot?If so, press the Menu button again and select 'Switch to list view' at the bottom of the screen. Then scroll down until you find 'Application manager' - as shown in this screenshotit's right above the 'Personal' sub-category.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-20-2014 01:01 PM
  14. castoff13's Avatar
    Thanks for your patience...I should have read the original thread more carefully......under "battery" there is a menu item for "apps". So I DID have an app manager...sorry. There is no "BadgeProvider" application...
    03-22-2014 09:55 AM
  15. GSDer's Avatar
    There is no "BadgeProvider" application.
    When you first open the Application manager it normally defaults to showing the 'DOWNLOADED' tab; swipe to the right a few times until you get to the 'ALL' tab, then scroll down until you find BadgeProvider

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-22-2014 12:16 PM
  16. castoff13's Avatar
    Thank you for all your help. I found the app (called "Badger" on my phone, but was there is no option to clear data and when I tapped "clear cache", nothing really happened. Tried it a couple of itmes, rebooted the phone etc. and it still shows one unread message. I do appreciate your time, I guess I'm just stuck with this piece of junk for a while.
    HC
    03-22-2014 03:37 PM
  17. GSDer's Avatar
    I found the app (called "Badger" on my phone
    I really don't get it - stock versions of Android have the same underlying framework, and BadgeProvider is part of that framework. This is what you should see when you find BadgeProvider.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-23-2014 03:20 AM
  18. castoff13's Avatar
    That IS pretty much what I see, except the "Clear data" button is soft (like the "Move to SD card" on your phone) and when I tap "Clear cache" nothing else pops up to indicate it is doing any clearing. This phone was purchased only four months ago. I may just stop by the Verizon store with this info and ask them what's up. You have been very helpful, believe me, but I don't know what else to do.
    03-23-2014 09:12 AM
  19. GSDer's Avatar
    when I tap "Clear cache" nothing else pops up to indicate it is doing any clearing
    You won't see any kind of pop-up, but you should see the cache size change to zero from whatever it was.

    Sorry this didn't work - it's normally a good fix, but there are others that have been posted in the past. Guess I'll have to reread from the beginning of your posts to see what else might be going on. (Verizon will probably suggest a Factory Reset.)

    Edit: Which Messaging app are you using?
    Are you using a 3rd party launcher?
    Is the erroneous count shown on the Lock screen or on the app icon on a Home screen or in the Notification bar?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-24-2014 12:51 AM
  20. castoff13's Avatar
    Using the Verizon messaging app that came with the phone. Using an stmp email server thingy..and, finally, .the erroneous count is on the app icon on the home screen.
    03-24-2014 05:19 PM
  21. GSDer's Avatar
    Using the Verizon messaging app
    Drat - sorry, I have no experience with that app. A quick look through the comments in the Google Play Store didn't show any similar complaints.

    I suppose you could clear cache and clear data on the app itself. Perhaps send them some email about it.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-24-2014 10:12 PM
  22. castoff13's Avatar
    thanks....will be stopping by verizon store later this week and see what they have to say...
    this has really been helpful, thank you so much
    03-25-2014 08:43 AM
  23. Jon Riege's Avatar
    I also had this problem. I went to settings/app manager/messenger/click on force stop then cleared data. Then I powered the phone off for 10 seconds and powered back on. Everything fixed.
    03-29-2014 04:09 PM
  24. Awais Rabbani's Avatar
    Thanks did the work...had to reset later for it to work
    07-02-2014 12:56 AM
  25. Hema Priyanka's Avatar
    will using the clear data option not delete all the messages?
    11-23-2014 10:39 AM

Similar Threads

  1. Google calendar on lock screen. How to remove?
    By Willstatt in forum Google Nexus 4
    Replies: 6
    Last Post: 07-01-2014, 06:26 AM
  2. Is there any update on 4.3 for the S3?
    By whoknows00100 in forum Sprint Galaxy S III
    Replies: 275
    Last Post: 12-21-2013, 08:54 AM
LINK TO POST COPIED TO CLIPBOARD