Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    After my google searches, all I'm finding is old threads that have nothing to do with the 4.3 upgrade or Sprint solutions.

    I have a Cspire phone...

    I've been all through the wifi settings and can't make this stop. Does anyone have an idea after the 4.3 where to go to make my phone stop connecting to wifi automatically???
  2. #2  
    Golfdriver97's Avatar

    Posts
    19,338 Posts
    Global Posts
    19,752 Global Posts
    ROM
    Liquidsmooth ROM

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    Quote Originally Posted by usmdesigner View Post
    After my google searches, all I'm finding is old threads that have nothing to do with the 4.3 upgrade or Sprint solutions.

    I have a Cspire phone...

    I've been all through the wifi settings and can't make this stop. Does anyone have an idea after the 4.3 where to go to make my phone stop connecting to wifi automatically???
    Have you tried to clear cache in recovery? Here is how: [Guide] Rebooting into Recovery Mode for the Galaxy S2, S3, and Tab2.

    Phone Timeline
    'If we could change ourselves, the tendencies in the world would also change.' - Mahatma Gandhi
    Community Guidelines and also here
  3. #3  

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    What do you mean by "turn it off"?

    Check these:

    -Settings> Connections> More networks> Mobile Networks> Connection Optimizer> Uncheck box.

    Sprint Galaxy S3 - 4.3 Q & A
    PLEASE, when asking for help provide as much information as possible. We can't help unless we know what the symptoms are and what you did before they began.
  4. Thread Author  Thread Author    #4  

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    Quote Originally Posted by meyerweb View Post
    What do you mean by "turn it off"?

    Check these:

    -Settings> Connections> More networks> Mobile Networks> Connection Optimizer> Uncheck box.

    Sprint Galaxy S3 - 4.3 Q & A
    By "turn it off", I mean when I go to Connections > Wifi, and select "off" it should stay off. Yet this thing keeps randomly deciding to connect to a wifi network when in range of it. This causes me to get stuck a lot because I think I'm on my mobile connection, only to find out the phone has tried connecting to another wifi again.

    The problem with that, is some wifi networks support you connecting, but make you get on the internet to type in a username and password to actually use it. So my phone is fooled into thinking I have a connection.

    When I go to:
    Settings>Connections>More Networks>Mobile Networks> There is no Connection Optimizer

    Just: Mobile Data (check or no check), Data Roaming (check or no check), Network mode, System Select
  5. #5  

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    Sorry, I forgot that Connection Optimizer is a Sprint-only thing.

    Try this. Go to Settings / Connections / Wifi and tap the menu button, then Advanced. Make sure "Always allow scanning" and "Network Notification" are unchecked.
    PLEASE, when asking for help provide as much information as possible. We can't help unless we know what the symptoms are and what you did before they began.
    Thanked by 2:
  6. #6  
    crabbz's Avatar

    Posts
    78 Posts
    Global Posts
    156 Global Posts

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    Go to Setting > Wifi, hit the menu button and select Advanced. Is the Auto Connect option enabled? It connects to known wifi networks when wifi is off for high-data usage applications, but I don't know what qualifies as high-data usage.
  7. Thread Author  Thread Author    #7  

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    Quote Originally Posted by meyerweb View Post
    Sorry, I forgot that Connection Optimizer is a Sprint-only thing.

    Try this. Go to Settings / Connections / Wifi and tap the menu button, then Advanced. Make sure "Always allow scanning" and "Network Notification" are unchecked.
    Going to try this. I've literally checked every setting I could find, but would have never known how to find this one. Good find! thanks (Cspire text support nor 3 people at Cspire knew how to help me)
  8. #8  
    nacho1's Avatar

    Posts
    4 Posts
    Global Posts
    9 Global Posts

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

  9. #9  

    Default Re: Galaxy S3 wifi keeps connecting after I turn it off!! Help!

    I have a question for anyone who can help. Since the last update on my Samsung Galaxy S3 I have discovered that my Wi-Fi will not connect to any Wi-Fi while the Mobile Data button is checked. Also, I can not download pictures or large files without the Mobile Data button being checked. These use to work together. As a matter of fact, my husband has the same phone and his phone still works with both features at the same time..

    Any advice???? Please help if you can.

Similar Threads

  1. Nexus 5 WIFI Speed Tests (Sky Broadband & Kitkat 4.4.2)
    By iku04108 in forum Google Nexus 5
    Replies: 26
    Last Post: 12-20-2013, 07:06 PM
  2. LED notification on S3 no long working (or there)after4.3 update
    By rickap7 in forum General Help and How To
    Replies: 1
    Last Post: 12-20-2013, 12:00 AM
  3. Jelly bean 4.1.1 rom for galaxy note 2
    By mjstark in forum General Help and How To
    Replies: 2
    Last Post: 12-19-2013, 08:18 AM
  4. sms issues! Please help!!!
    By Elizabeth Byers in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 12-19-2013, 07:59 AM
  5. Samsung Galaxy Tab 3 not turning on
    By David Mansfield1 in forum Samsung Galaxy Tab 3
    Replies: 2
    Last Post: 12-19-2013, 05:42 AM

Posting Permissions