Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default Samsung S3 won't send MMS

    Hi, I have a Sprint Galaxy S3 that I am using with Straight Talk. I have talked to customer service and Samsung and I can't figure out why my phone won't send a picture. When I try to send a picture it just sits there, sometimes for hours, trying to send the message and I'll eventually just get the message "MMS Failed". All you see when trying to send is the load circle. I've seen on the forums where people suggest adding an APN; however, I cannot add an APN. I don't have that option and Straight Talk says that I actually don't need an APN or it's already built in or something. Anyone know how to fix this?
  2. #2  

    Default Re: Samsung S3 won't send MMS

    How is your 3G/4G signal when it fails? If you are in a weak signal area it just will not go. If you are on 2G/Edge it won't work either.
    SGH-T999
    T-Mobile USA
    Rooted Stock 4.3
    (No KNOX)
  3. #3  

    Default Re: Samsung S3 won't send MMS

    I don't know anything about the difference between the Sprint version phone and the AT&T version, but apparently the latter requires APN changes Straight Talk apn settings for AT&T Samsung Galaxy S3
    (Straight talk apn settings for at&t samsung galaxy s3)

    Perhaps something in that thread will prove useful - if not, sorry for misdirecting you.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
  4. #4  

    Default

    is your mobile data on? that usually makes it not send if its off

    Posted via Android Central App
    Give me a THUMBS UP if I helped!

    Galaxy S3 AT&T SGH-I747
  5. #5  

    Default Re: Samsung S3 won't send MMS

    Try this, Before you go to setting go to google and type in eg (vodafone MMS port- to find out what is your MMSC and MMS port) once you got it.
    Now go to:
    Setting
    More Settings
    Mobile Network
    Access Point Name
    Select your prefer Network Option (APNs)
    Under MMSC(type the https site)
    Change your MMS port eg(8080) might be different depend which country you in.
    and LAST. APN type (type - mms,supl)

    hope this helps.. It works for me when nothing else does.......
  6. #6  

    Default Re: Samsung S3 won't send MMS

    Will that work for the S3 phone? The instructions say they're for the S4.

    AC App on SGS3
    Samsung Galaxy S3 4gLTE

Similar Threads

  1. Replies: 4
    Last Post: 12-31-2013, 12:29 PM
  2. My samsung wont turn on or go to Odin mode
    By Infermezzo in forum Verizon Galaxy S3 Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 12-28-2013, 12:00 AM
  3. Won't Detect USB 3.0
    By hell911 in forum Google Nexus 5
    Replies: 5
    Last Post: 12-27-2013, 04:09 AM
  4. Samsung Tab 3 10.1 - Apps stuttering
    By Harrier19 in forum Samsung Galaxy Tab 3
    Replies: 6
    Last Post: 12-26-2013, 09:26 AM
  5. Samsung Galaxy S4 Screen distortions HELP!
    By netizen007 in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 12-25-2013, 03:42 PM

Posting Permissions