1. jamezholt's Avatar
    Hi guys hope all are well

    I've been having a few issues over the last month with my Samsung galaxy s3 lte.

    At roughly 40-50% and less the battery on my phone goes berserk

    I could be on an app or just quickly checking my Facebook etc and all of a sudden my battery is at the 15% warning.

    At this point my phone has flashing white lines scrambling across the screen and you can literally watch the percentage drain in seconds.

    Come 5-10% my screen goes off and that's it phones dead and cannot get it back on until I've recharged it.

    While all this is happening my phone tells me my battery is fully charged at times and to unplug my charger (which isn't connected)

    Any ideas

    I've tried a different battery in my phone to see if it was the battery which it wasn't .

    Thanks in advance

    James
    01-14-2014 03:51 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Just to make sure it isn't the two batteries, try laying them flat on a table and spinning them. If they spin freely, then they could both be bad.
    01-14-2014 05:14 PM
  3. jamezholt's Avatar
    Hi there

    I have tried this and no does not spin

    Posted via Android Central App
    01-15-2014 10:22 AM
  4. WFbasketball's Avatar
    I have had the exact same issues, and I have not figured out whats going on with Android 4.3 to fix it.
    jamezholt likes this.
    01-15-2014 12:59 PM
  5. jamezholt's Avatar
    No ideas guys?

    Posted via Android Central App
    01-16-2014 12:43 PM
  6. GSDer's Avatar
    Did this problem start with the update to 4.3? If so, have you performed a Factory Reset and cache wipe in Recovery mode?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro
    01-19-2014 10:16 PM

Similar Threads

  1. Galaxy S4 - Browser history
    By ReMarkable2112 in forum Samsung Galaxy S4
    Replies: 14
    Last Post: 05-22-2014, 04:53 AM
  2. Verizon Galaxy Note 2 - Knox Bit and Rooting
    By DWooderson in forum Samsung SAFE and KNOX
    Replies: 1
    Last Post: 01-19-2014, 06:48 PM
  3. Default Browser Selection Issue on Galaxy S4
    By mkmck in forum T-Mobile Samsung Galaxy S4
    Replies: 4
    Last Post: 01-17-2014, 06:34 AM
  4. Verizon Galaxy Note 3 - CWM Safestrap
    By Imarik81 in forum Verizon Samsung Galaxy Note 3
    Replies: 0
    Last Post: 01-14-2014, 03:36 PM
  5. At&T S3 on T-mobile. Unable to send text messages
    By bbq9 in forum AT&T Galaxy S III
    Replies: 0
    Last Post: 01-14-2014, 03:03 PM
LINK TO POST COPIED TO CLIPBOARD