Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default S3 is stuck at Samsung logo

    Hello! Today while I was websurfing, my Samsung Galaxy s3 gt-I9300 suddenly turned itself off and after that was trying to boot, but it didn't happen. So it stucked at samsung logo ("Samsung Galaxy s3 gt-I9300") it haven't boot again. Also when I'm trying to charge my phone it shows me icon of gray battery with circle, and it is not showing me that battery is charching, it's stuck on this image.I was trying to find solution to this problem. A lot of people adviced me to install kies and select the second item in the Tools menu in Kies. But after my first attempt, kies gave me "notice F", I can't avoid it, this notice iterrupts whole process.Could you please help me? (I'm using win 8, also I've installed kies 3 and usual kies, it didn't help me a lot)
  2. #2  

    Default Re: S3 is stuck at Samsung logo

    Have you tried clearing the cache from Recovery Mode? (Turn phone off, press and hold Power + Home + Volume Up until it boots into recovery; from there select "Clear Cache" with the volume keys, confirm with Power. Reboot. BE CAREFUL NOT TO SELECT DELETE DATA).
  3. Thread Author  Thread Author    #3  

    Default Re: S3 is stuck at Samsung logo

    Also i forgot to mention that recovery mode stopped working, I can only use odin mode.
  4. #4  

    Default Re: S3 is stuck at Samsung logo

    Quote Originally Posted by coveretess View Post
    kies gave me "notice F", I can't avoid it, this notice iterrupts whole process.
    Common suggestions on Google include:
    - using a different USB port
    - trying a system with Windows XP

    Are you running Kies as Administrator?

    If none of that pans out then you can try reloading the stock firmware using Odin. What model/carrier (and region if you're an International user)? Was the phone already updated to 4.3 when the problem occurred?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk Pro

Similar Threads

  1. S3 4.3 update....what have you done
    By dennissr4 in forum Samsung Galaxy S3 I9300
    Replies: 7
    Last Post: 02-01-2014, 11:43 AM
  2. S3 Taking Longer to Charge
    By androidforum in forum Samsung Galaxy S3
    Replies: 5
    Last Post: 01-30-2014, 01:30 PM
  3. Nest: what exactly is it? A Thermostat!
    By Paul627g in forum Nest
    Replies: 2
    Last Post: 01-28-2014, 06:24 PM
  4. Video Playback is Glitchy
    By Floridadomer in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 1
    Last Post: 01-28-2014, 02:46 PM

Posting Permissions