Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
Like Tree3Likes
  • 2 Post By B. Diddy
  • 1 Post By UJ95x
  • 1 Post By Brian Phillips4
  1. Thread Author  Thread Author    #1  

    Default Help, please!!!

    I've been using up till yesterday an Iphone with Straight Talk as my service provider. However, yesterday I switched over to the Galaxy S3. Here is my dilemma, I have followed the apn settings I found for getting it to work with ST- and it works fine, until my phone connects to wifi. The moment my phone connects to wifi- I stop getting any and all texts to the Galaxy- they go to my iPhone (I discovered that this morning when I woke up and had all these texts on my iPhone and none on the Galaxy). I don't even know why the iPhone is still working, because there's no Sims card in it- I took it out of the iPhone and put it into the Galaxy.

    So, my question is how do I fix it where I still get my texts on the Galaxy when it's connected to wifi. And, before anyone suggests that I turn off the iPhone- I've already tried that. Still no texts to Galaxy, and they just go to my iPhone when it gets turned back on, and not to my Galaxy when I unhook the wifi.

    Frustrated!
  2. #2  

    Default Re: Help, please!!!

    Welcome to Android Central! It sounds like you didn't turn off iMessage on your iPhone before making the switch. Read this article for more info: Issues with texts after moving to Android from iPhone? Here's an easy fix! | Android Central
    UJ95x and GSDer like this.
  3. #3  
    UJ95x's Avatar
    Retired Ambassador

    Posts
    10,178 Posts
    Global Posts
    10,444 Global Posts
    Carrier
    Stock 6.0.1

    Default Re: Help, please!!!

    Quote Originally Posted by B. Diddy View Post
    Welcome to Android Central! It sounds like you didn't turn off iMessage on your iPhone before making the switch. Read this article for more info: Issues with texts after moving to Android from iPhone? Here's an easy fix! | Android Central
    This is likely the issue. My dad switched from an iPhone 4S to the Moto X recently, and he'd occasionally receive texts even after the service on the iPhone was cancelled.
    iMessage should be turned off, and you should call Apple to remove the number from their system.

    Sent from my Galaxy S4 running SlimKat 4.4.2
    B. Diddy likes this.
  4. Thread Author  Thread Author    #4  

    Default Re: Help, please!!!

    Thanks, that seems to have done the trick.
    B. Diddy likes this.

Similar Threads

  1. Please help. Samsung Galaxy S4 won't turn on.
    By Platuni in forum Samsung Galaxy S4
    Replies: 23
    Last Post: 04-26-2015, 02:01 AM
  2. I've deleted my android operating system on Galaxy Fit. HELP!
    By Alexghe966 in forum General Help and How To
    Replies: 1
    Last Post: 03-13-2014, 10:46 PM
  3. HELP Apps question
    By jfb42 in forum HTC EVO 4G LTE
    Replies: 2
    Last Post: 03-13-2014, 01:10 PM
  4. Please Help! :)
    By Millzey13 in forum Android 4.4 KitKat
    Replies: 3
    Last Post: 03-13-2014, 12:07 PM
  5. Help Please :)
    By Millzey13 in forum Samsung Galaxy S4
    Replies: 6
    Last Post: 03-13-2014, 11:46 AM

Posting Permissions