1. armymelon's Avatar
    About 2 weeks ago I went to my car with 100% or so on my battery and by the time I got to the the car it had drained to roughly 50%. So 50% gone in 10 minutes. That was just the beginning of the issues now my battery won't charge up past 65% if I'm lucky and it will disharge just as fast. I seem to be constantly plugged in to a wall. If anyone has any idea about what to do that would be great!

    Posted via Android Central App
    03-25-2014 07:39 AM
  2. armymelon's Avatar
    03-25-2014 07:45 AM
  3. GSDer's Avatar
    First - turn the phone off completely and connect the charger. It should fully charge in just over two hours - if it doesn't, there's either something wrong with the charger, the cable, the battery (most likely) or the phone.
    Second - not that you can really do anything about it, but the Mobile network signal in the History details looks rather marginal. Nothing will run down a battery faster than the radios constantly trying to maintain a connection.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-25-2014 10:55 AM
  4. AxlMyk's Avatar
    How old is the battery? Mine was 1.5 years old and I just replaced it. I'm using a RAVpower 2250mah unit that leaves me with 30% at the end of the day. That's with a lot of daily use. So far I'm very happy with it.
    03-25-2014 11:26 AM
  5. armymelon's Avatar
    Thanks for thr responses guys! It's been like this for two or so weeks so I ordered a battery online, I'll look into that RAVpower battery though thanks for the advice! Last night I charged for 12 hours while the phone was off and it only went from 1% to 9% so something isn't right for sure..

    Posted via Android Central App
    03-25-2014 09:43 PM

Similar Threads

  1. I love the battery life on the Moto G
    By arch stanton1 in forum Moto G (2013)
    Replies: 8
    Last Post: 04-10-2014, 03:00 PM
  2. Google+ battery use when disablef
    By smiarmstrong in forum Google Nexus 5
    Replies: 4
    Last Post: 03-25-2014, 03:05 PM
  3. Replies: 6
    Last Post: 03-25-2014, 11:23 AM
  4. I need help. How to fix this?
    By tehkie04 in forum HTC One S
    Replies: 1
    Last Post: 03-25-2014, 03:59 AM
  5. Samsung G4 - Samsung Account back up not working
    By judgecartman in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 03-25-2014, 03:17 AM
LINK TO POST COPIED TO CLIPBOARD