Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
04-10-2014 08:30 PM
1 replies
  1. Thread Author  Thread Author    #1  

    Default Galaxy S3 Splash Screen then Nothing

    I've tried searching and couldn't quite find this particular problem.. I apologize if I missed it.

    Phone: Sprint Galaxy S3
    Version: stock 4.3 (been running this for quite a while with no issues)

    • As soon as I put in the battery I get a single vibrate and the phone tries to boot. It shows the Samsung splash screen then goes blank. Not sure if it's still running (with screen blank) or has shut off, or whatever.
    • The phone is trying to boot immediately after putting in the battery. I don't have to hit the power button.
    • If I hit the buttons for recovery mode right after putting in the battery I see the message at the top about recovery mode but as above, I never see the recover screen... the phone goes "blank."
    • Same thing trying to enter download mode. I can briefly show the download screen then everything goes blank.
    • I've tried a different battery, booting with several different power cords, etc.


    Now the really odd part... after repeatedly trying I did manage to get the recovery mode to start. I wiped the cache and the phone seemed to reboot normally. However, after trying a shutdown and restart it started the same pattern above with stopping after the splash screen. So far haven't been able to get back into recovery mode.

    Any help is appreciated. I hope there is an option other than a bricked phone.
  2. #2  

    Default Re: Galaxy S3 Splash Screen then Nothing

    Quote Originally Posted by ncwitz View Post
    I've tried searching and couldn't quite find this particular problem.. I apologize if I missed it.

    Phone: Sprint Galaxy S3
    Version: stock 4.3 (been running this for quite a while with no issues)

    • As soon as I put in the battery I get a single vibrate and the phone tries to boot. It shows the Samsung splash screen then goes blank. Not sure if it's still running (with screen blank) or has shut off, or whatever.
    • The phone is trying to boot immediately after putting in the battery. I don't have to hit the power button.
    • If I hit the buttons for recovery mode right after putting in the battery I see the message at the top about recovery mode but as above, I never see the recover screen... the phone goes "blank."
    • Same thing trying to enter download mode. I can briefly show the download screen then everything goes blank.
    • I've tried a different battery, booting with several different power cords, etc.


    Now the really odd part... after repeatedly trying I did manage to get the recovery mode to start. I wiped the cache and the phone seemed to reboot normally. However, after trying a shutdown and restart it started the same pattern above with stopping after the splash screen. So far haven't been able to get back into recovery mode.

    Any help is appreciated. I hope there is an option other than a bricked phone.
    It's most likely your power button, hopefully it's just dust. You might try to blow it out with some compressed air, both inside and out.

    Sent from my ME302C using Tapatalk

Similar Threads

  1. Replies: 38
    Last Post: 06-21-2014, 04:08 PM
  2. Galaxy S3 Settings and SIM lock problems
    By desdrl in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 3
    Last Post: 04-10-2014, 09:00 PM
  3. Sale on Sprint Galaxy S5 at Sam's Club on 4/11/201
    By ab304945 in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 04-10-2014, 07:36 PM
  4. My gear won't connect to the galaxy s5
    By IAmCashmere_D in forum Samsung Galaxy Gear
    Replies: 0
    Last Post: 04-10-2014, 07:27 PM

Posting Permissions