Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 4 of 13 FirstFirst 1234567 ... LastLast
Results 76 to 100 of 302
Like Tree15Likes
  1. #76  

    Default Re: Please help... My Galaxy S4 wo'nt let me enable Wi-Fi

    i did the following

    1. rooted and removed the wpa_supplicant.conf file
    2. reboot
    3.It will create new wpa_supplicant.conf file

    This will work and we can see that wifi-button is enabled but when you reboot it seems the phone can not again access the file(wpa_supplicant.conf) and the button is disabled again
    So do we need to change the file permission so that button is enabled permanently?
  2. #77  

    Default Re: Please help... My Galaxy S4 wo'nt let me enable Wi-Fi

    Quote Originally Posted by Kilva View Post
    1. Root your phone
    2. Download Root Explorer.apk, put it on your phone via USB, install it
    3. navigate to either /data/misc/wifi or /system/etc/wifi
    4. rename or delete wpa_supplicant.conf
    4.5. reboot
    5. ???
    6. PROFIT!
    Thanks a Lot!! This is the solution for the light green/frozen wifi issue. Was a headache!! Dont try other things. This is the real solution for it. No factory reset, no battery,...
    Kilva likes this.
  3. #78  

    Default Re: Please help... My Galaxy S4 wo'nt let me enable Wi-Fi

    It works but when I restart the phone "wifi button" is disabled again . So i have to delete the "wpa_supplicant.conf" again everytime i restart
    It seems to be some permission issue ?

    Quote Originally Posted by Kilva View Post
    1. Root your phone
    2. Download Root Explorer.apk, put it on your phone via USB, install it
    3. navigate to either /data/misc/wifi or /system/etc/wifi
    4. rename or delete wpa_supplicant.conf
    4.5. reboot
    5. ???
    6. PROFIT!
    markeygood2go likes this.
  4. #79  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Try turnin off mobile data then connect the wi-fi. Samsung says the new update should fix the problem.

    Sent from my SAMSUNG-SGH-I537 using AC Forums mobile app
  5. #80  

    Default Re: Please help... My Galaxy S4 wo'nt let me enable Wi-Fi

    Quote Originally Posted by Kilva View Post
    1. Root your phone
    2. Download Root Explorer.apk, put it on your phone via USB, install it
    3. navigate to either /data/misc/wifi or /system/etc/wifi
    4. rename or delete wpa_supplicant.conf
    4.5. reboot
    5. ???
    6. PROFIT!
    Hi! I've tried all this, renamed the file both in system and in data and it doesn't recreate them on reboot. Any idea why it doesn't or some other workaround to fix the wifi issue?

    Thanks!

    EDIT: I did some research on this, but it didn't help me any further. Maybe somebody here can:

    CatLog shows following errors:
    WifiHW: return of insmod : ret = -1, No such device
    WifiStateMachine: Failed to load driver
    WifiStateMachine: sendErrorBroadcast code:10

    For me it seems the issue already starts before loading the .conf-file, which actually seems to be fine. wlan0 is missing though. In my oppinion this is causing all the other problems. Maybe a boot log could help. I couldn't find a way to look at or save it though..

    I'm using the following stock firmware at the moment: I9505XXUFNB8_I9505OXAFNB8_I9505XXUFNB8_HOME.tar.md5
    Until today the phone wasn't rooted and the problems didn't start with an update, if I can recall corectly. I waited on the new OTA update (4.4.2), hoping it would solve the wi-fi issue, but it didn't. Only then I started rooting and digging..

    Thanks again!
  6. #81  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Mine made a new supplicant and I compared the two. Change the line "ctrl_interface=wlan0" to "ctrl_interface=/data/misc/wifi/sockets"
    That seems to be the error within the supplicant file itself.

    The wlan0 reference is a bug as far as I can tell.
  7. #82  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Change ctrl_interface=wlan0 to ctrl_interface=/data/misc/wifi/sockets

    The reference to wlan0 is a bug, far as I can tell.
  8. #83  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Quote Originally Posted by Spacemanben View Post
    Mine made a new supplicant and I compared the two. Change the line "ctrl_interface=wlan0" to "ctrl_interface=/data/misc/wifi/sockets"
    That seems to be the error within the supplicant file itself.

    The wlan0 reference is a bug as far as I can tell.
    Thanks for your answer. Can you tell me what else you have in your .conf-file? I tried changing it, but after a restart the wlan0 is there again. Also: what file did you change? The /data/misc/wifi or /settings/etc/wifi one?

    I described my issue in detail over here: [Q] Samsung Galaxy S4 LTE (I9505) - Update to 4.4.2, wifi problems remaining - xda-developers. As you can see, I would be also interested in the contents of /data/.cid.info.

    Thanks again!
  9. #84  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    I changed the \misc\wifi one. Further reading and experimenting makes me believe this is an issue we will need to wait for Samsung to fix.

    Alternatively you could flash a custom rom onto your advice, tho I take no responsibility for any problems you have if you do that. ( Insert standard disclaimer here)

    Ill look at my phone and try and put up the contents of those two files, but i flashed the ROM, so no guarantees its the same.
  10. #85  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    The files are as follows...

    data\misc\wifi\wpa_supplicant.conf

    ctrl_interface=/data/misc/wifi/sockets
    disable_scan_offload=1
    update_config=1
    device_name=liquid_jflte
    manufacturer=samsung
    model_name=GT-I9505
    model_number=GT-I9505
    serial_number=2405af88
    device_type=10-0050F204-5
    config_methods=physical_display virtual_push_button
    p2p_disabled=1

    (Previously saved access point details are here in the file. Not sharing those. Sorry.)

    . Cid.Info

    semcosh

    Let me know if you need anything else...

    On a side note I moved to a custom ROM and my wifi is fine now. Definately a software issue. A custom ROM may be a good answer, if you wanna go down that path.
    Again, standard disclaimers apply. I'm not responsible, etc....
  11. #86  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Thank you very much for these infos! I've tried them, but didn't have any luck for now.

    Can you please tell me if you have anything in your /data/misc/wifi/sockets folder? Mine is empty..

    I also don't know what type of wifi/bluetooth-chip I have. I suppose it should be a "murata fem1", not a "semcosh", but I have no idea how to check it.
  12. #87  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    All you have to do is reboot your phone. When turning it on hold the volume up button while holding power button. Once it starts to turn on it will say something like rebooting in small blue at top left. Then let go of buttons and it will start as normal. This has worked for me.
  13. #88  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    could you more clearer? im having an issue with my wifi
  14. #89  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Try this : pull out your battery and put it back after half hour, your wifi will come back again, i tried twice, it works for my s4.
  15. #90  

    Default Re: Please help... My Galaxy S4 wo'nt let me enable Wi-Fi

    So, my s4 says that i am connected to wifi, like my home wifi and such, but whenever i try to refresh or reload an app such as facebook or twiiter, it says i am not connected to the internet. Please help!!
  16. #91  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    With the phone on, pull the battery out and put back in.

    Posted via Android Central App
  17. #92  

    Default Re: Please help... My Galaxy S4 wo'nt let me enable Wi-Fi

    Kevin Spring 1 - it might work for some but not all SG4's
  18. #93  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    this happened to my wife's s4 today out of nowhere. to fix it i rebooted into recovery and formatted the cache.
  19. #94  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    I had the same issue. I pulled out the battery and put it back in. Then restrated the phone and it was back to working.
    pipo3k and graysteg like this.
  20. #95  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Android 4.3: Removing the battery for a couple of minutes fixes the problem. (WiFi passwords gone thought, so it looks like android detected that something was wrong and replaced the file ?!)
  21. #96  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    ok, i had to sign up just to post this in the hope it helps others.

    my problem was the wifi button wouldnt turn on no matter what i did, i switched it on and it would switch off. anyhow...people suggested to root the phone then rename a wifi file and it will fix the problem. again this didnt work, i didnt have a clue on how to root, but after 5 hours i feel like an expert hehe. i managed to unroot the phone back to stock.

    i got speaking with a fella from another forum, he suggested dialing *#0011# and enter the service menu, from there hit the menu button and choose wifi, then turn off WiFi Power Saver Mode. i did this and exited. i then tried the wifi, it never worked but i then re dialed *#0011# and entered the service menu once more, hit the menu button and choose wifi, then turned on WiFi Power Saver Mode. after doing this it has worked flawlessly ever since. doing this resets the wifi cache. so in short disable WiFi Power Saver Mode then exit, then enable WiFi Power Saver Mode again.

    i thought i would post a solution that worked first time for me, like i say i tried rooting and unrooting but nothing worked. i only hope this will work for you.

    please reply if this helps you in anyway so others can benefit.

    thanks.
  22. #97  

    Default Re: Please help... My Galaxy S4 wo'nt let me enable Wi-Fi

    I have the same problem .. Please help
  23. #98  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Quote Originally Posted by tuk3r View Post
    ok, i had to sign up just to post this in the hope it helps others.

    my problem was the wifi button wouldnt turn on no matter what i did, i switched it on and it would switch off. anyhow...people suggested to root the phone then rename a wifi file and it will fix the problem. again this didnt work, i didnt have a clue on how to root, but after 5 hours i feel like an expert hehe. i managed to unroot the phone back to stock.

    i got speaking with a fella from another forum, he suggested dialing *#0011# and enter the service menu, from there hit the menu button and choose wifi, then turn off WiFi Power Saver Mode. i did this and exited. i then tried the wifi, it never worked but i then re dialed *#0011# and entered the service menu once more, hit the menu button and choose wifi, then turned on WiFi Power Saver Mode. after doing this it has worked flawlessly ever since. doing this resets the wifi cache. so in short disable WiFi Power Saver Mode then exit, then enable WiFi Power Saver Mode again.

    i thought i would post a solution that worked first time for me, like i say i tried rooting and unrooting but nothing worked. i only hope this will work for you.

    please reply if this helps you in anyway so others can benefit.

    thanks.
    No when you rooted it you should of went got the odin .tar files and re flashed your modem it would of put a clean flash as it would rewrite the modem files after ota updates sometimes it doesn't re rite it like it should and this causes your wifi cell data and GPS to crash but with clean flashes it cleans it up but I'm glad to see someone found an alternative way as most people faint and ring the hepatic bell when you mention rooting

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
  24. #99  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Quote Originally Posted by scatteredmac View Post
    Strangest fault, can't enable Wi-Fi, Wi-Fi Hotspot or Bluetooth... When I pull down the screen from the top to bring up the quick select enable menu Wi-Fi will not turn on, it is preselected and a very light green colour instead of a grey for disabled or bright green when it is enabled... Holding the Wi-Fi button down and entering the option doesn't help either as it says "turning on" but does nothing... the toggle switch to turn Wi-Fi on also does nothing.
    I have reset the device several times and have also now tried a factory reset... which I really didn't want to do and it still hasn't helped. I have searched forums and google for any sign of this same fault and found nothing. I also can't enable portable Wi-Fi hotspot or Bluetooth... Can someone please advise?
    Took the battery out while the phone was still on and that did the trick
  25. #100  

    Default Re: Please help... My Galaxy S4 won't let me enable Wi-Fi

    Took the advice on here about the wifi button not sliding my galaxy s4 and thanks it's now working again
Page 4 of 13 FirstFirst 1234567 ... LastLast

Similar Threads

  1. Replies: 19
    Last Post: 10-11-2015, 06:26 PM
  2. Speed up the galaxy S4 and enable the developer mode
    By MallyMall88 in forum Samsung Galaxy S4
    Replies: 21
    Last Post: 11-09-2014, 03:28 PM
  3. DNS not available on Wi-Fi settings on Nexus 10
    By regalhawk in forum Google Nexus 10 Tablet
    Replies: 3
    Last Post: 11-08-2013, 08:32 AM
  4. In-app Videos only playing on Wi-Fi
    By ajbrickyard in forum HTC One M7
    Replies: 6
    Last Post: 07-01-2013, 05:57 PM
  5. [Q] Wi-fi problems.
    By tomy22783 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 06-25-2013, 11:26 AM

Posting Permissions