I have a massive issue with my S4 GPE, it all started weeks ago at home when suddenly, after clearing my stored music from the Google Play Music app and trying to keep a playlist on the device, a notification appeared and said "Can't download music right now", and I thought it wasn't such a big deal, so I didn't try again until next morning at school with their wi-fi. But then, over the next few days, YouTube videos started to show this error: "Connection to server lost. Touch to retry", but when I touched the screen nothing happened.

That went on until almost every video was impossible to play (I noticed that this didn't affect playing YouTube videos on my laptop). I used VPN apps to be able to watch them, but I got tired and decided to make a factory data reset to see if that could help. After some tries getting the same error, something else came, and that's when the PlayStore problem began. Some apps were able to upgrade, but some others weren't.

And as the days passed, it got worse. I used again VPN apps so I could install the upgrades of those who weren't downloading, but then I couldn't even download VPN's through the PlayStore and now, I can't download any app. Besides, I cannot watch videos on Chrome for android, it gets the same error message.
I tried clearing data, cache, uninstalling updates, switching accounts, use other networks, factory resets, pretty much everything and I'm so desperate!

I thought it was my account because I live in Mexico and was using it for years to download stuff from the US store, so I tried creating a new one that worked in my country's store, but it failed, I got the same problem, and it spread to my Asus Transformer Infinity (I installed CyanogenMod in this device trying to figure out the source of the problem, but it is the same thing).
So far, I'm losing hope in solving this problem, and I'd be glad if someone could help me.

I have android 4.4.2 KitKat installed, problems started since I was on 4.4, and I think that could have messed things up, but it doesn't explain why my Asus is having the same issues. It seems to happen on my home's wi-fi network. (Sorry for the bad english).

Thanks!