12-12-2015 12:49 AM
148 ... 23456
tools
  1. Dave Ramsey's Avatar
    after you enter the new apn make sure to save the apn and delete the old apn and shut off the phone and restart and everything will work including mms and internet
    11-03-2013 10:39 AM
  2. Dave Ramsey's Avatar
    what sims do you have do you have the new lte sims or the older one
    11-03-2013 11:09 AM
  3. Dave Ramsey's Avatar
    do not put anything for the port after the apn I have the galaxy s4 and the new sims for lte and mine works great
    11-03-2013 11:13 AM
  4. gred's Avatar
    I have a Samsung Galaxy S4 I9500 unlocked, bought from newegg unlocked. I used it for a month in Spain with a phone only micro sim from movistar, no problems, just used wifi for data. Now I am back in USA, bought straight talk micro sim (appears to be t mobile from default APN) and cannot get data/internet or MMS to work. Spent an hour on phone with straight talk tech support, they gave me two sets of APN data to try (see below). Neither worked, so they say the phone is bad.

    Tried changing some parameters with what has worked for others in this thread, and big problem right now is that any time I change the MNC to 410 from 260, when I go to save the set of APN data it gets deleted. Any suggestions? Samsung says its a straight talk problem not a phone problem, including not properly saving APN data.


    set 1

    Name: Straight Talk
    APN: wap.tracfone
    Proxy: 216.155.165.40
    Port: 8080
    User name: not set
    Password: not set
    Server: not set
    MMSC: http://mmsc.tracfone.com
    MMS proxy: 216.155.165.40
    MMS port: 8080
    MCC:310
    MNC: 260
    Authentication type: none
    APN type: not set


    set 2

    Name: Straight Talk
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    User name: not set
    Password: not set
    Server: not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms2.tracfone.com
    MMS port: 80
    MCC:310
    MNC: 260
    Authentication type: none
    APN type: not set

    thanks for any help - Mark
    11-12-2013 01:02 PM
  5. Lomotius Belmont's Avatar
    I have a Samsung Galaxy S4 I9500 unlocked, bought from newegg unlocked. I used it for a month in Spain with a phone only micro sim from movistar, no problems, just used wifi for data. Now I am back in USA, bought straight talk micro sim (appears to be t mobile from default APN) and cannot get data/internet or MMS to work. Spent an hour on phone with straight talk tech support, they gave me two sets of APN data to try (see below). Neither worked, so they say the phone is bad.

    Tried changing some parameters with what has worked for others in this thread, and big problem right now is that any time I change the MNC to 410 from 260, when I go to save the set of APN data it gets deleted. Any suggestions? Samsung says its a straight talk problem not a phone problem, including not properly saving APN data.

    set 2

    Name: Straight Talk
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    User name: not set
    Password: not set
    Server: not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: mms2.tracfone.com
    MMS port: 80
    MCC:310
    MNC: 260
    Authentication type: none
    APN type: not set

    thanks for any help - Mark
    Try changing MNC to 410

    I've been dicking around with this phone for over an hour now, thanks for all of these suggestions y'all! Finally online and able to send MMS with an unlocked S4 octo-core on ST, this finally works for me - the "NAME" field appears to be just for reference, too. Just try using those settings and change your MNC - hopefully yours will work too.
    Robert Rightmire likes this.
    11-16-2013 07:22 PM
  6. Jessica Smith's Avatar
    Hi all, I'm looking now on Ebay to purchase a Galaxy S4 to put on Straight Talk. I'm interested in the LTE that Straight Talk now offers with AT&T. I'm new to Straight Talk so just doing all the research now and trying to learn.

    I was advised to just look for the AT&T Galaxy S4 model number SHG-1337 and it wouldn't matter if locked or unlocked. Is this true? I just want to make sure I order the right phone and don't have these issues with getting MMS to work on it....but thankful for this thread should I end up with problems. I'm trying to do homework before I get the phone.

    Thanks for any advice.
    11-21-2013 08:46 PM
  7. shyla158's Avatar
    Hi I have a unlocked Samsung s4 tmobile phone what are the apn steps to get internet I had purchased a unlimited 45$ plan from straight talk I have my calling and text but the internet icant get the settings and such to work can anyone please help
    11-23-2013 08:10 PM
  8. Persy's Avatar
    So weird - with those settings, neither data nor MMS works for me. If I remove the first proxy, data works, but MMS still doesn't. I can't get MMS to work no matter what I try!
    Me, either......
    11-25-2013 12:13 AM
  9. Persy's Avatar
    That's ME, too, I CAN SEND but NOT RECEIVE...I get a "Download" and when I click on it it says FAILED.... )-:
    11-25-2013 12:14 AM
  10. Greg Riegler's Avatar
    Settings that worked for my SGH-I337 AT&T Branded Galaxy S4 for use on Straight Talk are:

    name: straighttalk
    APN: tfdata
    Proxy: Not set
    Port: 8080
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mms-tf.net
    MMS Proxy: mms3.tracfone.com
    MMS Port: Not set
    MCC: 310
    MNC: 410
    Authentication Type: Not set
    APN Type: default,supl,mms,internet,hipri
    Bearer: Unspecified

    Any change in any of these settings on my phone disables MMS or Phone or Data
    11-25-2013 04:18 PM
  11. Greg Riegler's Avatar
    Hi all, I'm looking now on Ebay to purchase a Galaxy S4 to put on Straight Talk. I'm interested in the LTE that Straight Talk now offers with AT&T. I'm new to Straight Talk so just doing all the research now and trying to learn.

    I was advised to just look for the AT&T Galaxy S4 model number SHG-1337 and it wouldn't matter if locked or unlocked. Is this true? I just want to make sure I order the right phone and don't have these issues with getting MMS to work on it....but thankful for this thread should I end up with problems. I'm trying to do homework before I get the phone.

    Thanks for any advice.
    I purchased AT&T Branded S4 SGH-I337. Unlocking wasn't necessary. You just have to enable developer mode, and change APN Settings.
    11-25-2013 04:24 PM
  12. Persy's Avatar
    How does one Enable Developer Mode in the Samsung Galaxy S4...GT-I9500? Thanks...
    12-01-2013 09:33 PM
  13. Lighc003's Avatar
    Ok....Here's a new one. I have a Samsung Galaxy S4 Mini. Model GT-I9195 I'm trying to use Straight Talk....and like many others, I can send a text but not picture mail. If anyone has this phone and has a suggestion about APN settings....it would be GREATLY appreciated. Thanks
    12-02-2013 10:56 AM
  14. Greg Riegler's Avatar
    Ok....Here's a new one. I have a Samsung Galaxy S4 Mini. Model GT-I9195 I'm trying to use Straight Talk....and like many others, I can send a text but not picture mail. If anyone has this phone and has a suggestion about APN settings....it would be GREATLY appreciated. Thanks
    Did you try the settings i posted?

    How does one Enable Developer Mode in the Samsung Galaxy S4...GT-I9500? Thanks...
    On Android devices starting at API level 17, Android 4.2, the “Developer Options” section is not shown as one of the sections in the Settings app. To make it appear, you have to launch the Settings app, and tap on “About phone”. Inside the “About phone” section is a list item labeled “Build Number”. Tap on that selection 7 distinct times. After 3 taps, each tap shows a new toast message encouraging you to keep going (see attached screenshot). After the last tap, it shows a message saying “you are now a developer” and hey presto, the “Developer Options” will now be visible as one of the sections at the top level of Settings. Source: How to Enable Developer Options on the Samsung Galaxy S4 | Haptic Antics
    Persy likes this.
    12-04-2013 09:57 AM
  15. David Vasquez2's Avatar
    PLEASE SOME ONE HELP!!! I have the s4 but on verizon. Its the SCH-I545 and can not do mms. I have tried every apn posted on here. I can do everything but send and receive pics. I'm using the at&t micro sim that came with the straigtTalkbyop. I dont know what else to do.
    Ashley Collins1 likes this.
    12-13-2013 05:27 PM
  16. downtheroad's Avatar
    Settings that worked for my SGH-I337 AT&T Branded Galaxy S4 for use on Straight Talk are:

    name: straighttalk
    APN: tfdata
    Proxy: Not set
    Port: 8080
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mms-tf.net
    MMS Proxy: mms3.tracfone.com
    MMS Port: Not set
    MCC: 310
    MNC: 410
    Authentication Type: Not set
    APN Type: default,supl,mms,internet,hipri
    Bearer: Unspecified

    Any change in any of these settings on my phone disables MMS or Phone or Data
    Thanks, Greg. Been trying everything I could find online to setup my Straight Talk APN for my Verizon SCH-i545. Bought phone on eBay 2 months ago and installed Straight Talk's AT&T compatible micro sim. Was not able to receive MMS until today using your settings. The Port:8080 setting was the one that did the job for me. Thanks, again.
    12-15-2013 08:55 PM
  17. gred's Avatar
    My big problem right now is that any time I change the MNC to 410 from 260, when I go to save the set of APN data it gets deleted. Any suggestions?
    12-26-2013 07:31 AM
  18. jeffmike221's Avatar
    Me too! I have Verizon branded S4 i545. Tried all apn posted.
    01-04-2014 10:50 AM
  19. Leslie Mondrick's Avatar
    I tried to reset default apn after I put the straight talk apn in but I have the AT&T version and it restored those settings as default unchanged. I have tried to remove the default AT&T settings but they don't go away. Not sure what to do now.
    01-11-2014 04:33 PM
  20. chris wrublewski's Avatar
    I tried many of different settings with my att galaxy s4 and these are the ones that finally worked.
    01-24-2014 02:22 PM
  21. Redskies4you's Avatar
    Hello Chris , what finally worked for you exactly... i have new unlocked samsung galaxy S4 mini and nothing seems to work to get the mms pictures to work . phone plain text and internet work but no mms pictures. Thanks if you can completely post settings and how to.
    01-25-2014 01:52 AM
  22. nshoalm's Avatar
    I just tried several on my new s4 active - this one worked for me minus internet - had to put 80 in under proxy for internet to work on mine. Thanks
    02-07-2014 06:34 PM
  23. Alexandra Zink's Avatar
    I have a Galaxy S4 AT&T that I use on Straight Talk and I cannot receive or send MMS messages. What is the correct APN setting? I cannot delete the AT&T APN set on the phone.
    02-08-2014 03:10 PM
  24. Heather Pucheu's Avatar
    I have the Galaxy S4 Active and no matter what codes I put in I can NOT get my regular nor mms texting to work. Does anyone have this phone and if so can you please share APN information with me ty. dblspromo@gmail.com
    02-17-2014 02:30 PM
  25. shaganasty's Avatar
    hi, I have the same phone and sure would like to get your apn settings please.
    thank you very much
    02-20-2014 09:03 PM
148 ... 23456

Similar Threads

  1. Samsung galaxy s3 and straight talk
    By morton8683 in forum Samsung Galaxy S3
    Replies: 14
    Last Post: 11-27-2014, 04:17 AM
  2. Galaxy Proclaim on Straight Talk
    By terminalinfinity in forum Other US Carriers
    Replies: 5
    Last Post: 02-24-2014, 07:30 PM
  3. Samsung Galaxy S3 on Straight Talk
    By qzmpal in forum AT&T Galaxy S III
    Replies: 2
    Last Post: 04-30-2013, 01:52 AM
  4. Replies: 1
    Last Post: 04-25-2013, 01:58 PM
  5. Galaxy nexus with straight Talk?
    By Kale Blossom in forum Google / Samsung Galaxy Nexus
    Replies: 17
    Last Post: 02-05-2013, 10:32 AM
LINK TO POST COPIED TO CLIPBOARD