Results 1 to 17 of 17
Like Tree1Likes
  • 1 Post By ylarotia
  1. Thread Author  Thread Author    #1  

    Default Email Does Not Sync Over Mobile Data on my new gS4

    My email accounts sync perfectly over Wi-Fi however as soon as I don't have wi-fi none of my email accounts sync. Mobile data is ON and other web based applications work fine (browser, FB etc). this is getting to be a big problem for me as i am on the go most of the day... Any ideas?
    Thanks
  2. #2  
    Darth Spock's Avatar

    Posts
    5,684 Posts
    Global Posts
    5,723 Global Posts
    ROM
    Assassin 'Droid

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Quote Originally Posted by Costas S View Post
    My email accounts sync perfectly over Wi-Fi however as soon as I don't have wi-fi none of my email accounts sync. Mobile data is ON and other web based applications work fine (browser, FB etc). this is getting to be a big problem for me as i am on the go most of the day... Any ideas?
    Thanks
    Try this first ( I think this part you did already but double check)
    Settings > Data Usage > Mobile > Menu (button) > Auto Sync Data

    Then there is a toggle in the toggles in the notification shade
    Open Notification Shade > Scroll to the left and find "Sync" - Make sure this is enabled.

    ​Obvious statement: Why, I am an assassin 'droid, Master.
    May the Force Be With You

    Community Rules & Guidelines​
    (Formerly "NothingIsTrue")

  3. #3  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Quote Originally Posted by NothingIsTrue View Post
    Try this first ( I think this part you did already but double check)
    Settings > Data Usage > Mobile > Menu (button) > Auto Sync Data

    Then there is a toggle in the toggles in the notification shade
    Open Notification Shade > Scroll to the left and find "Sync" - Make sure this is enabled.
    AAAAND after doing this 2 steps, if it still won't work for you on mobile data, go to Settings>Data Usage, there, click on the Options button, and make sure the "Restrict Background Data" option is DISABLED..

    that should do the work...

    good luck
    Thanked by 2:
  4. Thread Author  Thread Author    #4  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Many thanks Rick.
    Unfortunately settings were exactly as you described but still I cannot sync over 3G.
  5. #5  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Are you using the stock email app or gmail app? if stock make sure you have the refresh rate enabled. It is not a push system but a pull. It must be set to poll at time intervals or manually. not sure why they are working on wifi and not mobile data, maybe a setting that say to sync on wifi not mobile data?. Can you send and receive texts?
    Lumia 925 w/Black, Nexus 5 (32GB), Moto X (32GB), Lumia 1020, Google Edition S4, Galaxy S4 (32GB), S4 Active, Nexus 4, Note 2, Galaxy S3, Galaxy Note (ATT), Galaxy Note Intl., Galaxy S2 Skyrocket, Nexus S, Atrix 2, Atrix, Galaxy S1 Captivate, Nexus 7 (32GB), iPad 4, Dell Venue Pro 8
    and yes...an iPhone 5 too...
  6. Thread Author  Thread Author    #6  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    I am using the stock email app. The strange thing is that the emails sync OK over wi-fi so it's not an email setting error and other aps like FB and Chrome work fine over 3G. I can send and receive txts and MMS fine. i have set the stock up to sync every 5mins and i also try manual refresh but nothing happens. I tried to find a setting n the email app to set sync over wi-fi only but could't find anything. The closesest setting available is "download attachments over wi-fi ".
    Thx
  7. #7  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Hi!
    I have the same issue, and can vouch for the repeatability of this error.
    Phone: Samsung XCover 2:
    Sonera 3g (21mbit/s) data connection ==> no email traffic
    Any WLAN ==> email syncs (sends outbound messages, pulls inbound as configured).

    I was able to check the SIM on another phone (older android) and that had no issues with email.
    It is either Android or the phone, almost as if there was a firewall rule on mail traffic.

    Web browsing works fine on 3G data and on WLAN.

    Any thoughts?

    BRgs,

    Aarne
  8. #8  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Hi!

    So I was able to solve my problem, which sounded exactly like yours with the help of this:


    and following the part about mobile internet settings. I gave a call to my carrier (Sonera in Finland), followed their advice about the proper APN settings, applied the correct settings - and lo & behold, e-mail works again.

    THis, if I understood correctly, is an issue for non-carrier bound devices. THey said outright that since I have bought the phone and the SIM module separately, I'll need to set the phone up manually.
    Thanked by:
    soll862002 likes this.
  9. #9  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Hi I had the same issue with Telenet (which is indicated as roaming on the Mobistar network).

    All settings in every possible menu were correct, but one did the trick... the Telenet APN authentication type was "none set", and had to be PAP.

    Doing so, mail is now also synced in case of mobile data, before it was only possible by wifi connection (sync etc settings were all double checked)

    Hope it will help you
  10. #10  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    I've had this issue a couple of times with my Galaxy S3. The first time was just after I got it; can't remember how I fixed it then; but it just recurred.
    I had been on holidays and had disabled data while roaming.
    But I also disabled a bunch of other stuff.
    If you go to settings :: Data usage :: Mobile, then scroll down to the individual programs running; check the individual email programs such as gmail, exchange, email, etc. and click each one to ensure that the box "restrict background data" is NOT ticked
    This solved my problem.
  11. #11  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    i had this issue when i got my new android jellybean, i followed tipps mentioned. I accidentally turned sync off etc. After i solved everything it also helped me a lot to install K-9 app from google play store, which syncs in real time. Have fun and thank u guyz!
  12. #12  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    I had this problem too, tried taking battery out, removing a/c and adding but still nothing. everytime i clicked the native app to check for email it would say that sync is disabled. i tried the above posters method too, doing into the data usage area. Still nothing. What I did that worked for me was to click the email icon which should open your email list, pressed the menu button, go to settings and select sync email. for some reason it keeps unselecting this!!! i may have to resort to 3rd party app in future. Gmail app works perfectly but I prefer the native one, when it works! I hope this helps someone!!
  13. #13  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    thanks for the link : )
    Orange Wap was selected instead of Orange Internet in Settings > Access Point Names
    I have a Samsung xcover 2 .... this was the fix for me : settings > mobile networks > Access Point Names > and i checked my correct APN that had NET , not WAP ...
  14. #14  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    I had the same issue.

    Went to settings, Mobile Networks, Access Point Names, Press the left key at the bottom (sorry not sure what its called) then press "Reset to Default" worked fine.
    Thanked by:
  15. #15  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    I have the same problem- can't send emails over data but works fine on wifi... although I can receive on both. This is true for both my work and personal email accounts (both POP accounts). I also have a Hotmail account that works fine on either wifi or data. I've double-checked all settings with my isps, and reconfigured the APN's to my Telco's specs, but still no success. I've tried downloading different email clients (K9) and have the same issue. I've spoken to tech support at Samsung, my ISP's and my Telco, and none can shed any light on the problem. So... over to you guys...
  16. #16  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Hey all,

    Found a fix that worked for me. Apparently the background data restriction option doesn't necessarily remove an app-specific restriction of the same kind. So then you have to remove that restriction for the exchange services. I went through all those forums for the past week and I ended up trying something that worked for me, it's finally working. Try the following (the names of the options and menus might vary for you, I'm on the Nexus 4).Steps below

    Go to settings

    Go to Data Usage

    After you get there, a list of apps and the amount of data they consume will show up below.

    Scroll down till you find the one titled; Exchange Services

    Open it, Scroll all the way down (past the View App Settings option). There should be a checkbox to Restrict Background Data. In my case, even though I had removed the background data restriction option from the general menu, it was still checked here.

    Make sure that this box is unchecked, and voila. Hope it works.

    Good luck
  17. #17  

    Default Re: Email Does Not Sync Over Mobile Data on my new gS4

    Thank you James Roberts!! Mystery solved. The path for my galaxy note 2 was slightly different but it did the trick! Like so many others email client on wifi worked. But not so over mobile network. Here is the path I followed to restore to the necessary default. Settings>more settings> mobile networks> access point names>hit your phones "menu" button (bottom left for me)> restore to defaults. Select this option after hitting your menu button and voila! Mobile network restored. Don't know what went screwy to cause this problem in the first place but restoring this specific default fixed the problem like a charm.
    Last edited by Shiloh2rtn; 01-24-2014 at 08:12 PM.

Similar Threads

  1. Replies: 0
    Last Post: 03-20-2013, 02:23 AM
  2. Google does not sync on my Phone
    By BenjaSands in forum AT&T Inspire 4G
    Replies: 1
    Last Post: 02-25-2012, 04:56 AM
  3. HTC EVO Does Not Sync Google Calendar
    By matthewriley in forum HTC EVO 4G
    Replies: 9
    Last Post: 02-24-2012, 04:52 PM
  4. Email issue - not syncing
    By mflynn in forum Motorola Droid X
    Replies: 11
    Last Post: 02-08-2011, 09:52 PM
  5. Email- me.com email address not syncing
    By sr71shark in forum Motorola Droid
    Replies: 2
    Last Post: 10-14-2010, 02:19 PM

Posting Permissions

B