Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 39
Like Tree2Likes
  1. Thread Author  Thread Author    #1  
    FastNOC's Avatar

    Posts
    7 Posts
    Global Posts
    9 Global Posts

    Default Wi-Fi on when turned off, keeps trying to connect.

    I am going crazy with this phone. I LOVE the droid after being a forced IPhone sheep for years. but some things i can't quite figure out.

    Something on this thing keeps forcing wifi to turn on. I don't want it to do this. I want to enable wifi only when i want to use it. I don't want it automatically connecting to att wifi areas, and i don't want it to just 'pop' on.

    Currenly, even with wifi turned OFF, i get constant popups of connection failures, that it keeps wanting me to connect, and says it failed. i cancel the message out,then go into settings, sure enough, wifi is completely turned off....

    Then i get the popup again. i cannot even describe how annoying this is. i dont want to use wifi, ever, unless i manually turn it on. I also downloaded this 'better wifi' app that doesn't fix the problem at all.

    1. I can't figure out what is forcing wifi on, but i want to stab it in the face,
    2. if i have wifi turned off, i dont wan it to ever, under any circumstances, try to connect without me doing it.

    is this possible? i'm sure this is purely my fault, and i did something stupid, i just can't figure out what i did.

    FYI this is a new Galaxy S4, The new love of my life
  2. #2  
    Sizzers's Avatar

    Posts
    423 Posts
    Global Posts
    426 Global Posts

    Default re: Wi-Fi on when turned off, keeps trying to connect.

    Im only replying in sympathy, not with a solution Im afraid.

    I had exactly the same problem with my XT890 and the only way I could stop it was by re-starting the phone, which was fine until the next time I connected to wifi and it would start all over again. At the time I was also using a separate wifi widget but uninstalling it made no difference.

    Thankfully I only had to endure this for a few days and my suspicion is that it was resolved by my uninstalling one of (many!) apps I had been trialling, but that is little more than a guess. It may be worth checking to see what permissions any new installed apps may have, but further than that sadly I cant be of any more help.

    Hope you get it sorted because I do feel your pain!.
    Putting out fire with gasoline
  3. #3  

    Default re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by FastNOC View Post
    I am going crazy with this phone. I LOVE the droid after being a forced IPhone sheep for years. but some things i can't quite figure out.

    Something on this thing keeps forcing wifi to turn on. I don't want it to do this. I want to enable wifi only when i want to use it. I don't want it automatically connecting to att wifi areas, and i don't want it to just 'pop' on.

    Currenly, even with wifi turned OFF, i get constant popups of connection failures, that it keeps wanting me to connect, and says it failed. i cancel the message out,then go into settings, sure enough, wifi is completely turned off....

    Then i get the popup again. i cannot even describe how annoying this is. i dont want to use wifi, ever, unless i manually turn it on. I also downloaded this 'better wifi' app that doesn't fix the problem at all.

    1. I can't figure out what is forcing wifi on, but i want to stab it in the face,
    2. if i have wifi turned off, i dont wan it to ever, under any circumstances, try to connect without me doing it.

    is this possible? i'm sure this is purely my fault, and i did something stupid, i just can't figure out what i did.

    FYI this is a new Galaxy S4, The new love of my life
    First off, welcome! You will love the phone and all of the wonderful things you can do with it. The device comes preset to automatically connect to AT&T wifi hotspots. If you go to wifi settings, there should be an option to not automatically connect to AT&T hotspots.
    Nexus 5-Black
    Rooted 4.4.2
    TWRP
  4. Thread Author  Thread Author    #4  
    FastNOC's Avatar

    Posts
    7 Posts
    Global Posts
    9 Global Posts

    Default re: Wi-Fi on when turned off, keeps trying to connect.

    oh yeah, i'm familiar with that, it turned that off the first day i had the phone. i've disabled wifi everywhere i can find.

    not only that, I have 3 different wifi networks in my home. i can connect to one, and it will continually fall off and say 'disabled' even though it's not, i try connected to the 2.4ghz side, or the 5ghz. same problem. i try connecting using wps, same problem. all 3 routers, all 3 the same thing so i'm 100% sure it's a problem with the phone, but i cxan't figure it out.

    i go through and 'forget' all networks, then just get that popup over and over and over.

    if this isn't fixable i'm not sure what i'm going to do. i also have a galaxy note ii but it doesnt seem to do this. the versions of o/s are one pr different, so i'm wondering if there's a problem in the 4.2.2 build of Jelly bean
  5. #5  

    Default re: Wi-Fi on when turned off, keeps trying to connect.

    Just make sure you go into Settings>Connections>Wifi and make sure it's off and all options below are unchecked.
  6. #6  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    1. Are you using the Samsung BatteryGuru app?

    2. In the AT&T Smart WIFI app, if you set it to any option other than the lowest setting, it'll keep turning wifi on. I eventually killed the AT&T Smart WIFI app.
    Possible Errors Between Keyboard And Chair.
  7. #7  
    Chetan Takyar's Avatar
    Banned

    Posts
    3,111 Posts
    Global Posts
    3,732 Global Posts

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by FastNOC View Post
    I am going crazy with this phone. I LOVE the droid after being a forced IPhone sheep for years. but some things i can't quite figure out.
    Forced iPhone sheep? So I'm a sheep for owning an iPhone? Don't follow your logic.
  8. Thread Author  Thread Author    #8  
    FastNOC's Avatar

    Posts
    7 Posts
    Global Posts
    9 Global Posts

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by Chetan Takyar View Post
    Forced iPhone sheep? So I'm a sheep for owning an iPhone? Don't follow your logic.
    I dont know, are you ? I was was refering to being forced to use it because our company requires them. well they did, until a few months ago, the same day i went and bought two Galazy Note IIs

    Quote Originally Posted by sniffs View Post
    1. Are you using the Samsung BatteryGuru app?

    2. In the AT&T Smart WIFI app, if you set it to any option other than the lowest setting, it'll keep turning wifi on. I eventually killed the AT&T Smart WIFI app.
    I can't figure out how to remove anything. here's the kicker, I'm a programmer, but have never been too intrerested in the phones. I think most of stems from the fact that i had ot use an iPhone for so long, and disliked it greatly. once i got the galaxy Note II I fell in love with Android. that's my first one. now I picked up an S4 and will be sticking with droid bsaed phones from here forward, njo question.

    Anyway, as a programmer you'd think i'd not have problems like this, but since i have very little experience with Droids, it's a learning curve. I am sure i'll figure out more, but i'm thrilled overall. to be honest, it really only happens at home. Can you please point out how i uninstall that stuff? to me and my limited smartphone knowledge, it apepars the ATT apps were packaged with the phone built into the O/S, hence I can't uninstll the ATT/Samsung apps. I would LOVE to find out how. I suppose i'll need to root the phone, but at this point that would be a last resort, as the older i get the more lazy i get

    The only options i see are the ones to uninstall the 'updates' but the core apps i don't see a way to remove.

    EDIT: Correction. I am incorrect. I had never even opened the app before, but when i did, it asked me i iwanted to continue, and i saw the link to the uninstall. i thought that only uninstalled updtes. PRs or whatever they call them. but not the core app. however, according to the page it had a link to remove which took me back to the play store, and ure enough there was an uninstall. so i guess my rant about the bloatware was only partially valid, since you can in fact uninstall 'some' apps. just not **** which i can't.
  9. Thread Author  Thread Author    #9  
    FastNOC's Avatar

    Posts
    7 Posts
    Global Posts
    9 Global Posts

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by sniffs View Post
    1. Are you using the Samsung BatteryGuru app?

    2. In the AT&T Smart WIFI app, if you set it to any option other than the lowest setting, it'll keep turning wifi on. I eventually killed the AT&T Smart WIFI app.
    thanks for the response, i missed it somehow.

    i'm not using that progrm, but am familiar with it. I honestly don't use that many apps right now, but only because i've been so burried i just simply haven't had time to reallyl put this thing together the way i want.
    Thanked by:
  10. Thread Author  Thread Author    #10  
    FastNOC's Avatar

    Posts
    7 Posts
    Global Posts
    9 Global Posts

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    By the way, I have removed the att app (i think) and will monitor progress. i'll follow up and let you know if that was the problem. hopefully it can help someone else.

    things like this are why i love forums. thanks everyone
  11. #11  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    I have a VERIZON Samsung Galaxy S3 and I am having major issues with my Wi-Fi as well. Mine wants to turn off and on while in use, interrupting backups, downloads, etc. It will randomly turn off and begin using 4G, then a few seconds later, kick back to my wi-fi. I have looked at a number of forums, googled the issue many times, and nothing seems to work....Please, any suggestions!?
  12. #12  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by FastNOC View Post
    thanks for the response, i missed it somehow.

    i'm not using that progrm, but am familiar with it. I honestly don't use that many apps right now, but only because i've been so burried i just simply haven't had time to reallyl put this thing together the way i want.
    Almost ALL of the AT&T stuff, I selected in the App Manager settings and clicked "Disable". The only one I left alone was the AT&T Hotspot.. that way if my WIFI *happens* to be on, it'll auto connect to the AT&T hotspots.. other than that, messenges, familylocator, smart wifi, all that junk is Disabled.
    Possible Errors Between Keyboard And Chair.
  13. #13  
    JayInNJ's Avatar

    Posts
    24 Posts
    Global Posts
    115 Global Posts

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    You probably did this, but make sure Auto-Connect is unchecked.
  14. #14  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    I had the same problem, ended up disabling ATT Smart Wifi then eventually uninstalling it all together. Problem solved...

    Posted via Android Central App
  15. #15  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by cwood07 View Post
    I have a VERIZON Samsung Galaxy S3 and I am having major issues with my Wi-Fi as well. Mine wants to turn off and on while in use, interrupting backups, downloads, etc. It will randomly turn off and begin using 4G, then a few seconds later, kick back to my wi-fi. I have looked at a number of forums, googled the issue many times, and nothing seems to work....Please, any suggestions!?
    Does this happen everywhere, or just on a particular network (i.e. at your home)? It's hard to tell given your symptoms if it's the phone or the router it is connecting to. There are some other threads I've seen here with folks having some issues with certain routers (mostly D-Link, I think), so maybe that's that the issue?

    What I'd do is try manually setting the wifi channel on your router, if you haven't already...sometimes when set to auto it will cause disconnects if the router is frequently changing channels due to outside interference (I recommend always using channel 1, 11, or 6).

    If that's not it, does the disconnection happen often enough that you could disable your routers security to test and see if that "fixes" it? You could also check to make sure you're router is running the most recent firmware version.
  16. Thread Author  Thread Author    #16  
    FastNOC's Avatar

    Posts
    7 Posts
    Global Posts
    9 Global Posts

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Pretty sure this issue was fixed when i unistalled the att wifi app.

    SO relieved. Thanks everyone. if there's any change i'll follow up
  17. #17  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    I'm on the Sprint S4 but try going to settings > Wi-Fi (actually click on Wi-Fi, not just turn it off) then click on Smart mode, it will go to a new screen and then in the top right you can move the slider to off.

    Hope this helps! It seems to be working on mine. I like you was about to throw my phone out the window it was pissing me off so much.
  18. #18  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Oh SNAPS. I had the same problem, which landed me here but I just figured it out.

    Settings>Wi-Fi>hit menu button and go to Advance>Keep Wi-Fi on during sleep and check NEVER!
  19. #19  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by vinnie27 View Post
    Oh SNAPS. I had the same problem, which landed me here but I just figured it out.

    Settings>Wi-Fi>hit menu button and go to Advance>Keep Wi-Fi on during sleep and check NEVER!
    Never mind damn thing turned itself on again...

    Real solution foreals this time

    Settings>More Settings>Mobile networks>Connections optimizer>Uncheck box that says "automatically select best mobile network"
    Thanked by 2:
    Blesd1 and BirdmanTamu like this.
  20. #20  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Hi...I'm also got the same problem with my samsung android, I just noticed it yesterday...did you found out real solution...this is so annoying plus more battery consumption...
  21. #21  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    Quote Originally Posted by Nick183 View Post
    I'm on the Sprint S4 but try going to settings > Wi-Fi (actually click on Wi-Fi, not just turn it off) then click on Smart mode, it will go to a new screen and then in the top right you can move the slider to off.

    Hope this helps! It seems to be working on mine. I like you was about to throw my phone out the window it was pissing me off so much.
    This.

    Sent from my *PURPLE* Galaxy S4
  22. #22  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    I had the same problem. If nothing else is working, try this:
    Settings>more settings>mobile networks>network mode. If the network mode is set to global, that may be your problem. Click LTE / CDMA to re-establish your 4G connection and exit. Make sure wifi is turned off and you should be good. Hope this helps you!

    Running with scissors and my Verizon Samsung Galaxy S3 4G LTE phone.
  23. #23  

    Thumbs up Re: Wi-Fi on when turned off, keeps trying to connect.

    At long last! This is the answer! Settings>More Settings>Mobile networks>Connections optimizer>Uncheck box that says "automatically select best mobile network"

    My WiFi hasn't cut back on automatically since I've done. Thank you for posting this.
  24. #24  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    At long last! This is the answer! Settings>More Settings>Mobile networks>Connections optimizer>Uncheck box that says "automatically select best mobile network"

    My WiFi hasn't cut back on automatically since I've done. Thank you for posting this.
  25. #25  

    Default Re: Wi-Fi on when turned off, keeps trying to connect.

    I was having this same problem. Do you by chance have AT&T? With the new system upgrade (I'm still on the galaxy s3) I had a lot of new stuff pop up. I found an app called AT&T smart wi-fi. I opened it and there was an option to disable the automatic connection. May want to see if that's what's doing it on yours too.
Page 1 of 2 12 LastLast

Similar Threads

  1. S4: How to turn off vibrate for email notifications
    By tabs31 in forum Samsung Galaxy S4
    Replies: 32
    Last Post: 11-24-2014, 11:22 AM
  2. keyboard vibrations wont turn off
    By legend32 in forum Samsung Galaxy S4
    Replies: 7
    Last Post: 08-21-2014, 03:28 PM
  3. Enable text messaging on Galaxy S4
    By kutchal in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 02-19-2014, 07:23 PM
  4. Any one have any good things to say about this phone
    By TheyStoleMyName in forum Samsung Galaxy S4 Active
    Replies: 13
    Last Post: 07-21-2013, 03:01 AM
  5. How to make notification bar transparent Verizon s4
    By jeffruby in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 07-10-2013, 07:45 PM

Posting Permissions