Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default Airplane Mode stays on with my T-Mobile GS4

    Hi, I have a Samsung Galaxy S4, and I went on a trip to England last week, I had airplane mode on the entire time to avoid roaming charges, but when I came back to the States and tried to turn it off, it wouldn't return to normal. It says that airplane mode will be disabled, but I can't get any signal, even with WiFi. I've restarted the phone 3 times and pulled the battery twice, but the problem persists. Help, please!!!!!!!!!!!!!!
  2. #2  

    Default Re: Airplane Mode stays on with my T-Mobile GS4

    Have you checked the settings for the Network and Data usage ?
  3. #3  

    Default Re: Airplane Mode stays on with my T-Mobile GS4

    You may have turned something off in your networks as well. If you pull down Samsung's toolbar and hold wi-fi, can you manually connect?

    BTW, you don't have to be in airplane mode to avoid data roaming charges. Just turn off data roaming over mobile networks. It is often good NOT to be in airplane mode, because you may need the occasional text message that comes through, or whatever. The phone in most places will also set your time and date for you by connecting to foreign networks, if your connected to the mobile network.

    The bugaboo of course is data roaming. That can just be turned off without turning the entire network off.

    Last edited by monsieurms; 07-20-2013 at 08:49 AM.
  4. #4  

    Default Re: Airplane Mode stays on with my T-Mobile GS4

    I solved this problem on my wife's phone by turning off the wifi calling option. I am guessing the wifi calling option on the gs4 is glitching and causing the restrictions that airplane mode enforces. Hope this helps anyone. Good luck and bSmart
  5. #5  

    Default Re: Airplane Mode stays on with my T-Mobile GS4

    Quote Originally Posted by bSmarts View Post
    I solved this problem on my wife's phone by turning off the wifi calling option. I am guessing the wifi calling option on the gs4 is glitching and causing the restrictions that airplane mode enforces. Hope this helps anyone. Good luck and bSmart
    You don't actually have to turn off the Wi-Fi Calling option completely. Most likely the issue was due to the option you had selected under "Wi-Fi Calling Preferences". If it was set to "Never use Cellular Network", then that is what is causing your problems -- I had the exact same issue when this was selected. All you need to do is change the option to "Wi-Fi Preferred", and you should be fine while still having Wi-Fi Calling enabled.
  6. #6  

    Default Re: Airplane Mode stays on with my T-Mobile GS4

    That was so helpful! Problem solved. Thank you so much !

Similar Threads

  1. How do I turn my standard HTC One into a GPE HTC one?
    By aaka3207 in forum HTC One Rooting, ROMs & Hacks
    Replies: 7
    Last Post: 08-01-2013, 12:32 PM
  2. tablet with three drives --- two internal and one external
    By 3dsbrock in forum Android 4.0 Ice Cream Sandwich
    Replies: 4
    Last Post: 07-29-2013, 12:22 PM
  3. "My Places" on the new Google Maps
    By sushiguy732 in forum General News & Discussion
    Replies: 6
    Last Post: 07-25-2013, 09:53 AM
  4. Nova Launcher on CM 10
    By markbehr in forum Sprint Galaxy S3 Rooting, ROMs, and Hacks
    Replies: 2
    Last Post: 07-19-2013, 07:33 PM
  5. Have update But do apps truly go on ExtSd card?
    By HPferoxCraft in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 07-19-2013, 07:29 PM

Posting Permissions

B