Results 1 to 19 of 19
Like Tree2Likes
  • 1 Post By NellieRose
  • 1 Post By sbrochew
  1. Thread Author  Thread Author    #1  

    Default Stock weather widget not updating????

    Sorry if this has been asked or answered......my stock accuweather clock/weather widget the phone came with just stopped updating the other day. It stopped at 4:20 pm and I have tried evrything to get it to update and it just wont. I am currently using Android Weather but I do not like it as much as the stock widget. I have googled some and I see where plenty of people have had the same problem but no one is listing a fix, or solution. Anyone have any ideas?
  2. #2  
    wms3's Avatar

    Posts
    62 Posts
    Global Posts
    730 Global Posts

    Default Re: Stock weather widget not updating????

    I have the opposite problem! Android weather won't update and gives an error when I try to update manually. Accu weather works fine. I wanted a smaller widget to save real estate o my screen.
  3. #3  
    str8bucs's Avatar

    Posts
    63 Posts
    Global Posts
    87 Global Posts

    Default Re: Stock weather widget not updating????

    I delete the widget and add it back... worked for me
  4. #4  
    wms3's Avatar

    Posts
    62 Posts
    Global Posts
    730 Global Posts

    Default Re: Stock weather widget not updating????

    glad you got it working. this did ot work for android weather, so Im using The Weather Channel widget instead.
  5. #5  

    Default Re: Stock weather widget not updating????

    When that happened to me I had to turn off the phone and do a battery pull. Then it worked fine for me.

    Sent from my SCH-R970 using AC Forums mobile app
    Running CyanogenMod 10 on my rooted Galaxy S3!
  6. #6  

    Default Re: Stock weather widget not updating????

    Quote Originally Posted by clintw22 View Post
    When that happened to me I had to turn off the phone and do a battery pull. Then it worked fine for me.

    Sent from my SCH-R970 using AC Forums mobile app
    I'm going to try the the battery pull. And, here I thought leaving my BB I wouldn't be finding the old reliable battery pull as little fixes. ;D
    clintw22 likes this.
  7. Thread Author  Thread Author    #7  

    Default Re: Stock weather widget not updating????

    I got it fixed! I simply deleted my location and then added it again. I did not have to uninstall. I really hope this does not keep happening though. What a pain it would be to do a few times a week!!!
    Thanked by:
    NellieRose likes this.
  8. #8  

    Default Re: Stock weather widget not updating????

    Quote Originally Posted by sbrochew View Post
    I got it fixed! I simply deleted my location and then added it again. I did not have to uninstall. I really hope this does not keep happening though. What a pain it would be to do a few times a week!!!
    I'll give this a try too. Thanks for the update.
  9. #9  

    Cool Re: Stock weather widget not updating????

    On Samsung Galaxy 3, you may want to got into the Settings for the Weather Widget and make sure that the "Auto Refresh Tab" is enabled for Every 1,3,6,12 or 24 Hour(s)!
  10. #10  

    Default Re: Stock weather widget not updating????

    You have to manually add your city, then in the widget swipe DOWN to get to that city. It will then update itself without location services on. You can tell if you did it right if there isn't a GPS icon next to the city.
    Thanked by:
  11. #11  

    Default Re: Stock weather widget not updating????

    You can try the following:
    If you have any task killer - just uninstall or change it's settings.
    I resolve this problem by simply disable my task killer I have DU Battery Saver - I love this programme. In the saver menu - Smart module - I have option Auto clear Apps. By disabling this option, everything was running just fine again. So now I have my current city updated and updates every time with no problems.
    Hope this helps.
  12. #12  

    Default Re: Stock weather widget not updating????

    This is very disappointing.



  13. #13  

    Default Re: Stock weather widget not updating????

    I know this thread isn't new, but I think it might help others researching this issue. The problem is not with the weather widget, at least on 4.3, it's the Launcher.

    There's no need to pull the battery or reboot the device, just go to Settings > More > Application Manager > All, then go to TouchWiz Home and select Force Stop. That will force TouchWiz to close, restart & refresh.

    Simple as that. Now, that being said, we SHOULD NOT have to do this. This is a Samsung bug, not Android, app, or user error. This needs to be fixed.
  14. #14  

    Default Re: Stock weather widget not updating????

    remove any app like task killer or clean master , then try it will work . anyway it works for me.
  15. #15  

    Thumbs up Re: Stock weather widget not updating????

    I tried what you suggested, delete the city and put it back on again. It worked like magic! Thanks.
  16. #16  

    Default Re: Stock weather widget not updating????

    How do I add a location? I can't seem to do anything with a widget except delete it.
  17. #17  

    Default Re: Stock weather widget not updating????

    On Samsung Galaxy Note 3, Go Settings, Device, Easy Mode. Go into the Weather widget, at the bottom is the little circle 'refresh' icon, do the icon, then go into Settings and make sure the 'auto refresh' is set for something useful.
  18. #18  

    Default Re: Stock weather widget not updating????

    Samsung Galaxy S4 weather widget not updating. Stuck on 2.11.14.
  19. #19  

    Default Re: Stock weather widget not updating????

    Samsung Galaxy S4 weather widget not updating. Tried removing battery. Resets and stops working again.

Similar Threads

  1. Error updating IG ?
    By PcNy in forum Google Nexus 4
    Replies: 3
    Last Post: 08-08-2013, 11:17 AM
  2. Updating Apps
    By Suzi1987 in forum Verizon Samsung Galaxy S4
    Replies: 3
    Last Post: 08-08-2013, 09:23 AM
  3. Getting package invalid for app updates
    By jpriest007 in forum Google Play Store
    Replies: 1
    Last Post: 08-08-2013, 08:32 AM
  4. Failed to boot 0x1000-Help!!!
    By kebenifeni in forum AT&T ATRIX
    Replies: 0
    Last Post: 08-08-2013, 08:27 AM
  5. Replies: 0
    Last Post: 08-08-2013, 07:39 AM

Posting Permissions

B