Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 24 of 24
Like Tree2Likes
  • 1 Post By Robert Baragona
  • 1 Post By sillydee
  1. Thread Author  Thread Author    #1  

    Default Galaxy S4: Watchon Notification Icon won't go away!

    I've never used watch on and yesterday the purple notification icon appeared at the top of my screen and kept asking me to set it up. I couldn't never close it. So i went ahead and set it up and the notification icon is still there. Is there anyway to get rid of it without having to go into the app manager and unchecking stop notifications?
  2. #2  
    Leilan's Avatar

    Posts
    40 Posts
    Global Posts
    84 Global Posts

    Default Re: Watchon Notification Icon won't go away!

    Settings> show remote control on notification panel
  3. #3  

    Default Re: Watchon Notification Icon won't go away!

    True, I can go into the app and turn off the nification icon....BUT when I reboot it comes back! I never had this problem until recently. Not sure if it was a recent update or what?!?
  4. #4  

    Default Re: Watchon Notification Icon won't go away!

    Quote Originally Posted by lwenzel View Post
    True, I can go into the app and turn off the nification icon....BUT when I reboot it comes back! I never had this problem until recently. Not sure if it was a recent update or what?!?
    Try clearing the app's data/defaults

    Posted via Android Central App
  5. #5  

    Default Re: Watchon Notification Icon won't go away!

    This is what I did:

    1. Settings
    2. More
    3. Application Manger
    4. Samsung WatchOn
    5. Remove the check for "Show Notifications"

    This doesn't stop the program from starting on powerup, but it removes it from the notifications.
    Thanked by 2:
    Kieron Shepherd likes this.
  6. #6  

    Default Re: Watchon Notification Icon won't go away!

    I just started having the same problem. Unchecking the notification box only lasts until reboot...

    Posted via Android Central App
  7. #7  

    Default Re: Watchon Notification Icon won't go away!

    Just happened to me when I rebooted my phone. I don't mind it in the drop down because it just makes it quicker when I want to use it but I can go without the icon at the top though. I wonder why it just started happening. I've rebooted a couple times over the past week and never came up before. Weird.
    Mobile Devices: S6 Edge, iPhone 6 plus
    Carrier: AT&T
    Computer: MacBook Pro (2012) 8GB RAM, 750GB HDD
    Other devices: iPad Mini
  8. #8  

    Default Re: Watchon Notification Icon won't go away!

    I noticed it about 3 days ago...

    Posted via Android Central App
  9. #9  

    Default Re: Watchon Notification Icon won't go away!

    mine is doing this as well, i emailed the dev from the app page in the play store and told them about the issue, i suggest you guys do it as well... its annoying that it restarts when you restart the phone
  10. #10  

    Default Re: Watchon Notification Icon won't go away!

    This happens to me too!!
  11. #11  

    Default Re: Watchon Notification Icon won't go away!

    I started this thread a couple days ago. Might help with more questions. Looks like its just a bug that need to get fixed.

    Why is Watch On showing up in my notification area on restart?
  12. #12  

    Default Re: Watchon Notification Icon won't go away!

    This is happening because of an update to the WatchOn app in the Play Store. It may be because of a change in policies in 4.3 (I may be wrong about this, so take it with a grain of salt). Now, I believe apps are required to put a persistent notification in the status bar if they're running (or something to that effect).
  13. #13  

    Wink Re: Watchon Notification Icon won't go away!

    I have had this same problem. Did not notice it until I opened the app to show someone else and it would not close. Here is what I did:

    > settings > application manager>downloaded apps

    I selected the watchon app. There were two running. The video app and the actual app itself.

    I uninstalled updates on both of them

    Restarted my phone

    It will update them automatically if you have selected. As long as you do not open it again, you should be good to go. Have not had a problem since then.
  14. #14  

    Default Re: Watchon Notification Icon won't go away!

    I have been having the same issue.

    I like the application and use it quite often to control my tv, But that notification icon and controller in the notification bar is very annoying.

    Disabling until there is a fix.
  15. #15  

    Default Re: Watchon Notification Icon won't go away!

    I figured out how to stop it. Just open the app then hit the menu key. There is a Setting option. Scroll down to the Notification section and change the options.
    Thanked by 2:
  16. #16  

    Default Re: Watchon Notification Icon won't go away!

    Settings>more>application manager>watch on>force stop
  17. #17  

    Default Re: Watchon Notification Icon won't go away!

    This worked for me. Even after a reboot. Thanks,
  18. #18  

    Default Re: Watchon Notification Icon won't go away!

    I dont know if it was solved, but there is a much easier way to solve it without disabling or stopping the Watchon app. Just go to the app, I have s4, so I click the menu button and get choices such as: change room, edit channels, settings etc... You want to go to settings, then scroll down and there will be a section titled notifications and you can check or uncheck the option that reads: Show remote control on notification panel. Uncheck that box and you should be set.
    Thanked by:
  19. #19  

    Default Re: Watchon Notification Icon won't go away!

    might not have shut it down 100% but the icons gone so out of sight out of mind and all that thanks mate
  20. #20  

    Default Re: Watchon Notification Icon won't go away!

    This actually solves my problem! Thank you!
    Open watchon> settings>Notifications>Untick the box which says "show remote control on notif panel" And turn off "auto display remote control on lock screen".. this is for s4 and android 4.3.
    komunist likes this.
  21. #21  

    Default Re: Galaxy S4: Watchon Notification Icon won't go away!

    Hi all I had this problem on my samsung s4. I figured out how to get rid of this annoying app watchon.
    Go to settings, the select the more tab at the top the select application manager the select watchon. THEN SELECT uninstall updates when you Confirm it will ask you to set back to factory default select yes and this will get rid of it on all occasions and any previous settings will be erased for this app.
  22. #22  

    Default Re: Galaxy S4: Watchon Notification Icon won't go away!

    YEAH thats solution for sure !!! THANX A LOT!
  23. #23  

    Default Re: Galaxy S4: Watchon Notification Icon won't go away!

    If you don't use it just disable it.
  24. #24  

    Default Re: Galaxy S4: Watchon Notification Icon won't go away!

    To turn it off you need to go to application manager and search ALL. Once you get to Watch on open it and force stop. Don't use the Running Section use the All Section

Similar Threads

  1. HTC One: How to set an mp3 as a notification sound?
    By lachdanan in forum HTC One M7
    Replies: 18
    Last Post: 01-16-2015, 08:58 PM
  2. Samsung Galaxy S4 doesn't send text notification
    By Wayfarer315 in forum General Help and How To
    Replies: 3
    Last Post: 01-19-2014, 02:07 AM
  3. Galaxy s3 - No power on, Won't Charge!
    By Erinn GainGreen in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 08-11-2013, 05:16 PM
  4. Number of rings before going to voice mail.
    By peterclewes in forum Google Nexus 4
    Replies: 0
    Last Post: 08-11-2013, 04:03 PM
  5. Replies: 0
    Last Post: 08-11-2013, 03:46 PM

Posting Permissions