Results 1 to 8 of 8
  1. Thread Author  Thread Author    #1  

    Default Samsung Galaxy S4 - Problem with sim card/network after repair

    Hey guys, I've been looking around the internet for days now and still can't find a solution to my problem, so here goes. I recently had my galaxy s4 repaired by a third party repairer, I've had phones repaired by them before and they've been fine. Anyway, the phones working well, except it doesn't read the sim card, I just get a circle with a line through it displayed where the signal strength should be. It also doesn't allow me to search for networks at all. I've tried factory resetting the phone also, several times. The phone detects when a sim card isn't inserted, so it's got me thinking that maybe it isn't the sim card reader, however the sim works fine in other phones. Is it possible something could of been damaged when it was being fixed? I'd really like to know if there's any information for this out there before I go spending more money on the thing.
    Thanks,
    Aaron.
    Samsung Galaxy S4 - Problem with sim card/network after repair-screenshot_2013-11-10-09-01-06-1-.jpg
  2. #2  

    Default Re: Samsung Galaxy S4 - Problem with sim card/network after repair

    Hey Aaaron,

    I am having the exact issue you were. I have tried everything, still no joy . Were you able to fix it and how?

    Karin
  3. #3  
    STARGATE's Avatar

    Posts
    3,773 Posts
    Global Posts
    4,101 Global Posts
    ROM
    None

    Default Re: Samsung Galaxy S4 - Problem with sim card/network after repair

    Hello guys!
    Who's your carrier?

    I had a similar problem back in July and I got it sorted out but I'm with Sprint.

    Sent From Inside The TARDIS in a Galaxy S4 Away!
    If I'm very clever, and I'm more than clever, I'm brilliant! I might just save the World, or rip it apart!
  4. #4  

    Default Re: Samsung Galaxy S4 - Problem with sim card/network after repair

    I've been having the same problem for a month now not being able to make a call or use the Internet. Only if I connect to wifi can I use the Internet. I've tried everything factory reset 2 times still nothing. If you got yours to work please let me know what you did to fix it I would appreciate it a lot. I don't have insurance and samsung said it's out of warranty and I really don't want to get another phone
  5. #5  

    Default Re: Samsung Galaxy S4 - Problem with sim card/network after repair

    Same problem.... Help
  6. #6  

    Default Re: Samsung Galaxy S4 - Problem with sim card/network after repair

    Hey there

    Ive got the same problem as well and i sent mine of to get fixed n it was working fine but when they decided to recheck the phone b4 they send it back and it wasnt working,they reckon it might be a software problem coz i did replace the sim tray n it stil didnt work so i might have to reboot the phone,but if any of use manage to fix your guys phone can u help me out as wel.lol

    Thanks
  7. #7  
    metle_geek's Avatar
    Banned

    Posts
    829 Posts
    Global Posts
    831 Global Posts

    Default Re: Samsung Galaxy S4 - Problem with sim card/network after repair

    Either that or the system board isn't reading it seems to be a problem I was talking to a guy a week ago about this and they changed his system board and it worked I blame faulty soldering personally or bad ribbon cables

    Sent from my SAMSUNG-SGH-I337 using AC Forums mobile app
  8. #8  

    Default Re: Samsung Galaxy S4 - Problem with sim card/network after repair

    Quote Originally Posted by aaron2195 View Post
    Hey guys, I've been looking around the internet for days now and still can't find a solution to my problem, so here goes. I recently had my galaxy s4 repaired by a third party repairer, I've had phones repaired by them before and they've been fine. Anyway, the phones working well, except it doesn't read the sim card, I just get a circle with a line through it displayed where the signal strength should be. It also doesn't allow me to search for networks at all. I've tried factory resetting the phone also, several times. The phone detects when a sim card isn't inserted, so it's got me thinking that maybe it isn't the sim card reader, however the sim works fine in other phones. Is it possible something could of been damaged when it was being fixed? I'd really like to know if there's any information for this out there before I go spending more money on the thing.
    Thanks,
    Aaron.
    Click image for larger version. 

Name:	Screenshot_2013-11-10-09-01-06[1].jpg 
Views:	20 
Size:	95.5 KB 
ID:	90912

Similar Threads

  1. Replies: 17
    Last Post: 02-22-2014, 04:02 PM
  2. No MMS with any 3rd Party App
    By Bruce Jenner in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 5
    Last Post: 01-14-2014, 04:54 PM
  3. Foxfi on a T-mobile S4
    By rsxtcy4me in forum T-Mobile Samsung Galaxy S4
    Replies: 4
    Last Post: 12-22-2013, 08:58 PM
  4. Samsung Galaxy Note 10.1 (2014) College Student considering note 10.1
    By ewgrosschris in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 8
    Last Post: 12-14-2013, 03:34 PM
  5. Foxfi on a T-mobile S4
    By rsxtcy4me in forum Samsung Galaxy S4
    Replies: 0
    Last Post: 11-10-2013, 01:52 PM

Posting Permissions

B