1. tomvanavermaet's Avatar
    Hello everyone,

    Something quite annoying (extremely annoying) and confusing happend to me today. All of a sudden my Samsung S4 was unable to connect to any mobile internet network (the mobile network itself seems to connect fine). I then connected to several different wifi networks and although it connects to the network, there doesn't seem to be actually an internet connection being established.

    This happened all of a sudden and without any real explanation. I tried rebooting numerous times, taking out the battery, changing sims (same problem with both my sims US & European). Currently on a roaming network, but this wasn't a problem before.

    Also the fact that no wifi connection is working (connecting but not getting data) never happened to me before. I cleared the cache from the internet, cleared the memory cache, but to no avail. I tried to wipe the cache partition in the recovery mode, but couldn't do that (just got error)

    I have a US Samsung S4 - unlocked.

    Any help, insight would be really appreciated as I don't know what to do and this is extremely annoying as I need to be connected as much as I can

    Tom
    11-19-2013 05:04 AM
  2. Haalcyon's Avatar
    Welcome to Android Central!

    Well, taking your phone into the carrier is always a safe bet. However, you could always back up your phone and do a factory reset (keep that thought in your hip pocket). Helium Backup is great for backups. Pop into settings Networks -->More--> Mobile Networks (I'm wing'n it, I no longer has a Samsung phone) and take a look at your mobile network settings. Does anything seem amiss here? Everything checked that should be? You could try toggling a few settings like Network mode (or the equivalent) and rebooting to see if that makes any difference. Worse comes to worse you can do that backup (if you want) and do a factory reset.
    11-19-2013 05:35 AM
  3. tomvanavermaet's Avatar
    Hey Haalcyon, thanks for the advice, as the phone is unlocked it's not bound to a carrier. I can't easily take it into the shop where I bought and unlocked it as it's in Los Angeles. The factory reset might also not be an option because of that as I would then probably lose my unlocked mode, right?

    Any other opions on this or people who had this happen, my mobile network isn't even connecting to the 4G or regular data network.
    Could my internal antenna be broken or something, any way I can check this?
    11-19-2013 05:54 AM
  4. tomvanavermaet's Avatar
    Haven't updated yet either, version is 4.2.2.
    11-19-2013 06:02 AM
  5. Haalcyon's Avatar
    The factory reset might also not be an option because of that as I would then probably lose my unlocked mode, right?
    Now that is a good question and one of which I don't know the answer.
    11-19-2013 07:43 AM
  6. Edible Walrus's Avatar
    Hey Haalcyon, thanks for the advice, as the phone is unlocked it's not bound to a carrier. I can't easily take it into the shop where I bought and unlocked it as it's in Los Angeles. The factory reset might also not be an option because of that as I would then probably lose my unlocked mode, right?

    Any other opions on this or people who had this happen, my mobile network isn't even connecting to the 4G or regular data network.
    Could my internal antenna be broken or something, any way I can check this?
    I had this happen intermittently with calls and data for unknown reasons. I cleared the phone apps cache and data and it's been okay since then (now I've jinxed it)

    Posted via Android Central App
    11-19-2013 02:52 PM
  7. tomvanavermaet's Avatar
    Tried cleaning the memory cache, is there another way to clear cache (the reboot mode give me an error when I want to do it via that)

    I had this happen intermittently with calls and data for unknown reasons. I cleared the phone apps cache and data and it's been okay since then (now I've jinxed it)

    Posted via Android Central App
    11-19-2013 04:41 PM
  8. tomvanavermaet's Avatar
    Correction, it seems I can access the wifi networks and I contacted my provider and it seems to be a dataroaming issue. Hope it gets sorted too, at least it's not a phone problem.
    11-19-2013 04:56 PM
  9. michie10's Avatar
    Hi there. I faced that problem today. I found that by 1. Turning off mobile data, 2. Deleting the APN 3. Restarting the phone 4. Adding back the same APN works like a charm. Why not give that a try.
    01-03-2014 06:51 AM
  10. tmozer's Avatar
    Hi there. I faced that problem today. I found that by 1. Turning off mobile data, 2. Deleting the APN 3. Restarting the phone 4. Adding back the same APN works like a charm. Why not give that a try.
    What is APN 3 and where would it be found (to delete)?
    01-03-2014 07:22 AM
  11. Ted Nicholas1's Avatar
    My S4 too has suddenly stopped connecting to the internet both through wifi and mobile network even though it says it is connected to both my home wifi as well as the mobile network. I have rebooted multiple times and have even reset my home wifi but nothing has seemed to work.
    05-21-2014 04:33 AM
  12. Ted Nicholas1's Avatar
    Ok well instagram as well as skype seem to be a couple of the few apps that are able to connect to the internet through wifi, however facebook, google play and snapchat are a few apps which cannot. What is going on?
    05-21-2014 04:37 AM
  13. Juliet Newson's Avatar
    I feel your pain. My unlocked S4 lost internet connections a few weeks ago, then after fiddling with APN etc, picked it up again, but now completely lost, hasn't worked for over a week, no matter what I do, or where I am.

    It picks up the mobile network (vodafone New Zealand) just fine, although not so good at my house as we have a very weak signal there.

    Please can someone help? No-one I speak to has a clue.
    06-19-2014 09:57 PM
  14. Another Droid's Avatar
    THis problem has occurred many times on several android phones. The only solution I find is to back up contacts then perform a factory reset.
    04-28-2015 02:48 AM
  15. Mohis's Avatar
    I've had no luck in the above, anything else I can try peeps?
    04-30-2015 02:34 PM
  16. Black Widow 5's Avatar
    1. Turning off mobile data
    2. Deleting the APN
    3. Restarting the phone
    4. Adding back the same APN works like a charm

    Rewritten.
    02-13-2016 07:52 AM
  17. Deliscon's Avatar
    Make sure your clock is correct. if it's not, go to "date and time settings" and check "Automatic date and time"

    Worked for me.
    08-26-2016 06:38 PM

Similar Threads

  1. Replies: 10
    Last Post: 08-08-2016, 02:20 PM
  2. Replies: 9
    Last Post: 11-20-2013, 07:57 PM
  3. I see the Note II just got 4.3
    By Zookeeper63 in forum HTC EVO 4G LTE
    Replies: 1
    Last Post: 11-20-2013, 03:16 PM
  4. s4 problems
    By sfilansno1fan in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 11-19-2013, 06:45 AM
LINK TO POST COPIED TO CLIPBOARD