Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By Haalcyon
  1. Thread Author  Thread Author    #1  

    Default s4 back button not working - is there any other option to go back

    My s4 got wet near the charge port, and now the settings and back soft buttons are not working - is there any other option to go back as it is very limiting without the back button.

    Thanks.
  2. #2  
    Haalcyon's Avatar

    Posts
    5,730 Posts
    Global Posts
    6,211 Global Posts
    ROM
    CM 10.2

    Default Re: s4 back button not working - is there any other option to go back

    Welcome to the forums!

    I'm not aware of any other options other than sending the phone in for repair and that's what I recommend.
    Live long and prosper.


    Red_Berry_21 likes this.
  3. #3  

    Default Re: s4 back button not working - is there any other option to go back

    Yeah there is no other way id do what haalcyon said send it for repairs because if you leave it any longer then your not gunna have no phone

    Sent from my C6603 using AC Forums mobile app
  4. #4  

    Default Re: s4 back button not working - is there any other option to go back

    You can always download a soft key emulator from Google Play for the time being.

    Posted via Android Central App
  5. #5  
    Haalcyon's Avatar

    Posts
    5,730 Posts
    Global Posts
    6,211 Global Posts
    ROM
    CM 10.2

    Default Re: s4 back button not working - is there any other option to go back

    Quote Originally Posted by graysonk95 View Post
    You can always download a soft key emulator from Google Play for the time being.

    Posted via Android Central App
    Perhaps you can share a link to a good choice?

    gp8.3
    Last edited by Haalcyon; 12-09-2013 at 12:47 AM.
    Live long and prosper.


  6. #6  

    Default Re: s4 back button not working - is there any other option to go back

    Search the play store for an app called pie control (I do not have it specifically). If it does not need root, then try it. I am rooted and use a pie control all the time, just not that one. May or may not help? Good luck.

    Sent from my SCH-I545 using Tapatalk

Similar Threads

  1. Galaxy S Blaze Booting to Odin Mode After Attempted Firmware Upgrade
    By simpmg in forum T-Mobile Galaxy S Blaze 4G
    Replies: 1
    Last Post: 12-10-2013, 07:42 PM
  2. according to Android police
    By stackberry369 in forum General News & Discussion
    Replies: 5
    Last Post: 12-08-2013, 03:09 PM
  3. Regular Tab 3 to Tab Kids?
    By airos4 in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 12-07-2013, 10:55 PM
  4. MMS not loading in Hangouts
    By rich maddox in forum T-Mobile Samsung Galaxy Note 3
    Replies: 1
    Last Post: 12-07-2013, 10:44 PM
  5. Help resetting Galaxy S4 to stock
    By adam.bean in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 12-07-2013, 08:08 PM

Posting Permissions

B