Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  

    Default OTG SD-card unmounts automatically

    Hi

    I got an OTG USB/card reader for my S4 (9505) in October. Worked great, could transfer files between an SD card and my phone.

    Updated from 4.2 to 4.3 in December. Thought I tested everything worked but apparently not, because when now when I plug it in it detects it but I immediately get the message "USB mass storage safely removed". Don't know if the update is the cause but it's the most significant change to my phone that I can think of.

    Under Settings > More > Storage, the option is there to mount OTG storage, but selecting it does nothing. I've tried various OTG diagnostic/checking apps, they can all detect it, even that I'm using a 16 GB SD card with it. But I can't actually use the 'darn' thing.

    Any suggestions would be greatly appreciated. Phone is not rooted. I'm currently away from home so I wouldn't be able to make use of a solution that needs a PC . This is also why I need this device to work - to back up my photos from my (non-phone) camera because I have no other way.

    Incase it's relevant:
    Model GT-I9505
    Android 4.3
    Baseband I9505XXUEMKF
    Kernal 3.4.0-2082040
    Build JSS15J.I9505XXUEMKF

    Thanks in advance.
    Last edited by GlacialDrift; 02-20-2014 at 06:17 AM. Reason: Adding version details

Similar Threads

  1. Encrypt SD Card
    By AMG_Roadster in forum AirWatch
    Replies: 9
    Last Post: 02-22-2014, 01:21 PM
  2. Nexus 4 + LTE Sim Card Question
    By Sun Hyung Hong in forum Google Nexus 4
    Replies: 2
    Last Post: 02-19-2014, 11:53 PM
  3. Linking data to SD card?
    By moeed in forum General Help and How To
    Replies: 1
    Last Post: 02-19-2014, 03:11 PM

Posting Permissions

B