Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
  1. Thread Author  Thread Author    #1  

    Default Brand new Galaxy S4 not auto connecting to Wifi

    Hello to you all,

    I hope someone can help out with this problem. My girlfriend recently got an S4 and as the title suggests it is not auto connecting to our home Wifi. Every other phone we have had auto connects as soon as you turn Wifi on when getting home.

    I've searched online and have tried suggestions but it still won't connect automatically, you have to select the network from the available list and press connect. The password is saved so at least you don't have to input that all the time.

    If it helps, S4 is stock, locked to EE network in the UK and running latest Android 4.4.2 update.

    Thanks in advance

    Joe
  2. #2  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Did you find a solution to this because I'm having the same problem with my new S5.
  3. #3  
    mhinc's Avatar

    Posts
    693 Posts
    Global Posts
    956 Global Posts

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Quote Originally Posted by Joedm45 View Post
    Hello to you all,

    I hope someone can help out with this problem. My girlfriend recently got an S4 and as the title suggests it is not auto connecting to our home Wifi. Every other phone we have had auto connects as soon as you turn Wifi on when getting home.

    I've searched online and have tried suggestions but it still won't connect automatically, you have to select the network from the available list and press connect. The password is saved so at least you don't have to input that all the time.

    If it helps, S4 is stock, locked to EE network in the UK and running latest Android 4.4.2 update.

    Thanks in advance

    Joe
    First question. Does it connect to other networks automatically, have you tried any other than just your home?
    Second. Have you had your S4 "FORGET" the wifo info and tried to choose the connection again fresh, typing in the password again?
    Thrid if the above doesn't work. Forget the info again on your phone. And power cycle aka unplug your router for 5 seconds, plug it back in, wait 30
    seconds and then try to connect fresh to your network again.
    Still would like an answer to the first question though
    Samsung Galaxy S4 SGH-I337M - 4.2.2
    Telus Mobility
    Niagara Falls, Ontario, Canada
    ---
    Thanked by:
  4. #4  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Two days ago, my 8 month old s4 stopped connecting to wifi. It would just hang when I toggled it on in the quick settings. I fixed this with a battery pull, however I lost all of my passwords etc. Might be something similar.
  5. Thread Author  Thread Author    #5  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Quote Originally Posted by mhinc View Post
    First question. Does it connect to other networks automatically, have you tried any other than just your home?
    Second. Have you had your S4 "FORGET" the wifo info and tried to choose the connection again fresh, typing in the password again?
    Thrid if the above doesn't work. Forget the info again on your phone. And power cycle aka unplug your router for 5 seconds, plug it back in, wait 30
    seconds and then try to connect fresh to your network again.
    Still would like an answer to the first question though
    Thanks for your response, to answer your questions:
    I haven't tried other networks but will give it a go tomorrow as we'll be out & about somewhere I know the password to.
    I've tried forgetting the network and re-type password with no joy. It remembers the network again but doesn't auto connect.
    I've also tried the power cycle on the router with no luck either.

    I appreciate it's not a major problem and more of an annoyance but there must be a solution somehow.

    Thanks again

    Joe
  6. #6  
    mhinc's Avatar

    Posts
    693 Posts
    Global Posts
    956 Global Posts

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Quote Originally Posted by Joedm45 View Post
    Thanks for your response, to answer your questions:
    I haven't tried other networks but will give it a go tomorrow as we'll be out & about somewhere I know the password to.
    I've tried forgetting the network and re-type password with no joy. It remembers the network again but doesn't auto connect.
    I've also tried the power cycle on the router with no luck either.

    I appreciate it's not a major problem and more of an annoyance but there must be a solution somehow.

    Thanks again

    Joe
    Frankly I would consider it a major problem, especially if you like to reserve your data like I do, and happen to forget to manually connect to your WIFI because your phone is NOT doing as it should.
    I look forward to hearing if you are successful conneciton to the other network you know the pw for. Please let me know. If THAT does the same thing as your experience at home. I would contact Samsung or whomever you got your phone from as there is an issue. If it DOES work at the other place, I would guess it's a router setting, but I have never heard of it connecting manually but not auto. So I am pushing more towards phone. Guess we shall see!
    Samsung Galaxy S4 SGH-I337M - 4.2.2
    Telus Mobility
    Niagara Falls, Ontario, Canada
    ---
  7. Thread Author  Thread Author    #7  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Quote Originally Posted by mhinc View Post
    Frankly I would consider it a major problem, especially if you like to reserve your data like I do, and happen to forget to manually connect to your WIFI because your phone is NOT doing as it should.
    I look forward to hearing if you are successful conneciton to the other network you know the pw for. Please let me know. If THAT does the same thing as your experience at home. I would contact Samsung or whomever you got your phone from as there is an issue. If it DOES work at the other place, I would guess it's a router setting, but I have never heard of it connecting manually but not auto. So I am pushing more towards phone. Guess we shall see!
    Thanks again for your help.
    I've now tested on another network and the same happens, connects manually but not automatically.
    I have searched online with this problem and there is nothing recent so it can't be a 4.4.2 glitch as more people would have complained about it.
    I will get my girlfriend to contact the phone supplier and go through the relentless useless questions they ask before agreeing there is a fault lol!

    Thanks again, you have been most helpful

    Joe
  8. #8  
    mhinc's Avatar

    Posts
    693 Posts
    Global Posts
    956 Global Posts

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Quote Originally Posted by Joedm45 View Post
    Thanks again for your help.
    I've now tested on another network and the same happens, connects manually but not automatically.
    I have searched online with this problem and there is nothing recent so it can't be a 4.4.2 glitch as more people would have complained about it.
    I will get my girlfriend to contact the phone supplier and go through the relentless useless questions they ask before agreeing there is a fault lol!

    Thanks again, you have been most helpful

    Joe
    Joe there is one last thing. It COULD be an app you have installed. Something as simple as a virus program or something that's TOLD wifi to connect manually for security
    reasons. Sometimes it's always the simple reason. I would check that one last thing.
    Samsung Galaxy S4 SGH-I337M - 4.2.2
    Telus Mobility
    Niagara Falls, Ontario, Canada
    ---
  9. #9  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Hey Joe and everyone else having problems with your Galaxy s4 not automatically connecting to wifi. I finally found the number to call samsung and get the answer 888-987-4357. All you need to do is go into your wifi settings and open it by tapping the name of it. A window will open asking you to either edit, view, or forget. Tap the forget button and then take your battery out and wait 30 seconds. Then just sign back into your wifi. It worked for me. The hardest freaking thing is getting the otter box case off. Good luck
  10. #10  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Quote Originally Posted by jim bindewald View Post
    Hey Joe and everyone else having problems with your Galaxy s4 not automatically connecting to wifi. I finally found the number to call samsung and get the answer 888-987-4357. All you need to do is go into your wifi settings and open it by tapping the name of it. A window will open asking you to either edit, view, or forget. Tap the forget button and then take your battery out and wait 30 seconds. Then just sign back into your wifi. It worked for me. The hardest freaking thing is getting the otter box case off. Good luck

    I have similar issue but Battery pull and forget network has not worked.

    It is the same on other wifi networks.

    I am also on 4.4.2 with the EE network. I think this is a operating system issue.
  11. #11  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Quote Originally Posted by tucker61 View Post
    I have similar issue but Battery pull and forget network has not worked.

    It is the same on other wifi networks.

    I am also on 4.4.2 with the EE network. I think this is a operating system issue.
    Same here. Wish ee would provide an update.
  12. #12  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    I have the same with my S4 on EE. The other day it was connecting automatically for 2 days now it's gone back to me having to manually connect it.

    Posted via Android Central App
  13. #13  

    Default Re: Brand new Galaxy S4 not auto connecting to Wifi

    Hey Joe, Have you sorted out the problem with you S4? If not try this simple technique I have a similar problem not only on wifi but also in 3G/4G. Go to setting, From Network connection tap the Wi-Fi, then the menu (it is left side of the home button) tap the advance. Then uncheck the "auto network switch" hope that this works for you.

Similar Threads

  1. Need Help: Japanese Galaxy S5
    By Hellbound in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 04-07-2014, 10:23 PM

Posting Permissions