1. kristian19's Avatar
    I upgraded to KitKat and my phone was working flawless. Decided to do a wipe my phone clean, start fresh with KitKat now I'm having issues with my SGH-I337m.

    I can have full service at my house (as of now for ex.) but my LTE/4G Mobile Data data refuses to connect even with the check box toggled on. If I restart my phone it works perfectly fine after that, but then a few hours later it repeats it self and refuses to connect.

    Just seeing if anyone else has had this issue in the past and would be keen on sharing any tips or solutions.

    -Cheers
    04-18-2014 09:16 AM
  2. Joe Vile's Avatar
    How to Upgrade / Install Android 4.4 KITKAT on Sa:

    Posted via Android Central App
    04-20-2014 12:54 PM
  3. Joe Vile's Avatar
    Theres a link in the description to flash a different modem

    Posted via Android Central App
    04-20-2014 12:54 PM
  4. kristian19's Avatar
    update: turned off juice defender and it seems to hold signal throughout the day now. might be a bug with the battery saving app.
    04-21-2014 04:12 PM

Similar Threads

  1. rear camera not working
    By dcastillo in forum Moto X (2013)
    Replies: 29
    Last Post: 04-07-2017, 01:47 AM
  2. The Official: I love my Galaxy S5 thread
    By Davyo in forum Samsung Galaxy S5
    Replies: 84
    Last Post: 09-05-2015, 05:39 PM
  3. Not getting Push Notifications on Nexus 4 on Wifi
    By PogoMips in forum Android 4.4 KitKat
    Replies: 1
    Last Post: 07-05-2014, 11:36 AM
  4. Downloading... Do not turn off target!!!
    By UscTheGamer427 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 04-18-2014, 08:59 AM
  5. Galaxy S4 Mini (Korean version) - debrand?
    By mjr8591 in forum Samsung Galaxy S4 Mini
    Replies: 0
    Last Post: 04-18-2014, 08:19 AM
LINK TO POST COPIED TO CLIPBOARD