Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default I just updated to kitkat, no problems

    I just updated to kitkat, and my s4 is completely normal!
    Why all the buzz about how it will ruin your device?

    Posted via Android Central App
  2. #2  

    Default Re: I just updated to kitkat, no problems

    Its not that it will ruin your device, many just don't like the performance or " lack of " they seem to get once updated. Plus just like any major OS update there are changes, some good and some bad and consumers don't always approve of what Google or the OEM has changed.

    Hope things continue to work out for you! My wife complained a bit at first but now its water under the bridge
    Paul
    Moderator Team Leader @ Android Central

    I am the Tegra Champ. What this means is that from time to time NVIDIA might send me new products to try out. This will not affect my thoughts, ideas, or opinions about any product that are discussed in the forums. Those are still my own.
  3. #3  
    Golfdriver97's Avatar

    Posts
    23,772 Posts
    Global Posts
    24,214 Global Posts
    ROM
    SlimKat

    Default Re: I just updated to kitkat, no problems

    Because KitKat modified the SD card use in the OS.

    Phone Timeline
    What could not be changed, must be endured - New Spring, by Robert Jordan
    Community Guidelines and also here, Developer Rules, and Marketplace
    Mobile Nations Sister Forums: iMore/Connectedly/Windows Central/Crackberry

Similar Threads

  1. Replies: 12
    Last Post: 10-04-2014, 03:33 AM
  2. Will updating loose root
    By Nick Bruton in forum HTC One M8 Rooting, ROMs, & Hacks
    Replies: 12
    Last Post: 06-21-2014, 03:32 PM
  3. Replies: 12
    Last Post: 05-30-2014, 10:21 AM
  4. android wall how to
    By Marco Feijoo in forum T-Mobile Samsung Galaxy Note 3
    Replies: 2
    Last Post: 05-28-2014, 01:10 PM
  5. lg optimus g pro: no sound
    By jap54 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 2
    Last Post: 05-27-2014, 10:15 AM

Posting Permissions