Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. Thread Author  Thread Author    #1  

    Default S4 has no indication of it charging, yet it is.

    I recently dropped my phone in water like the fool that I am.

    Once dry, everything seemed to be working okay, aside from the fact that it wouldn't charge due to the "temperature being too low". I then ordered a new charging port and replaced it, hoping that this would fix the issue.

    Now my phone charges, however there is no indicators that it is doing so. (no vibration, no icon next to battery life etc.) I feel like this might be an issue? Might overheat during charging?

    My menu/back button have now stopped working which is also equally annoying!

    Any thoughts on fixing this?
  2. #2  
    Golfdriver97's Avatar

    31,319 Posts
    Global Posts
    31,817 Global Posts
    Pure Nexus/Franco Kernel

    Default Re: S4 has no indication of it charging, yet it is.

    The downside to water damaged devices is this may only be the start of your trouble. Right now I would have to say you probably need to replace at least the screen assembly, but like I said, this may only be the beginning.

    Do you have insurance on the device? I would look at that before dropping any more money into this.
  3. Thread Author  Thread Author    #3  

    Default Re: S4 has no indication of it charging, yet it is.

    No insurance on the device sadly, but even if I did I don't think it covers water damage.

    Ive arranged an appointment with the samsung geek squad to see what they have to say on the matter but until then im just hoping it holds out for a while!

Similar Threads

  1. Ported S-Health APK from Samsung Galaxy S4
    By jarombautista in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 09-10-2014, 06:37 AM
  2. Is OK Google Working in 4.4.3 Update for Nexus 5 ???
    By Chaitanya Kumar2 in forum Android 4.4 KitKat
    Replies: 4
    Last Post: 06-09-2014, 07:37 PM
  3. Any sprint users get 4.4.3 yet?
    By Brian Low in forum Google Nexus 5
    Replies: 5
    Last Post: 06-08-2014, 11:00 PM
  4. Phone recognizes that it's plugged in, but doesn't charge
    By csdude55 in forum Sprint Epic 4G
    Replies: 1
    Last Post: 06-06-2014, 12:19 PM
  5. No pics over 32K through text
    By creek4353 in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 06-06-2014, 02:21 AM

Posting Permissions