Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
Like Tree3Likes
  • 1 Post By hardrocker89
  • 1 Post By tlo07
  • 1 Post By Masum56k
  1. Thread Author  Thread Author    #1  

    Default Incoming Call From --Turn it off?

    Whenever a call comes in, a voice anounces the caller by name. I have talked with both samsung and the best buy samsung guru and nothing works to then this off. Any ideas?
    I love the phone - am leaving the dark side and Apple.
  2. #2  

    Default Re: Incoming Call From --Turn it off?

    Do you have driving/hands free mode turned on?

    Sent from my SPH-L720 using Tapatalk
    GeekNews likes this.
  3. #3  
    tlo07's Avatar

    Posts
    258 Posts
    Global Posts
    1,201 Global Posts

    Default Re: Incoming Call From --Turn it off?

    Go into Settings>accessibility>vision and make sure TalkBack is off.

    Sent from my iPad using Tapatalk HD
    GeekNews likes this.
  4. #4  

    Default Re: Incoming Call From --Turn it off?

    Did you manage to fix this?? I'm still having this issue. Spoke to Samsung and they were as helpful as a chocolate tea pot! Turn everything (previously mentioned off) and then factory reset it. Any more ideas how to stop the phone reading out who's calling?
  5. #5  

    Default Re: Incoming Call From --Turn it off?

    Go to Settings -> Language and input -> Scroll down to Read Notifications aloud and make sure they are all unchecked.
  6. #6  

    Default Re: Incoming Call From --Turn it off?

    I'm also facing the same boring thing..


    Sent from my SM-G900H using AC Forums mobile app
  7. #7  

    Default Re: Incoming Call From --Turn it off?

    Thanked by:
  8. #8  

    Default Re: Incoming Call From --Turn it off?

    Quote Originally Posted by MartinisandStilettos View Post
    Thanks Boss. Issue Solved. 👍

    Sent from my SM-G900H using AC Forums mobile app
  9. #9  

    Default Re: Incoming Call From --Turn it off?

    Quote Originally Posted by jackskellington6 View Post
    Go to Settings -> Language and input -> Scroll down to Read Notifications aloud and make sure they are all unchecked.
    I just turned ON to have the phone read aloud "Calls from favorite contacts" and "Messages from priority senders."

    Thanks, I never knew the phone had those features.
  10. #10  

    Default Re: Incoming Call From --Turn it off?

    Unchecking all the 'read notifications aloud' worked but now it won't read out callers if I turn hands free mode on. I can either have it read them out all the time, or never. What's the point of a hands free mode then?!
  11. #11  

    Default Re: Incoming Call From --Turn it off?

    Quote Originally Posted by scrabbley View Post
    Unchecking all the 'read notifications aloud' worked but now it won't read out callers if I turn hands free mode on. I can either have it read them out all the time, or never. What's the point of a hands free mode then?!
  12. #12  

    Default Re: Incoming Call From --Turn it off?

    I just figured it out on my phone. Its stupid really. You have to make sure you don't have "answer incoming calls with voice" turned on. If you do, the phone will automatically talk to you so that you can reply. It took me forever to figure it out. Go to accessibility> answer and ending calls> voice control & make sure it is unchecked.
    Thanked by:
  13. #13  

    Default Re: Incoming Call From --Turn it off?

    Thats the only thing that worked for me (You have to make sure you don't have "answer incoming calls with voice" turned on. )

Similar Threads

  1. Replies: 14
    Last Post: 04-13-2014, 07:48 AM
  2. Galaxy S5: Worth it to upgrade from Galaxy S3 ?
    By MeNTaIPaTleNT in forum Samsung Galaxy S5
    Replies: 12
    Last Post: 04-13-2014, 07:29 AM
  3. Replies: 5
    Last Post: 04-12-2014, 08:11 PM
  4. Calendar doesnt notify me.. Should I return it?
    By demarco5 in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 04-12-2014, 10:56 AM
  5. Replies: 0
    Last Post: 04-12-2014, 10:36 AM

Posting Permissions