Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 53
Like Tree5Likes
  1. Thread Author  Thread Author    #1  

    Default Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Hi
    I'm a new android user. The problem I'm having is that when my wifi drops out or if I come home the Internet on my phone does not switch back from mobile data to wifi. I'm with bigpond and I have put the password into my phone and I don't need to put the password in each time but when I go to wifi settings it says sign in required and I press connect and the wifi turns on. As soon as I come home or the Internet drops out it switched back to 3G and doesn't connect back to wifi unless I do what I mentioned above.

    The advanced setting on the wifi are
    Proxy-none
    Ip settings DHCP
    Signal strength- very strong
    Security wpa2 psk

    I also have the smart network switch toggled to off. I have reset my telstra router.

    I would love some help with this, I will readily admit to knowing nothing about android but I'm willing to learn. I've wasted a lot of my mobile data this week before I realised that when I left the house or the net dropped out my phone was staying on 3G and not switching back to wifi the way my iPhone and every other phone I've owned did.

    Thanks so much
  2. Thread Author  Thread Author    #2  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    I've also found that if I toggle off the wifi, wait until it switches to 3g and switch it back on then it reconnects automatically (it says saved, secured, checking ip, checking quality of internet connection) and then connects. If I turn off the router at the wall or if it drops out it will not connect automatically (it doesnt go through the routine with checking ip etc, it just says sign in required) and I need to go and manually connect it.
  3. #3  
    atg284's Avatar

    Posts
    311 Posts
    Global Posts
    367 Global Posts

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Not sure but do you have this....wifi settings, menu, advanced, always allow scanning checked.
  4. Thread Author  Thread Author    #4  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Hi thanks for your reply
    I do have that checked. I wonder if it is a router problem? It is really driving me crazy! I did a search and it seems it can be a common problem with galaxy phones but i found no clear solution,
  5. #5  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    What router do you have?

    Make and model.

    Samsung Galaxy Note 3 (Verizon)
  6. #6  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    I'm having the same issue with my S5 on the work wifi and at home. Starting to wonder if I need to trade this in for another phone while I'm still in my 14 day window.
    carbear02 likes this.
  7. #7  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    I also noticed this

    -Sent from Tapatalk
    carbear02 likes this.
  8. #8  
    sirmaru's Avatar

    Posts
    264 Posts
    Global Posts
    265 Global Posts

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Get WiFi Analyzer from the Google Play store. You have 14 WiFi channels and the Analyzer will determine the best one. Then go to the web page for your Browser and change to that channel.

    Channels can be affected by usage by neighbors, other equipment in the house, etc.

    Bad channels will always have disconnection problems.
    Thanked by:
    Dizfunctions and rahxephon like this.
  9. Thread Author  Thread Author    #9  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Hi
    I've spoken to samsung and they have told me to get a new phone. I also have an iPhone 4 and that never has a problem connecting automatically but I guess It is possible that it is my router as my Internet frequently drops out. I've spoken to my telco and they are sending me a new one router. I'm going to wait until it arrives (hopefully in the next couple of days) and see if there is any change and I will post back here with my results and make and model of router. Thanks so much for the help.
  10. Thread Author  Thread Author    #10  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Just an update in case anyone else has this issue in the future. I went and swapped my phone over and brought it and connected it to my wifi, turned my modem/router on and off a few times and so far so good. It's connecting how it is supposed to!
    Thanked by:
  11. #11  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Aloha. Did you get an entire new s5? And now that one works? My buddy is saying his connects auto every time but mine doesnt.
  12. #12  
    brash10's Avatar

    Posts
    6 Posts
    Global Posts
    14 Global Posts

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Hey Accendo are you with Telstra?, i am just wondering how you went with swapping the handset? do u have Stay connected?, Im experiencing the same things aswell
  13. #13  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    try "forgetting" the network and reconfigure it

    it solved my issues with my home wifi where it wouldn't automatically connect upon turning on wifi
    Thanked by:
  14. #14  
    davew41's Avatar

    Posts
    14 Posts
    Global Posts
    15 Global Posts

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Also a lot of times just changing the routers channel will do the trick. In populated areas this is a very common solution. We had to do this with the s3 and s4 we had. So far the 2 s5's are doing OK. I've noticed this only with Samsung devices the iPhones always connected okay so this is definitely something to do with Samsung's wireless technology.

    Posted via Android Central App
  15. #15  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    I have the same problem. I did swap out phones and still have the same issues. The weird thing is that some networks are being saved. At least I found one place. However, at my office and home I am having to enter my password every time. Also, I called Sprint tech and Samsung and so far they haven' been able to help. Grrr. :-)
    Thanked by:
  16. #16  
    KJ78's Avatar

    Posts
    190 Posts
    Global Posts
    1,028 Global Posts

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    I have a similar problem but it seems to be limited to Comcast public wifi hotspots. It always wants to connect to a weak signal when driving but not always when I am at work.

    Posted via Android Central App
  17. #17  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Quote Originally Posted by eyecon82 View Post
    try "forgetting" the network and reconfigure it

    it solved my issues with my home wifi where it wouldn't automatically connect upon turning on wifi
    This worked for me thanks.

    For the record my home wifi would connect automatically but my work one would need to manually connect simply by tapping 'connect' on the router name as per the original post.
  18. #18  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    This happened to me. All I did was forget network then reconnect and it's been fine since.

    Posted via Android Central App
  19. #19  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Quote Originally Posted by accendo View Post
    Hi
    I'm a new android user. The problem I'm having is that when my wifi drops out or if I come home the Internet on my phone does not switch back from mobile data to wifi. I'm with bigpond and I have put the password into my phone and I don't need to put the password in each time but when I go to wifi settings it says sign in required and I press connect and the wifi turns on. As soon as I come home or the Internet drops out it switched back to 3G and doesn't connect back to wifi unless I do what I mentioned above.

    The advanced setting on the wifi are
    Proxy-none
    Ip settings DHCP
    Signal strength- very strong
    Security wpa2 psk

    I also have the smart network switch toggled to off. I have reset my telstra router.

    I would love some help with this, I will readily admit to knowing nothing about android but I'm willing to learn. I've wasted a lot of my mobile data this week before I realised that when I left the house or the net dropped out my phone was staying on 3G and not switching back to wifi the way my iPhone and every other phone I've owned did.

    Thanks so much
    Ok, so I know this may be a bit late but for those of you having issues try going into wifi>settings>advanced>keep wifi on during sleep>always. Many people will be recieving this because it'll be set to only when plugged in/never
  20. Thread Author  Thread Author    #20  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Hi, I'm still having the same problems. When I forget the network it works again for a few days but then I get the dreaded 'sign in required'.

    Im almost 100% sure its a modem problem. It connects to my mum's modem with no problems. I borrowed my mum's old modem and it was fine, it connected with no issues with the samsung although it kept kicking my idevices off and required them to sign in!

    So I think a new modem is in order, hopefully it will help with dropouts to as we have way over 20 dropouts a day (telstra)

    Oh and I have the keep wifi on during sleep activated.
  21. #21  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Is it activated to always or only when plugged in? I'll post a full list of the settings I have which has sorted this issue. If they don't woek for you then I'd recommend a new modem
  22. #22  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Quote Originally Posted by accendo View Post
    Hi, I'm still having the same problems. When I forget the network it works again for a few days but then I get the dreaded 'sign in required'.

    Im almost 100% sure its a modem problem. It connects to my mum's modem with no problems. I borrowed my mum's old modem and it was fine, it connected with no issues with the samsung although it kept kicking my idevices off and required them to sign in!

    So I think a new modem is in order, hopefully it will help with dropouts to as we have way over 20 dropouts a day (telstra)

    Oh and I have the keep wifi on during sleep activated.
    The list of Advanced settings you need to check are the following 3:

    Keep WiFi on during sleep = Always

    Always allow scanning = Ticked

    WiFi Timer = Ensure no times are set and it can always connect
  23. #23  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    I had this problem when I first got my S5. it was noticeable because my S4 never had an issue automatically connecting to Wifi.

    it turned out to be a problem with my router as BT came and changed it to fix an unrelated issue with my broadband, and hey presto, my S5 has automatically connected perfectly since.

    worth checking your router if possible.
  24. #24  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    Quote Originally Posted by geoffr86 View Post
    I had this problem when I first got my S5. it was noticeable because my S4 never had an issue automatically connecting to Wifi.

    it turned out to be a problem with my router as BT came and changed it to fix an unrelated issue with my broadband, and hey presto, my S5 has automatically connected perfectly since.

    worth checking your router if possible.
    Sounds like it will be the modem then. I did have the issue until I configured the above settings
  25. #25  

    Default Re: Wifi is not connecting automatically on S5. I need to manually connect to wifi every time

    A little update of my findings on this problem.

    I regularly connect to 2 modems, home and work. They both connect automatically with no problem except after restarting the work one (a fairly new BT modem). It needs a restart for an unrelated printer problem and the restart triggers in the need to manually connect the S5. It's as simple as selecting the router and clicking on connect in settings. Other phones in the office do not have this issue, just the S5.

    I don't yet know if the same issue will apply to the home modem as I've yet to try a restart of it.
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 20
    Last Post: 05-09-2014, 10:13 PM
  2. Not enough storage available
    By TSLS in forum Samsung Galaxy Tab 2
    Replies: 2
    Last Post: 04-27-2014, 10:00 PM
  3. wallpaper not sizing right.
    By kami8586 in forum Samsung Galaxy Note 3
    Replies: 12
    Last Post: 04-17-2014, 04:26 PM
  4. S5 needs more RAM or less touch wiz
    By Zylograth in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 04-15-2014, 10:58 PM
  5. MHL to HDMI Cable
    By Tarlach in forum HTC One (M8)
    Replies: 3
    Last Post: 04-15-2014, 04:09 PM

Posting Permissions