1. tmurray315's Avatar
    So i just got the s5 yestrday and i cant get my gmail notifications to pop up. auto sync is turned on, notifications are turned on can anyone help me with this.
    04-15-2014 07:23 PM
  2. Chris Abbott's Avatar
    Had a thread about this early. Sometimes they would work, sometimes not. I tried EVERYTHING. I uninstalled the updates for the app and it seems to work OK at the moment. Ok, as in I get the email a few min after I send it. Good enough I suppose.
    04-15-2014 07:33 PM
  3. tmurray315's Avatar
    is this a defect in the phone or bug on my s4 it worked fine?
    04-15-2014 07:36 PM
  4. erasat's Avatar
    So i just got the s5 yestrday and i cant get my gmail notifications to pop up. auto sync is turned on, notifications are turned on can anyone help me with this.
    Reset your gmail app and Google services framework, the next time you open a Google app it should an you for the account and other stuff, restart and send some test emails to see what happens, if that doesn't fix it, forget about return it just rest to factory and begin again, it must work then.
    04-15-2014 07:42 PM
  5. tmurray315's Avatar
    how do i reset gmail app and google framework?
    04-15-2014 08:05 PM
  6. Alan Bosher's Avatar
    Hi

    you need to set up notifications for each of your gmail tabs. Go into settings and click on your email address. Click on manage labels then select "Primary" then select label notifications. Do this for any other labels that you want to receive notifications for e.g. Social or Promotions.
    Hope that helps

    Cheers
    04-22-2014 12:46 PM
  7. Jwong123's Avatar
    try factory resetting it. This also happen to me after i got my s5
    04-22-2014 05:31 PM
  8. LisaLee660's Avatar
    So, I was having the same problem.

    I'd been looking around and inadvertently figured it out but reading someone else's similar issue on a completely other device.

    Figured out I was only not receiving notifications when wi-fi was disconnected (at work, I feel like the 4G LTE connection is better than our internet connection, so I been keeping it off) and I was in power saving mode (not ultra, although I'd imagine that would be the same problem). As soon as I turned off power save I began receiving my notifications, whether I am am on wi-fi or not. Kinda makes sense when you think about the reasoning behind that.

    Anyway, hope that helps.

    PS - Alan Bosner - I followed your advice on the labels and I still wasn't getting notifications until I figured out the above. NOW, that turns out to be a big help, as I will receive ALL email notifications. Prior to reading this thread, I only had my "primary" label set up. Thanks
    marrzie likes this.
    04-23-2014 02:53 PM
  9. Arcadias1795's Avatar
    Whenever I turn off ultra power saving mode, I receive no push notifications for apps that I KNOW would have given me a notification. I use UPSM at night, and I'll wake up and turn it off, but I always have to reboot to see my push notifications, and even then I'm lucky to get my Gmails. Has anyone else had issues with Instagram, SnapChat, Facebook, etc not working AFTER Ultra Power Saving Mode has been turned off?
    mezrik likes this.
    05-15-2014 07:09 PM
  10. cmandala's Avatar
    Whenever I turn off ultra power saving mode, I receive no push notifications for apps that I KNOW would have given me a notification. I use UPSM at night, and I'll wake up and turn it off, but I always have to reboot to see my push notifications, and even then I'm lucky to get my Gmails. Has anyone else had issues with Instagram, SnapChat, Facebook, etc not working AFTER Ultra Power Saving Mode has been turned off?
    So I had the same problem, and thought it was just the UPSM but apparently not because even when off/after rebooting don't get any notifications for any apps with the following exceptions: Gmail and messages work 100% of the time & Facebook and Twitter are hit or miss. But i don't get ANY other push notifications (Snapchat, ESPN, etc) unless the app happens to be open at the exact time the application is pushed to my phone (if the app is opened later on after one should have been received it does not come in upon opening). I've Uninstalled and reinstalled all the apps, checked the notification settings, and made sure data/background sync is on and nothing has worked. Needless to say, Verizon customer service was less than helpful when I called.

    Has anyone else had this issue and/or been able to fix it? I'd really appreciate any suggestions bc I'm at a loss. Thanks!
    06-01-2014 07:32 PM
  11. ernch's Avatar
    I found this solution on another thread and it worked for me when I was having the same problem after doing the latest update.

    go to settings > data usage > under the mobile tab .. click on the menu button (touch) > select Auto Sync data
    07-23-2014 11:34 AM
  12. Adrian Belu's Avatar
    Thanks Alan. That was the missing tick on mine. Cheers
    08-17-2014 04:53 PM
  13. Philip Spinucci's Avatar
    I'm having the same problem. It just stops notifying me. I prefer to use the email icon rather than the gmail icon.
    09-07-2014 12:50 PM
  14. jdoherty's Avatar
    This problem has been really bothering me on my Galaxy S5 (Verizon Lollipop and even before). I have now been receiving e-mail for an hour (with numerous tests) so I think I finally have it fixed. I've tried numerous suggestions short of factory reset. The only one that fixed it for me was:

    Settings
    Applications
    Application Manager
    (All Tab)
    select Google App
    (Clear Cache)
    then select Google Account Manager
    (Clear Cache)
    then select Gmail
    (Clear Data and Cache)
    then rebooted phone
    default e-mail app and gmail FINALLY both started receiving push notifications within a minute even when screen is off (little blue light finally working)
    04-17-2015 11:35 AM
  15. James Gund's Avatar
    So far, this seems to have solved it:
    Settings
    Applications
    Application Manager
    (All Tab)
    select Google App
    (Clear Cache)
    then select Google Account Manager
    (Clear Cache)
    then select Gmail
    (Clear Data and Cache)
    then rebooted phone
    default e-mail app and gmail FINALLY both started receiving push notifications within a minute even when screen is off (little blue light finally working)

    Keeping my fingers and my manmeat crossed...
    02-25-2016 03:14 PM
  16. L_Spilker's Avatar
    I had to uninstall all gmail updates to make it work again.
    02-29-2016 12:50 AM
  17. HoserOmega's Avatar
    I got the gmail thing worked out.

    Open gmail app.

    top left hand corner has 3 bars. tap on it

    scroll to the bottom and hit settings. the gear thing

    click on your email address.

    make sure that the box beside notifications is checked.

    Under that there is Inbox sound & vibrate.

    click on that.

    at the bottom, there is a setting that says Notify for every message.

    click on that and get the blue check mark in the box.

    Problem solved.
    05-02-2016 02:57 PM

Similar Threads

  1. S5 Camera question?
    By kelpike in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-01-2014, 04:36 PM
  2. S5 and wireless charging card?
    By skullfreak in forum Samsung Galaxy S5
    Replies: 10
    Last Post: 04-16-2014, 12:07 AM
  3. Replies: 2
    Last Post: 04-15-2014, 07:19 PM
  4. Can i flash ROM or RUU on a relocked bootloader?
    By raj patel7 in forum HTC One Google Edition
    Replies: 0
    Last Post: 04-15-2014, 07:01 PM
  5. Latest gear manager on non samsung phones.
    By ray1204 in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 0
    Last Post: 04-15-2014, 06:28 PM
LINK TO POST COPIED TO CLIPBOARD