1. minidre's Avatar
    Hey all, I have this very annoying problem with my GS5. When the screen is locked and is plugged into the charger, anytime I receive a text message the screen lights up and NEVER automatically puts itself back to sleep. The screen will dim, but stay lit until I physically press the lock button. Is anybody else experiencing this?
    04-18-2014 07:59 PM
  2. Eclipse2K's Avatar
    My friend had the same issue with his Sprint S5. Go to settings > developer options > uncheck the keep screen on while charging option.

    Samsung Galaxy S5 (Verizon)
    minidre, bleu310 and Craig Goslan like this.
    04-18-2014 08:25 PM
  3. UncleBubby's Avatar
    I have the same problem. The screen comes on with a notification (usually that it is fully charged) and will then stay on. Daydream is off, SmartStay is off and the StayAwake on the Developer Options is grayed out and I can't find a way to wake it so it isn't gray to be able to uncheck it if it is. Any other ideas?
    05-08-2014 04:44 PM
  4. byeblackberry's Avatar
    Go to the settings menu on your GS5.
    Scroll down to the "System section and tap "About Device."
    Now scroll down to "Build number."
    Tap the "Build number" section seven times. (You'll see a warning that you're about to unlock developer options.)
    Now back out to the main settings menu, and you'll see "Developer options" listed.

    Posted via Android Central App
    05-08-2014 10:32 PM
  5. UncleBubby's Avatar
    Sorry to post this twice...I din't know which topic would be followed. It isn't Developer Options that is grayed out, it is the StayAwake inside that that is grayed out.
    05-08-2014 10:41 PM
  6. athletejmv's Avatar
    This is just what I needed to know for my HTC One M8. Thank you Eclipse2k.

    "My friend had the same issue with his Sprint S5. Go to settings > developer options > uncheck the keep screen on while charging option. "
    Eclipse2K likes this.
    07-08-2014 01:54 AM
  7. Tracy Jakubowski's Avatar
    Thank you, I also had this problem and I couldn't find developer options anywhere. I had to have a factory reset done on my phone and a lot of the stuff that I knew was on the phone before the the reset disappeared.
    07-08-2014 10:21 AM
  8. Brian Manny's Avatar
    Thank you so much
    07-22-2014 09:19 PM
  9. MIKEY831's Avatar
    I'm going through the same thing with my tmobile S5 screen stays on when I receive notifications and won't turn off unless I press the power button. I'm trying to figure out how to fix this problem. It's annoying and it drains my phones battery
    04-17-2015 10:28 PM
  10. MC246258's Avatar
    Mikey831, I have the t mobile S5 doing the same thing, and I think I figured it out. I went to the t mobile app settings go to options I only have the wifi checked. I also went to the battery saver mode in the same app (just scroll down). I clicked on 10 screen. Hope that helps man....
    04-25-2015 09:52 AM
  11. rakeshs73's Avatar
    Did you get the fix? I am having same issue with my Samsung S5 on T-Mobile.
    05-06-2015 09:58 PM
  12. destro777's Avatar
    Try turning powersaver on, this resolved the screen staying on after a notification. As soon as I did this the screen would shut off shortly after receiving a notification. I tested by turning power saver off and the screen would stay on until I hit the lock button.
    05-22-2015 06:28 PM
  13. Donald Wyman's Avatar
    Hey all, I have this very annoying problem with my GS5. When the screen is locked and is plugged into the charger, anytime I receive a text message the screen lights up and NEVER automatically puts itself back to sleep. The screen will dim, but stay lit until I physically press the lock button. Is anybody else experiencing this?
    I have the same problem I went into developer options and unchecked it witch didn't do anything can anyone help?
    10-13-2015 06:23 PM
  14. Donald Wyman's Avatar
    Did you ever get it to work? Cause I have the same problem and I have tried what I think to be everything
    10-13-2015 06:30 PM
  15. bleu310's Avatar
    Thanks!
    12-01-2015 07:11 PM
  16. Ghazi Yassine's Avatar
    I hade the same problem with my note 4 and i have solved it i have disabeled my peel smart remote and it does turn off automaticly now !!
    05-15-2016 06:38 AM
  17. Mick Wenzel's Avatar
    For me unchecking "Smart Stay" in my settings prevented the screen flashing whilst charging.
    08-01-2016 04:46 AM
  18. BlackZeppelin's Avatar
    I hade the same problem with my note 4 and i have solved it i have disabeled my peel smart remote and it does turn off automaticly now !!
    I can testify that this is correct. You don't have to disable the entire Peel smart remote app. All you have to do is go into the Peel app settings and under "widgets", turn off the notification widget. All you lose is the lockscreen widget. But that did the trick for my Galaxy S5 that is running Marshmallow 6.0.1.

    Hope that helps others.
    08-01-2016 05:57 AM
  19. BlackZeppelin's Avatar
    I just realised that I got a recent update of the Peel smart remote app. So no doubt there is a bug in the widget causing the lockscreen to stay on. This will be fixed likely in the next update.
    08-01-2016 06:01 AM
  20. Brotherly's Avatar
    Go to the settings menu on your GS5.
    Scroll down to the "System section and tap "About Device."
    Now scroll down to "Build number."
    Tap the "Build number" section seven times. (You'll see a warning that you're about to unlock developer options.)
    Now back out to the main settings menu, and you'll see "Developer options" listed.

    Posted via Android Central App
    All the boxes In developing options are unchecked after I opened it. Any other tips?
    08-15-2016 11:51 AM
  21. Darren Loo's Avatar
    I have the same problem but I have it even when my phone is not charging.
    09-08-2016 12:54 AM
  22. Paladin's Avatar
    I know this is an old thread but I have this issue on my Samsung S7 Edge. Developer-Stay Awake is OFF. I don't have anything called peel smart remote.
    Phone screen stays on while charging from wireless or wired. No settings are set to do this as far as I can tell.

    I plug it in to charge and the screen turns on and stays on. I have to turn it off manually. Send myself an email, screen turns on and stays on as long as it is charging..

    Extremely annoying.

    Any further ideas?
    11-20-2016 09:24 PM

Similar Threads

  1. Nexus 4 Stuck at boot screen after replacing the LCD/Digitizer
    By BigsMcGee in forum General Help and How To
    Replies: 9
    Last Post: 02-01-2017, 10:41 PM
  2. Lock Screen Timeout
    By cjohns024 in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 04-23-2014, 10:32 PM
  3. Verizon S3 wont turn on all the time
    By AWESOME_O_1000 in forum Verizon Galaxy S III
    Replies: 6
    Last Post: 04-19-2014, 05:13 PM
  4. Galaxy S5: Can infinite scroll be turned off in TouchWiz?
    By awesomeabs in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 04-18-2014, 07:43 PM
  5. Replies: 0
    Last Post: 04-18-2014, 06:53 PM
LINK TO POST COPIED TO CLIPBOARD