Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By erasat
  1. Thread Author  Thread Author    #1  

    Default Maybe I turned off LTE accidentally?

    My iPhone 5S had LTE just about everywhere around town. With the S5... Nothing. Have not seen it since the day I brought the S5 home. All it says is 4G and not 4G LTE. Is there a way to turn LTE on and off like on my iPhone 5S? I can't seem to find it.
  2. #2  
    atg284's Avatar

    Posts
    309 Posts
    Global Posts
    365 Global Posts

    Default Re: Maybe I turned off LTE accidentally?

    What carrier are you on?
  3. Thread Author  Thread Author    #3  

    Default Re: Maybe I turned off LTE accidentally?

    Quote Originally Posted by atg284 View Post
    What carrier are you on?
    T-Mobile
  4. #4  

    Default Re: Maybe I turned off LTE accidentally?

    Quote Originally Posted by Xm_jdm View Post
    T-Mobile
    Thats your problem
  5. Thread Author  Thread Author    #5  

    Default Re: Maybe I turned off LTE accidentally?

    Quote Originally Posted by DreamSTi View Post
    Thats your problem
    iPhone 5S, Galaxy S4 and Galaxy S4 Active picked up LTE with no problems at all. The S5...Nothing. So no, it's not T-Mobile.
  6. #6  
    erasat's Avatar

    Posts
    271 Posts
    Global Posts
    522 Global Posts

    Default Re: Maybe I turned off LTE accidentally?

    Quote Originally Posted by Xm_jdm View Post
    iPhone 5S, Galaxy S4 and Galaxy S4 Active picked up LTE with no problems at all. The S5...Nothing. So no, it's not T-Mobile.
    Go to your settings, More networks, mobile network, and check that Network Mode is set to LTE, it just happened to me today although I swear I didn't change anything on the settings myself, but weird, it wasn't selected.
    Thanked by:
    Xm_jdm 
    Xm_jdm likes this.
  7. Thread Author  Thread Author    #7  

    Default Re: Maybe I turned off LTE accidentally?

    Quote Originally Posted by erasat View Post
    Go to your settings, More networks, mobile network, and check that Network Mode is set to LTE, it just happened to me today although I swear I didn't change anything on the settings myself, but weird, it wasn't selected.
    Thank you! It was checked off. And there is no way I did that on my own. How strange.

    Anyway, I am good to go now and LTE is up and running. Much thanks!
  8. #8  

    Default Re: Maybe I turned off LTE accidentally?

    Quote Originally Posted by DreamSTi View Post
    Thats your problem
    Depends on where you are. I live in Jacksonville FL and get LTE pretty much all around town.. And we are very spread out land wise.. .

    Sent from my T-Mobile Note 3 using AC Forums.
    Sent from my T-Mobile Note 4 using AC Forums.

Similar Threads

  1. Replies: 7
    Last Post: 07-22-2014, 09:19 PM
  2. HTC M7 WiFI not turning on
    By Kylellwood in forum AT&T HTC One
    Replies: 5
    Last Post: 07-19-2014, 06:18 AM
  3. Galaxy S3 turns on only for a moment [VIDEO]
    By shoez in forum Sprint Galaxy S3
    Replies: 2
    Last Post: 04-21-2014, 12:03 PM
  4. Replies: 2
    Last Post: 04-19-2014, 06:05 PM
  5. Note 3 battery problem. Dead wont turn on at all/ drains fast.
    By Michael Tung in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 04-19-2014, 03:46 PM

Posting Permissions