1. mnuttall87's Avatar
    Hey guys,

    Had my GS5 for about a week now and everything has been great, but yesterday it started getting an error. I'll be using the phone and get a little box that says "Sprint Connection Optimizer Updater Not Responding" or something to that effect. Anyone know the cause of this or how to disable it? It then throws the phone into a reboot cycle, but it will get stuck on the Sprint Spark screen and I have to rip the battery in order to get it to boot.
    04-23-2014 06:54 AM
  2. toonzizhere's Avatar
    Mine doesn't reboot, I can just back out of it, but I get that screen as well. I notice it when I'm on WiFi and I get a "data connection lost due to roaming" or some such message. I'm neither roaming nor have I lost data (on WiFi after all). I've checked settings and I do have my phone set up to roam for voice & data, so I just move on, nothing seems adversely affected.

    Posted via Android Central App
    04-23-2014 07:50 AM
  3. cyberdman's Avatar
    Smartest thing you can do for yourself is disable the Sprint Connection Optimizer and manually optimize your own connection. That program is a joke and does not work as promised.
    04-23-2014 08:39 AM
  4. mnuttall87's Avatar
    Smartest thing you can do for yourself is disable the Sprint Connection Optimizer and manually optimize your own connection. That program is a joke and does not work as promised.
    Yeah, I thought I had it turned off so I wasn't sure why it was still attempting to do anything in the background? Any other way to completely disable it without root?
    Mst99 likes this.
    04-23-2014 08:45 AM
  5. thelonghop's Avatar
    I'm having the exact same issue. I've seen that popup about the Connection Optimizer Updater crashing and keep finding my phone stuck at Sprint Spark and have to force a reboot but hadn't connected the two. I don't see any way to disable connection optimizer updater. I did a force quit but the disable button is grayed out.

    Also, you can push Power+Volume to force a reboot when stuck at that Sprint Spark screen.
    04-30-2014 12:07 PM
  6. mnuttall87's Avatar
    I'm having the exact same issue. I've seen that popup about the Connection Optimizer Updater crashing and keep finding my phone stuck at Sprint Spark and have to force a reboot but hadn't connected the two. I don't see any way to disable connection optimizer updater. I did a force quit but the disable button is grayed out.

    Also, you can push Power+Volume to force a reboot when stuck at that Sprint Spark screen.
    Good to know. I did a factory reset, went to developer and switched to ART and then back to DALVIK but it hasn't happened again. Not sure what the issue was.
    04-30-2014 12:25 PM
  7. thelonghop's Avatar
    I was about to ask. I've been using ART. You were using DALVIK when you originally had the issue?
    04-30-2014 01:52 PM
  8. mnuttall87's Avatar
    I was actually using ART when it happened, but its been okay after the factory reset/switch to ART to optimize/switch to DALVIK because it seems more stable.
    04-30-2014 02:08 PM
  9. thelonghop's Avatar
    Hmm, it might be an ART issue then.
    04-30-2014 02:46 PM
  10. andrewjs18's Avatar
    I'm on dalvik and have this issue as well.

    where do you actually turn off that stupid app?
    04-30-2014 11:54 PM
  11. Thomas Clearo's Avatar
    Settings, more networks, mobile networks. I'm on Sprint.

    Posted via Android Central App
    Donald Schoolfield likes this.
    05-01-2014 03:44 AM
  12. cyberdman's Avatar
    Yes, just go in there and turn it off. Goodbye problems, it will never bother you again.
    05-01-2014 05:47 AM
  13. andrewjs18's Avatar
    thanks.
    05-01-2014 11:36 AM
  14. eyecon82's Avatar
    Settings, more networks, mobile networks. I'm on Sprint.

    Posted via Android Central App
    After turning it off, does it randomly turn back on?

    -Sent from Tapatalk
    05-01-2014 04:04 PM
  15. cyberdman's Avatar
    No.
    05-01-2014 08:08 PM
  16. kevin musgrove's Avatar
    dude mine is doing the same thing I was going to post that question but I don't need to mine is doing it over and over too. it will finally stop for a while then start agian like 15 times a day its pissing me off because sprint spark sucks enough as it is i settled with the constant 3g but i don't want to have mine phone freeze up because my carrier sucks
    05-29-2014 09:41 PM
  17. Merle Taylor's Avatar
    dude mine is doing the same thing I was going to post that question but I don't need to mine is doing it over and over too. it will finally stop for a while then start agian like 15 times a day its pissing me off because sprint spark sucks enough as it is i settled with the constant 3g but i don't want to have mine phone freeze up because my carrier sucks
    06-21-2014 11:52 AM
  18. Merle Taylor's Avatar
    I found my ph staying in 3G is a sprint/ smart spark issue. I know I'm in a LTE area but the "smart spark" is "finding the best" connection! My area is not "smart spark" ready so it'll change my settings to " samsung network" rather than sprint and there is no such thing! I'm not sure any carrier other than sprint is having this issue..
    06-21-2014 11:59 AM
  19. Jeffin92833's Avatar
    Any chance this is what is causing a bug I see a couple times per week where WiFi is turned off (only when I am out of range)? I was sitting at a restaurant a couple Sundays ago and saw WiFi cycle on and off several times in a matter of seconds.

    I usually have Data turned off (I have a Prepaid account for my phone and rarely need data when I am not connected to WiFi at home or work). I expect WiFi to automatically connect when in range, but for the past several weeks, it has been turned off when I arrive at work.

    I have Timesheet installed and set to start a timer when I arrive at work to calculate my hours (obviously, it won't work if WiFi is off, and there is a bug where turning WiFi on when I am in range doesn't trigger Timesheet to start recording), but it's been working for months and this problem started recently.


    Jeff
    02-26-2015 03:45 AM

Similar Threads

  1. Connecting Galaxy S5 to Certain Bluetooth Devices
    By Marta3 in forum Samsung Galaxy S5
    Replies: 40
    Last Post: 01-31-2015, 04:44 PM
  2. Sprint Easy Pay
    By TheJediGoddess in forum Sprint
    Replies: 10
    Last Post: 04-27-2014, 06:23 PM
  3. Sprint Galaxy Note 2: Hotspot feature missing from settings
    By gggoodgggirl in forum Sprint Galaxy Note 2
    Replies: 4
    Last Post: 04-25-2014, 12:52 PM
  4. Replies: 5
    Last Post: 04-24-2014, 11:02 AM
  5. May have faulty charger or connection, have you ?
    By kingfisher171 in forum Chargers and Batteries
    Replies: 0
    Last Post: 04-22-2014, 11:53 AM
LINK TO POST COPIED TO CLIPBOARD