Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 33
Like Tree1Likes
  1. Thread Author  Thread Author    #1  

    Default S5 has 4g signal but loads extremely slow

    Hey guys
    This is a very annoying issue that i have encountered starting yesterday.

    I have Verizon as my carrier. My phone is showing that I have LTE signal, things should load fine. However they don't. Apps are taking a lot longer than usual. Mightytext is extremely slow and won't even send or receive messages even after its linked. Fb chat takes too long to load,I funny,etc. If I connect to my Wi-Fi the problem is gone, however I don't want to always be connected to Wi-Fi just to use my apps.

    Anyone else run into this issue? It just started for me had the phone for about a month

    Sent from my SM-G900V using Tapatalk
  2. #2  

    Default Re: S5 has 4g signal but loads extremely slow

    Use speedtest to see what speed you are getting. It's an app. On LTE I get around 5.5-6 mbps. Blazingly fast.
  3. Thread Author  Thread Author    #3  

    Default Re: S5 has 4g signal but loads extremely slow



    Those are my results

    Sent from my SM-G900V using Tapatalk
  4. #4  

    Default Re: S5 has 4g signal but loads extremely slow

    Just used speed test. 9 mbps
  5. Thread Author  Thread Author    #5  

    Default Re: S5 has 4g signal but loads extremely slow

    So my are my speeds normal then?

    Sent from my SM-G900V using Tapatalk
  6. #6  

    Default Re: S5 has 4g signal but loads extremely slow

    Those are very fast speeds. I've noticed in some areas where it says I have great signal still acts like a dead spot. Not many places but a few.
  7. Thread Author  Thread Author    #7  

    Default Re: S5 has 4g signal but loads extremely slow

    Hmm this is really Strange then, because even to post and view tapatalk I need to have my Wi-Fi on as well. I'm at home now and never had an issue with this before

    Sent from my SM-G900V using Tapatalk
  8. #8  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by bbalcrazy92 View Post
    So my are my speeds normal then?

    Sent from my SM-G900V using Tapatalk
    No....I don't understand how you can get 30 plus mbps on LTE, what's even more surprising is your upload speed. 18 mbps would be impressive on the best wifi
  9. Thread Author  Thread Author    #9  

    Default Re: S5 has 4g signal but loads extremely slow

    That's really weird then. My speeds are really good but the performance isn't. Even from this app I didn't get the notification that you replied to the thread until I turned my Wi-Fi back on. Seems like no online apps work for me properly unless I have Wi-Fi

    Sent from my SM-G900V using Tapatalk
  10. #10  

    Default Re: S5 has 4g signal but loads extremely slow

    That doesn't make sense. You're getting way better mbps than I do on a $50 a month wifi connection lol.
  11. #11  

    Default Re: S5 has 4g signal but loads extremely slow

    by those speeds, nothing should choke your phone. You should be able to download huge pdf files in seconds.
  12. Thread Author  Thread Author    #12  

    Default Re: S5 has 4g signal but loads extremely slow

    My mom also has a gs5 I ran speed test on her phone these are her results
    Edit : so it can't be just my phone that is being odd with the fast speeds. Hers is even faster lol
    Sent from my SM-G900V using Tapatalk
  13. #13  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by bbalcrazy92 View Post
    Hey guys
    This is a very annoying issue that i have encountered starting yesterday.

    I have Verizon as my carrier. My phone is showing that I have LTE signal, things should load fine. However they don't. Apps are taking a lot longer than usual. Mightytext is extremely slow and won't even send or receive messages even after its linked. Fb chat takes too long to load,I funny,etc. If I connect to my Wi-Fi the problem is gone, however I don't want to always be connected to Wi-Fi just to use my apps.

    Anyone else run into this issue? It just started for me had the phone for about a month

    Sent from my SM-G900V using Tapatalk
    The short answer is that that something in your firmware must have broken. Your speed itself is great, but you are dealing with crazy system imposed lag. You could try wiping the android cache....did yoy install any particular app tho just before this began?
  14. Thread Author  Thread Author    #14  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by Relgoshan View Post
    The short answer is that that something in your firmware must have broken. Your speed itself is great, but you are dealing with crazy system imposed lag. You could try wiping the android cache....did yoy install any particular app tho just before this began?
    No i have not installed any new app at all recently. Would I lose anything important wiping the cache?

    Sent from my SM-G900V using Tapatalk
  15. #15  

    Default Re: S5 has 4g signal but loads extremely slow

    No, and you shouldn't have to do that. I've had my phone for a month, no cache cleaner, no ram booster, no app killer, no anti virus.....I think you should do a factory reset to see if that solves the issue.
  16. #16  

    Default Re: S5 has 4g signal but loads extremely slow

    Cache clean is less drastic than factory reset and sometimes you get lucky.
  17. #17  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by Relgoshan View Post
    Cache clean is less drastic than factory reset and sometimes you get lucky.
    I don't think you should ever need to clear your cache. Let him try though, no harm can come from it.
  18. Thread Author  Thread Author    #18  

    Default Re: S5 has 4g signal but loads extremely slow

    Alright I'll try the cache clean first, how do I go upon doing that?

    Sent from my SM-G900V using Tapatalk
  19. #19  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by Jon Jackson View Post
    No....I don't understand how you can get 30 plus mbps on LTE, what's even more surprising is your upload speed. 18 mbps would be impressive on the best wifi
    You'll have to see the AWS Verizon speeds and T-Moblie 20x20 LTE speeds.. People pull 100.

    My coworker pulled this earlier this morning down the road from my work. Speeds on LTE are actually really fast .

    Sent from my T-Mobile Note 3 using AC Forums.
    Attached Thumbnails Attached Thumbnails S5 has 4g signal but loads extremely slow-1400009601169.jpg  
  20. #20  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by bbalcrazy92 View Post
    Alright I'll try the cache clean first, how do I go upon doing that?

    Sent from my SM-G900V using Tapatalk
    Just google up "Galaxy S5 cache wipe" and you'll see how popular the topic is. Wiping cache especially can fix software issues, and since it's harmless they always suggest trying it.
  21. #21  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by bbalcrazy92 View Post
    Hey guys
    This is a very annoying issue that i have encountered starting yesterday.

    I have Verizon as my carrier. My phone is showing that I have LTE signal, things should load fine. However they don't. Apps are taking a lot longer than usual. Mightytext is extremely slow and won't even send or receive messages even after its linked. Fb chat takes too long to load,I funny,etc. If I connect to my Wi-Fi the problem is gone, however I don't want to always be connected to Wi-Fi just to use my apps.

    Anyone else run into this issue? It just started for me had the phone for about a month

    Sent from my SM-G900V using Tapatalk
    Did this just start today? I'd try clearing the cache on the apps or a reboot to see if it fixes the issue. You can do this by going to settings, application manager, then find the app and select it. After that there will be a screen that let's you clear cache. (see below for an example).



    Sent from my T-Mobile Note 3 using AC Forums.
    Attached Thumbnails Attached Thumbnails S5 has 4g signal but loads extremely slow-1400009878027.jpg   S5 has 4g signal but loads extremely slow-1400009888519.jpg   S5 has 4g signal but loads extremely slow-1400009900759.jpg  
  22. Thread Author  Thread Author    #22  

    Default Re: S5 has 4g signal but loads extremely slow

    Hey almeuit ty. It started the other day it's not for any particular app. It's every app that uses internet connection. I'm going to wipe the cache on the phone and see if this solves the issue. Will report back

    Sent from my SM-G900V using Tapatalk
  23. Thread Author  Thread Author    #23  

    Default Re: S5 has 4g signal but loads extremely slow

    Wiped cache with no success in solving the problem, you guys think a hard reset would do anything? I hate that I'd lose my stuff lol

    Sent from my SM-G900V using Tapatalk
  24. #24  

    Default Re: S5 has 4g signal but loads extremely slow

    Quote Originally Posted by bbalcrazy92 View Post
    Wiped cache with no success in solving the problem, you guys think a hard reset would do anything? I hate that I'd lose my stuff lol

    Sent from my SM-G900V using Tapatalk
    I would, and if that does not work, take the phone back.
  25. Thread Author  Thread Author    #25  

    Default Re: S5 has 4g signal but loads extremely slow

    Alright I'll give it a shot later tonight and see what happens. Thanks!

    Sent from my SM-G900V using Tapatalk
    Jon Jackson likes this.
Page 1 of 2 12 LastLast

Similar Threads

  1. Unrooted my phone, but it refuse to do updates
    By kooritsuki in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 9
    Last Post: 06-23-2014, 09:31 PM
  2. S5 Freezing on Lock Screen
    By Tom Skeens in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 05-24-2014, 07:13 AM
  3. error loading player: no playable sources found
    By emilygs3 in forum Samsung Galaxy S3
    Replies: 0
    Last Post: 05-13-2014, 09:57 AM
  4. Verizon galaxy s3 randomly loses all signal
    By pontiacfreak142 in forum Verizon Galaxy S3
    Replies: 0
    Last Post: 05-13-2014, 06:39 AM
  5. Galaxy S5 text picture icon notification
    By larry_ocean in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 05-13-2014, 01:59 AM

Posting Permissions