1. brandquad's Avatar
    Just got the Galaxy S5 with Virgin Mobile but when I connect to my home Wi-Fi network, my internet speeds are awfully slow/non-existant. Anytime I try going to a webpage it will try connecting but time out every single time. I've noticed apps that use Wi-Fi are a lot slower and everything seems fine on paper after using Wifi Fixer and it says my signal is really strong but nothing is loading. When I turn off wi-fi my mobile data is blazingly fast but I want to be able to use wi-fi!
    05-25-2014 05:09 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! What kind of router do you have? Are you sure it's set to the fastest speed (usually Wireless N)?

    Review this guide and see if any of the tips help: [GUIDE] Troubleshooting Wi-Fi Connection Problems

    Posted via Android Central App.
    Please excuse any typos or autocorrect derps.
    SpasticPat likes this.
    05-25-2014 05:14 PM
  3. eyecon82's Avatar
    My wifi is fine, it's probably your router

    -Sent from Tapatalk
    05-25-2014 06:52 PM
  4. AZgl1500's Avatar
    I just ran Speed Test and I'm getting 11 Mbps thru put on WIFI to the internet via my DSL router/modem.

    WiFi Manager reports that the Router to phone WiFi transfer rate is 144 Mbps with WPA-PSK.... security turned ON.
    05-25-2014 07:10 PM
  5. brandquad's Avatar
    Thanks! It looked like changing my router security fixed everything
    B. Diddy likes this.
    05-25-2014 07:18 PM
  6. ab304945's Avatar
    this is what i get on wifi

    05-25-2014 09:25 PM
  7. AZgl1500's Avatar
    You make me jealous of when I had COX cable and those super fast speeds.
    Used to live in Mesa, AZ and Cox was the way to go to get upwards of 50 mB/s

    DSL tops out at 11.1 mips.

    when I moved here and found out the closest cable connection is 18 miles away, I bawled a river's worth of water. I searched everywhere for a good connection.... no dice.

    AT&T was the best that I could find, DSL riding over a land line. puke!
    05-25-2014 09:29 PM
  8. ab304945's Avatar
    You make me jealous of when I had COX cable and those super fast speeds.
    Used to live in Mesa, AZ and Cox was the way to go to get upwards of 50 mB/s

    DSL tops out at 11.1 mips.

    when I moved here and found out the closest cable connection is 18 miles away, I bawled a river's worth of water. I searched everywhere for a good connection.... no dice.

    AT&T was the best that I could find, DSL riding over a land line. puke!
    I feel sorry for you.

    I cant stand DSL, i wouldnt use it even if they payed me to use it.

    COX just announced that they will be rolling out Gigabit internet in my area soon, plus all other speeds will be doubled.
    05-25-2014 10:30 PM
  9. Lizette Sweezer-Morris's Avatar
    Hi, I am having the same problems. How did you fix the security on your wi-fi?
    Mrluky likes this.
    05-26-2014 10:00 AM
  10. B. Diddy's Avatar
    Welcome to Android Central! You need to log into the router's settings screen using your browser on the computer. Look at your router's manual to learn how to do it, because it varies with the model. Once in the settings, you can change the security from WEP or WPA to WPA2, which is recommended.

    Posted via Android Central App--please excuse the brevity and any typos!
    Mrluky likes this.
    05-26-2014 11:45 AM
  11. AZgl1500's Avatar
    I feel sorry for you.

    I cant stand DSL, i wouldnt use it even if they payed me to use it.

    COX just announced that they will be rolling out Gigabit internet in my area soon, plus all other speeds will be doubled.
    Maybe, just maybe there "might be" some light at the end of the tunnel.

    I read in yesterday's newspaper that Google is installing fiberglass gigabit internet for the entire Northeastern corner of Oklahoma.

    Those folks have been petitioning the governor for years to get internet available in those countys.

    If you could not afford satellite internet, you just didn't have any.
    05-26-2014 12:17 PM
  12. 1iwilly's Avatar
    it doesn't matter how many times i check or time of day i'm on a turbo 30mbps wifi using a wrt54 g router and the best i can see is between 13mbps to 17mbps i do have wap set how can i fix the speed issue.??? thanks
    07-24-2014 09:36 PM
  13. darlene24's Avatar
    Just got the Galaxy S5 with Virgin Mobile but when I connect to my home Wi-Fi network, my internet speeds are awfully slow/non-existant. Anytime I try going to a webpage it will try connecting but time out every single time. I've noticed apps that use Wi-Fi are a lot slower and everything seems fine on paper after using Wifi Fixer and it says my signal is really strong but nothing is loading. When I turn off wi-fi my mobile data is blazingly fast but I want to be able to use wi-fi!
    yes maybe the router itself.. try to off for a moment then on.. and yours too your phone off wifi then on. to restart loading or searching.
    07-24-2014 09:55 PM

Similar Threads

  1. Samsung S5 MMS not sending?
    By baileysqueen in forum Samsung Galaxy S5
    Replies: 8
    Last Post: 03-24-2015, 09:15 AM
  2. Can not access my S5 through my iMac
    By grenfrog00 in forum Samsung Galaxy S5
    Replies: 12
    Last Post: 08-18-2014, 02:30 AM
  3. S5 Rebooting on Ap Install?
    By Effect One in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-26-2014, 06:03 PM
  4. Problem: S5 G900L has not SMS Delivery Report!
    By T_N in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 05-26-2014, 01:13 AM
  5. Replies: 0
    Last Post: 05-25-2014, 03:36 PM
LINK TO POST COPIED TO CLIPBOARD