Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default Help: My S5 permanently shows 4G!

    My S5 permanently shows 4G evn though there is no 4G. I got it from GSM Nation and they sent me the G900W8 (Canadian) model instead of the G900F (International) but it works fine in my country. There is no actual 4G in my country, yet my phone shows that. Does anyone have a solution or have the same problem?
  2. #2  
    sjaduae's Avatar

    Posts
    296 Posts
    Global Posts
    316 Global Posts

    Default Re: Help: My S5 permanently shows 4G!

    Quote Originally Posted by vasodys View Post
    My S5 permanently shows 4G evn though there is no 4G. I got it from GSM Nation and they sent me the G900W8 (Canadian) model instead of the G900F (International) but it works fine in my country. There is no actual 4G in my country, yet my phone shows that. Does anyone have a solution or have the same problem?
    go to setting/connections/more networks/mobile networks/network mode and try wcdma/gsm
  3. Thread Author  Thread Author    #3  

    Default Re: Help: My S5 permanently shows 4G!

    Quote Originally Posted by sjaduae View Post
    go to setting/connections/more networks/mobile networks/network mode and try wcdma/gsm
    Sadly, it still shows 4G and when I change to GSM only it shows arrows without an icon over them.
  4. #4  
    sjaduae's Avatar

    Posts
    296 Posts
    Global Posts
    316 Global Posts

    Default Re: Help: My S5 permanently shows 4G!

    Is the data working correctly ? if so is this just cosmetic ?
  5. Thread Author  Thread Author    #5  

    Default Re: Help: My S5 permanently shows 4G!

    The data is working fine and the arrows show activity. The icon should change according to your connection. Comparing it to my friend's G900F where it works properly, I know there's something wrong.

    Sent from my SM-G900W8 using Tapatalk

Similar Threads

  1. The vibrate mode on my phone will not work
    By kaylamarie91110 in forum Droid RAZR HD
    Replies: 15
    Last Post: 07-20-2016, 05:18 PM
  2. Replies: 11
    Last Post: 06-23-2014, 08:58 PM
  3. Transferring videos from my phone to my Macbook Pro
    By joncslaten in forum AT&T LG G2
    Replies: 2
    Last Post: 06-18-2014, 06:46 PM
  4. Replies: 12
    Last Post: 06-13-2014, 12:57 AM
  5. White color on my Nexus 7 2013 screen not perfectly even!!Is this normal?
    By Aditya Shanbhag1 in forum Google Nexus 7 Tablet (2013)
    Replies: 3
    Last Post: 06-11-2014, 07:28 PM

Posting Permissions