Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  

    Default Wifi Issues

    Hello Guys...
    So I bought my Galaxy S5 this Saturday and I am really satisfied it is super light weight and awesome. In the videos that I watched on it, it looked cheap but now that I have it, it's SOO much better. Anyways I got it with T-Mobile and got the 5gb plan, since I'm in summer vacation and will be using the wifi at my house. Well, that's where my problem is the first two days that I had my phone the wifi was fast like it always is but since yesterday the wifi started going as slow as a snail. YouTube videos took like 5 min to load and pages didn't want to load either. I thought that it was my service that was bad but my sister has an IPhone 4s and the wifi is still working. The wifi has speed up a little since the initial problem but it is still going slower than usual. Is anyone else having this problem? Also, note that the day after I got my phone I downloaded an update can that be it? I also checked my settings and went to the power saving mode to make sure no restrictions were on. Any help will be appreciated thanks.

    Posted via Android Central App

Similar Threads

  1. Folder Issues on Galaxy Note 10.1
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2014, 11:11 AM
  2. Verizon Galaxy S3 won't switch from wifi to 4G
    By jcspivak in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 06-18-2014, 06:41 AM
  3. My Prism won't connect to any wifi
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-17-2014, 11:54 PM
  4. SDcard issues
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-17-2014, 08:53 PM
  5. google play store issue
    By pandrade11 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-17-2014, 03:46 PM

Posting Permissions