06-13-2016 11:00 PM
55 123
tools
  1. Coolaaron88's Avatar
    Hey S5 forum, I have noticed an issue with the Galaxy S5 that apparently only occurs with the Verizon variant. I work for a place called Wireless Advocates, we are the cell phone kiosk inside of Costco. I'm asking about this because I've had three customers come in to ask about this background data issue.

    I'm not sure what triggers this issue but when I try opening up google play I get the "Background Data Disabled : Google Play Store Needs background data to be Enabled" error. It then gives you the ability to either quit or enable the data. If you press enable it takes you to the account screen in settings.

    When I go to Data usage the option to "restrict background data" is greyed out. You can't even select it and it isn't checkmarked either. Just to clarify, accessing the internet and other things on the phone work perfectly fine. It's just the use of Google Play that is having issues. I called Samsung customer care and they aren't aware of this issue at all. I'm not sure if Verizon know about it but I figured I'd ask here because maybe someone else has experienced this issue with their galaxy s5. Also note that force stopping google play, play services, removing the google accounts and adding them back and rebooting the phone haven't solved it. After the reboot the phone will appear fine and then a box that says "Restricting background data".

    Thanks for reading and hopefully this issue can be resolved.


    Sent from my iPad using Tapatalk HD
    06-24-2014 12:21 PM
  2. mike almodovar's Avatar
    Go to power saving mode and uncheck the box that says "block background data" ... Once that is cleared you will have access to the restrict data settings on individual apps again.

    Posted via Android Central App
    06-24-2014 06:46 PM
  3. AZgl1500's Avatar
    I keep background data OFF all the time.

    but, Google Play services requires two things.

    Background data and sync. both of them have to be ON.

    The only time I ever need sync is when downloading an app from Play Store, otherwise I have no use for it.

    Background data I turn off because it is a huge waste of battery power.

    I have not had any reason to regret turning both of those items OFF.
    everything works like it is supposed to.
    06-24-2014 09:19 PM
  4. SAMmarked1's Avatar
    You will notice if you go to data usage this option should be there as well. It has to do with wifi/carrier data charges from apps running in the background. Due to all the constant updates these phones do people go over the data SO now we have a feature to disable background data usage.

    Posted via Android Central App
    06-24-2014 09:45 PM
  5. fantom305's Avatar
    and sync
    I don't really know if in fact this is necessary because I don't have enabled on my phone except when I am in need of backing up something and my Google Play works with out any problem.....
    Tritonemusic likes this.
    06-25-2014 12:32 AM
  6. gnsanjay1's Avatar
    Hi
    Excellent! Google play store background data enabled by disabling in power saving in settings
    G.N.Sanjay
    06-25-2014 12:02 PM
  7. Mr Tripod's Avatar
    I was asked to troubleshoot a Galaxy S5 phone today which, for some reason, was not able to access the Google Play store, Weather app, Google+ Photos and other apps. I quickly surmised that the common thread was apps that require "Background Data" to sync.

    Another clue was that under Settings > Data Usage, the setting "Restrict Background Data" -- while not checked -- was locked / unable to be changed.

    Also, another clue as mentioned within this thread, was after opening Google Play store - the user is prompted that Background Data is required but not enabled.

    The core issue for this device was the Power Savings settings of this phone. Under Settings > Quick Settings > Power Saving > Power Saving Mode (on) > Block Background Data. This setting was ON / Enabled / Checked. Once I unchecked / disabled it, not only did the main issue go away which I was troubleshooting ... but the aforementioned "Data Usage" > "Restrict Background Data" option was no longer greyed out / locked.

    In my opinion, since the power saving feature clearly disabled the "Restrict Background Data" option, a toast or similar clue should be provided, when the user attempts to alter the greyed out / locked setting.
    08-13-2014 09:33 PM
  8. AZgl1500's Avatar
    I used to purposefully lock out Background data on my phone and keep it that way,

    but.... that said, I also know that when trying to download an app from the Play Store,
    Background data has to be Enabled or the app won't download.


    Recently, about a month ago, I took a totally different approach to Data/Background data.

    I use MacroDroid to turn DATA, WIFI off when the screen locks. ie, the internet is DEAD, no app can use the internet while my phone is idle. For me, that is an ideal situation. No security breaches, no wasted battery power.

    When MacroDroid senses that I have unlocked the screen, it restores everything to normal.
    The very slight delay has not even been noticeable for me. By the time I can open an app, DATA is ready and waiting to be used.
    08-13-2014 11:55 PM
  9. Marcos C's Avatar
    I followed the steps recommended from Settings \ Data Usage..........etc........Background Data.

    However, that did not fix it for me entirely. I then went to Settings \ Application Manager \ Google Play Store - cleared my cache, cleared my data, did a force stop. Then I went back to my main, called Google Play Store again..........and WALLA.......it's working.
    08-28-2014 02:35 PM
  10. GalaxyLuva's Avatar
    Go to power saving mode and uncheck the box that says "block background data" ... Once that is cleared you will have access to the restrict data settings on individual apps again.

    Posted via Android Central App
    Thank you so much......Unlike technical support you helped me fix the issue with my phone....
    09-03-2014 07:12 PM
  11. DeViBos's Avatar
    Worked for me.
    Thank you Mike
    09-12-2014 09:01 AM
  12. Shane Gilles's Avatar
    Wow after a long battle I think I finally got it. I had to also clear the cache and force stop. Frustrating!
    09-16-2014 02:10 PM
  13. jmagid51's Avatar
    One additional step helps also and that is after force stop and clearing data and cache you should reboot the device.

    The same steps also will clear up many issues with ANY app.

    Enjoy.!!
    09-16-2014 02:41 PM
  14. Jacqueline Shepard's Avatar
    Many thanks to 'Marcos' whose posting allowed me to fix the issue with Google Play Store - restrict background data was already unchecked but when I cleared cache it finally enabled me to search/download an app.
    09-28-2014 10:54 AM
  15. Kelli Adcock's Avatar
    Tried all others.. this one worked! Thanks!
    09-29-2014 08:30 AM
  16. Kelli Adcock's Avatar
    Can't believe it this one worked!! Thank you!!!!!!
    09-29-2014 08:31 AM
  17. Aaron Geary's Avatar
    Worked here too. Many thanks.
    10-03-2014 04:19 AM
  18. AZgl1500's Avatar
    Yes, it does help a lot to clear out the cache and do a reboot.

    I just went through this yesterday again when Google Services stopped working. Reporting the issue accomplishes nothing, unless you get a personal sort of warmness about pressing a Report Button.

    How can a Report get through to Google, when Services has stopped?
    10-03-2014 08:12 AM
  19. davidlnewman's Avatar
    I am on Verizon also. Just force stopping the google play store works for me. After that I can go back into google play and it works fine. The question I have is this seems to happen on a very regular basis. I would say multiple times a week. Why does it keep happening and what can be done to stop this?
    10-03-2014 02:35 PM
  20. AZgl1500's Avatar
    I am on Verizon also. Just force stopping the google play store works for me. After that I can go back into google play and it works fine. The question I have is this seems to happen on a very regular basis. I would say multiple times a week. Why does it keep happening and what can be done to stop this?
    I note also that it happens far too frequently. Why should we have to force close/clear cache on the Play Store just to use it?
    10-03-2014 07:25 PM
  21. Syafiq Azmir's Avatar
    Finally, a working solution!!!
    10-14-2014 10:03 PM
  22. Christine Moscinski's Avatar
    Yes this WORKED!!! TY!!
    10-16-2014 02:11 PM
  23. James Sherrod's Avatar
    Tried everything above with no success. This worked perfectly, thanks.
    11-09-2014 09:40 PM
  24. Vikram Arya1's Avatar
    Go to
    settings - application manager - all - click on Google play store - clear data

    Problem resolved
    11-20-2014 12:03 PM
  25. a_sensei's Avatar
    Hello Tripod,

    Thanks for your solution. I was a similar problem on my galaxy k-zoom. On a separate note, it is not intuitive to have "block background data" within a "power saving" mode option. Not sure why they made it so complicated. Anyways, your solution helped.

    Thanks
    01-04-2015 09:25 AM
55 123

Similar Threads

  1. LG Optimus L7: Unlocking screen leads to dialpad!
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 09-13-2014, 02:56 PM
  2. Newest tablet on gomroo? Any help would be appreciated.
    By eric_roberts in forum Samsung Galaxy Tab S 10.5
    Replies: 5
    Last Post: 06-24-2014, 01:32 PM
  3. Rooted VZW S5, now trying to disable Pattern Lock
    By BillyTRichVa in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 0
    Last Post: 06-24-2014, 11:58 AM
  4. How to recover lost numbers from google
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2014, 11:49 AM
  5. Adding Multiple PDF files from box.com to an Email
    By diego.roscetti in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 06-24-2014, 10:38 AM
LINK TO POST COPIED TO CLIPBOARD