Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
Like Tree1Likes
  • 1 Post By Thomas Van Damme
  1. Thread Author  Thread Author    #1  

    Default S5 Not receiving incoming calls when connected to wifi

    I've had a fun afternoon with Virgin Mobile... I received a new Samsung S5 4 days ago and hadn't noticed until now that incoming calls weren't getting through, when I tried calling my mobile from a different number it was saying that the phone wasn't connected.
    Fix - re-seat the sim card - Worked for about 2 minutes and was successfully receiving incoming calls, then I noticed that every call I made to the mobile went to the answer machine so called Virgin mobile back.
    Fix - Go into settings and remove reference to LTE as follows (I am on a 3G contract)
    . Settings
    . More networds
    . Mobile networks
    . Network mode
    . Select WCDMA/GSM (auto connect) – The default is 'LTE/WCDMA/GSM' and as I don't have LTE was told to switch this off

    This fix worked for another 2 minutes, and then I noticed that every incoming call went to the answer machine, so I called back...
    Fix - Turn off wifi
    Incoming calls work fine now, and every time I turn on wifi they go to answer machine.
    I then did some searching around the net and also called Samsung UK directly, and was advised that I have a faulty handset and to ask Virgin Mobile to replace it.
    I then called back Virgin Mobile and was told that it affect Kit Kat and ALL networks, and Samsung are aware of the issue. I was told that they wouldn't swap it for another Samsung S5, but as I am only 4 days into my contract they can swap it for another make/ model.

    Anyone else noticed this, it appears to be a little intermittent, but I can reproduce the issue fairly consistently when turning the wifi (in the settings) on and off
  2. #2  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Doesn't Virgin Mobile have WiFi calling now? That delay sounds like the time it it would take to see WiFi, connect and setup call diverting. Could be a case of something not being configured right and calls are being routed to voice mail because they're not being received/answered on the phone. Maybe turn on airplane mode with WiFi on and see if you can call out via WiFi only?
  3. Thread Author  Thread Author    #3  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Quote Originally Posted by JudH View Post
    Doesn't Virgin Mobile have WiFi calling now? That delay sounds like the time it it would take to see WiFi, connect and setup call diverting. Could be a case of something not being configured right and calls are being routed to voice mail because they're not being received/answered on the phone. Maybe turn on airplane mode with WiFi on and see if you can call out via WiFi only?
    Hi, thanks for your reply, I have tried what you suggest..Turn on flight mode/ then turn on wifi (with flight mode enabled), I then went to make an outgoing call but got the message 'Flight mode on. Turn Flight mode off to make calls'.
    I followed the prompts and it turned off flight mode, and I was then asked to decide what app to use to make the calls, either the samsung phone app (The main phone icon) or the Virgin Mobile wifi one, I selected the main samsung one and it allowed me to make outgoing calls (I set this as the default) but not incoming ones.

    I have purposely not set up the virgin media 'SmartCall' app as I don't want the account merging with my home phone, primarily as I have an unlimited contract on the mobile.

    I have also double checked the 'Call Rejection' menu (In the phone menu) and set the default to the following - Auto Reject Mode = OFF

    It's pretty strange as the first time I tested the call rejection change I could receive an incoming call, but after turning the phone off and on again I couldn't.
    Looks like wifi is the problem, when I did the initial install of the phone I turned on the Virgin Mobile app called 'Simple Wifi', I have had a play with it since and by going into the settings and disabling it, it makes no difference.

    I can feel a full reset coming on followed by a replacement handset.
  4. Thread Author  Thread Author    #4  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    I have just reset my phone back to factory setttings three times to test a few combinations -

    1. On the initial start entered my home wifi and also enabled the Smart network switch setting that says it automatically switches between wifi and mobile networks to maintain a stable internet connection, I then called my phone with wifi enabled and it went to answer machine, I then called my phone with wifi disabled and it worked fine, and just to be sure called again with wifi enabled and it went to answer machine
    2. On the initial start entered my home wifi and did NOT enable the Smart network switch setting, I then called my phone with wifi enabled and it went to answer machine, I then called my phone with wifi disabled and it worked fine, and just to be sure called again with wifi enabled and it went to answer machine
    3. On the initial start did not enter any wifi details, I then called the phone and it worked fine

    Maybe it is a duff handset, I have noticed that the issue has appeared in another forum, so am wondering if it only affects a few of us
  5. #5  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Having exactly the same issue. They are refusing to give me a new handset as im around 18 days into my new contract, not happy, escalating this up the chain as far as I can, will be ofcom/trading standards next if its not resolved.
  6. #6  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Quote Originally Posted by silverghost123 View Post
    I was then asked to decide what app to use to make the calls, either the samsung phone app (The main phone icon) or the Virgin Mobile wifi one, I selected the main samsung one and it allowed me to make outgoing calls (I set this as the default) but not incoming ones.
    Try the WiFi app and see if you can make OUTGOING calls on WiFi.

    Could be a router or firewall issue, maybe a port has to be open for unsolicited incoming packets. Shouldn't BE unsolicited though if the WiFi app is holding a handshake open to their server. Might check the routers timeout setting--maybe it's closing the connection very quickly.
  7. #7  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    I don't understand why Virgin Mobile is having this problem.

    I am with Verizon and the phone don't care if WiFi is ON or OFF, or is DATA if ON or OFF.

    It will always receive phone calls as those can always be delivered to you via the 1x network.
    Verizon Galaxy S5 since Launch Day, using ART
    Box Stock, not rooted
    Nova Prime, Textra, Blue Mail
    MacroDroid senses Scrn off=Wifi & Data OFF,
    senses Scrn on=WiFi & Data ON
    Thanked by:
    JudH 
  8. #8  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Quote Originally Posted by AZgl1500 View Post
    I don't understand why Virgin Mobile is having this problem.

    I am with Verizon and the phone don't care if WiFi is ON or OFF, or if DATA if ON or OFF.

    It will always receive phone calls as those can always be delivered to you via the 1x network.
    Virgin Mobile has implemented true WiFi calling (which I don't believe Verizon has) where their system detects the phone is on WiFi (via the provided app) and diverts both outgoing and incoming calls TO THE CELLULAR NUMBER to the phone via WiFi only. This is a big plus over 3rd party voice over IP apps that have to receive calls with another number. In this case the system detects the WiFi, attempts to divert the call, then fails and let's voice mail pick up. Oops that means my router suggestion above doesn't hold water since if the app's connection was dropped/blocked their system wouldn't see the WiFi link at all and would send via cellular normally. I'm out of ideas.
  9. #9  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Verizon does not as of now support WiFi calling. Wish they did, but it don't matter for me anymore as I purchased their Network Extender cellsite modem and it gives me 5 bars anywhere on my property.

    I'm in a rural area and cell sites are sparce.
    Verizon Galaxy S5 since Launch Day, using ART
    Box Stock, not rooted
    Nova Prime, Textra, Blue Mail
    MacroDroid senses Scrn off=Wifi & Data OFF,
    senses Scrn on=WiFi & Data ON
  10. Thread Author  Thread Author    #10  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Thanks everyone for your help and suggestions, I tried the phone again this afternoon and surprisingly everything is now working as it should. I am positive it is nothing that I did myself, and called Virgin Mobile to try and find out more and also to cancel the replacement phone. I could only speak to first level support, and to be honest they were totally useless, but they did say that the technical team had been making changes to my settings, but couldn't tell me what.
    Good luck to everyone else with the same problem, I'm afraid I don't know any more than being told that the technical team dealt with the problem.
  11. #11  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Mine was fixed but is now having the same issue yet again, very annoying
  12. #12  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Just one question: has any one bothered to turn on the WI-FI CALLING in the settings ? so that every time the wi-fi is turned on the wi-fi calling is also turned on and calls can be made and received over wi-fi....
  13. #13  
    nrthwds's Avatar

    Posts
    34 Posts
    Global Posts
    65 Global Posts

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Wish you knew what they did to make your phone work. I'm on AT&T, switched from Verizon as AT&T has a new tower in my rural area for better reception. I have 3 bars in my home and when talking on the phone it goes up to 4 bars. No problem calling out. Purchased the new Samsung Galaxy S5 on 9/15/14.
    Incoming calls go directly to VM. Sometimes the phone works as it should and calls and messages came thru in a timely manner.
    Mostly the calls go to VM and text messages are delayed. Vm doesn't show up as having a vm for hours.
    I have gotten a new sim card, exchanged the phone and the new phone does exactly the same thing, I am now past my 14 days so I am stuck with this phone unless I agree to a warranty replacement phone from AT&T. (Same phone S5)
    I have has 4 cases with AT&T and nothing has helped. Last case will be resolved bu Oct 4.
    I will try turning off WIFI while at home and see if that helps.
    I have reset the new phone, did not help. I don't understand why with 3 bars I can't receive calls.
    Calling out is no problem. Incoming doesn't work correctly. Any suggestions are greatly appreciated. Thanks in advance.
  14. #14  
    nrthwds's Avatar

    Posts
    34 Posts
    Global Posts
    65 Global Posts

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Friends of mine were at my house over the weekend and he had a samsung s4 and had the same problem after logging onto my wifi. It is the wifi causing the problem. I had an old modem and netgear router that we hooked up and then we were able to receive calls like you should. We switched out the modem/router combo on Sat to my older setup and my phone is still working normally! I called my dsl provider and told them about the problem as I just bought the modem/router combo from them recently.
    They never heard of anything like this. I do find it hard to believe that the home wifi equipment disrutes the cell phone signal. But my phone is now working!!! Anyone ever heard of this or that can explain why this would happen I would love to hear about it.
  15. #15  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Hi,
    Seems like I am not the only one in this problem. I bought SIM free Galaxy S5 phone from internet and My Incoming calls are not working when WIFI is switched on . I am having Virgin Media contract SIM . I observed one more wiered behavior that Phone is not able to receive calls when mobile data is switched off.

    So:
    Mobile data off + WIFI OFF = no incoming
    Mobile data off + WIFI ON = no incoming
    Mobile data on + WIFI ON = no incoming
    Mobile data on + WIFI OFF = incoming works.

    I also have Virgin Media PAYG SIM. Now that SIM works perfectly fine. No issues at ALL. Nothing seems wrong with phone.
    I called Virgin Media support , they gave me same logic , SAMSUNG is working on some update.

    I feel that this started happening when I register myself with virgin Smart CALL feature. I un-installed APP, reset phone , de-register myself from Vigin account on their online login system. But nothing happened.

    Virgin Media is going to send me a NEW SIM now . I will not resgister this SIM with SmartCALL and lets see how it works then.

    Update :
    I used the same VirginMedia contract SIM in Nexus 5 phone . Exactly same issue. Not able to receive calls when WIFI is on. Clearly issue with Virgin media somewhere. most probably their smart call feature. Nothing wrong with Galaxy S5

    Waiting for their new SIM now .

    Upate2: new SIM arrived. No issues . Works perfectly. I am not going to subscribe to Smartcall feature o VirginMedia for the moment.
  16. #16  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Hi,

    My girlfriend had the same issues. Solved it by changing the network type to "GSM only".

    Greets
    Glenn 1410 likes this.
  17. #17  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Open settings up and find call settings then scroll down to the bottom
    Now the phone is scaning for internet calls but will have no account
    So press the option called Use internet calling
    and set it to only for internet calling, any other will will look for a VOIP connection
    now if you have not set one up this would explain why its going to voicemail
    look on your phone for a app called smart call if you have this disable this and the phone should now work
  18. #18  

    Angry Re: S5 Not receiving incoming calls when connected to wifi

    Hi,

    I'm having the exact same problem with my S5. I got it last Saturday and haven't been able to receive incoming calls when connected to Wifi. I've rang Virgin helpline 4 times in total and have been given different advice each time - none of which worked. They told me they would text me a link and 4 digit passcode so that I could update the operating system - that was Thursday night and I still haven't received it (Sunday afternoon).

    I think I'll pop back into the Virgin shop to see if they'll swap hand sets, but I'm not hopeful having read some of the threads.
  19. #19  

    Cool Re: S5 Not receiving incoming calls when connected to wifi

    Hi Thomas (post 10-12-2014, 10:23 AM),

    I tried that and it seems to have worked!!! Thank you!

    Can anyone tell me the difference between 'WCDMA/GSM' (this is what my phone was set to) and 'GSM' please?

    Thanks.
  20. #20  

    Thumbs up Re: S5 Not receiving incoming calls when connected to wifi

    After trawling through a number of comments, and feeling the frustration building up to the point of groaning, I uninstalled Virgin Smart Call and WiFi Buddy, and Hey Presto!
  21. #21  
    erasat's Avatar

    Posts
    342 Posts
    Global Posts
    593 Global Posts

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Quote Originally Posted by Glenn 1410 View Post
    Hi Thomas (post 10-12-2014, 10:23 AM),

    I tried that and it seems to have worked!!! Thank you!

    Can anyone tell me the difference between 'WCDMA/GSM' (this is what my phone was set to) and 'GSM' please?

    Thanks.
    I can swear that is not your Wifi Calling, if doing the above fixed it for you, then it's the VoLTE settings, just go to Call Settings and turn off that option, go back and set your data connection to LTE not just GSM, and try again.
  22. #22  

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Any body find solution for this case
  23. #23  
    jdr1000's Avatar

    Posts
    9 Posts
    Global Posts
    52 Global Posts

    Default Re: S5 Not receiving incoming calls when connected to wifi

    Same issue, cant find call settings where to disable Internet Calling.

Similar Threads

  1. Which country do i have to choose to update?
    By mekelle in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 3
    Last Post: 07-09-2014, 03:49 PM
  2. S5 camera storage
    By troyfd in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 07-08-2014, 05:21 PM
  3. Adhoc wifi?
    By novasquid in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 07-08-2014, 03:16 PM
  4. youtube is not working
    By Unregistered in forum Ask a Question
    Replies: 2
    Last Post: 07-08-2014, 01:59 PM

Posting Permissions