1. Vtec-Pete's Avatar
    Hi. I'm hoping someone on here can shed some light onto a problem that is driving me insane. I have a Galaxy S5 (SM-G900F) running Android 5.0. I've been using Nova and Teslaunread now for about a year with no problem. Today, however, the badges for by Samsung email app and Facebook will no longer update. My email says 183 unread when I have about 65 and that number will not change no matter what I do. I have uninstalled and re-installed Teslaunread 3 times so far and have cleared the data and cache multiple times to no avail. I emailed the developers but I've had no response from them either.

    I fear it might have something to do with Cleanmaster which I did have installed and only ever used to free up space on my phone but accidentally hit "yes" accidentally when it asked me whether it should hibernate apps that kept restarting. But I subsequently deleted Cleanmaster in case it was getting in the way and it's not helped.

    Does anyone have any clues as to how to fix this? Not having a clue whether I have messages to read without opening the app is driving me crazy!

    Cheers

    Pete
    09-16-2015 02:45 PM
  2. CMeys's Avatar
    I just had the same problem -- though mine happened on it's own (possibly after some update).

    I contacted the developer and he had me try 2 things (now this may not apply to your situation since I didn't use Cleanmaster or do anything like that). The first didn't work, but the 2nd did. I'll paste his instructions here:

    1) That's a Play Store bug. Usually clearing your Play Store app cache fixes it. You can do this by opening your device Settings menu. Press Applications > Google Play Store > "Clear Cache" and then try downloading the app once more. (I did this and it didn't help).

    2) Try these steps:
    - Open your device Settings menu
    - Press Applications (if you don't see it, press More and it'll be on the next menu)
    - Swipe from right to left until you see All at the top
    - Press BadgeProvider
    - Press "Clear Data" then "Force Stop"
    Then open the email app and return to Nova.
    This one worked for me. Try it and see. Nothing to lose.
    Vtec-Pete likes this.
    09-16-2015 08:37 PM
  3. CMeys's Avatar
    I also need to add that my symptoms were not exactly the same as yours. I have badge notifications set for a number of apps and all were fine except for the Email one which had suddenly stopped working. The instructions above in #2 fixed that issue.
    Vtec-Pete likes this.
    09-16-2015 08:40 PM
  4. Vtec-Pete's Avatar
    I just had the same problem -- though mine happened on it's own (possibly after some update).

    I contacted the developer and he had me try 2 things (now this may not apply to your situation since I didn't use Cleanmaster or do anything like that). The first didn't work, but the 2nd did. I'll paste his instructions here:

    1) That's a Play Store bug. Usually clearing your Play Store app cache fixes it. You can do this by opening your device Settings menu. Press Applications > Google Play Store > "Clear Cache" and then try downloading the app once more. (I did this and it didn't help).

    2) Try these steps:
    - Open your device Settings menu
    - Press Applications (if you don't see it, press More and it'll be on the next menu)
    - Swipe from right to left until you see All at the top
    - Press BadgeProvider
    - Press "Clear Data" then "Force Stop"
    Then open the email app and return to Nova.
    This one worked for me. Try it and see. Nothing to lose.
    CMeys - you are an ABSOLUTE STAR! This has been driving me around the twist but I followed your instructions and option 2 fixed it straight away. Thanks so much.

    Pete
    09-17-2015 02:32 PM
  5. CMeys's Avatar
    CMeys - you are an ABSOLUTE STAR! This has been driving me around the twist but I followed your instructions and option 2 fixed it straight away. Thanks so much.

    Pete
    I'm really glad I could help, but it is just coincidental that I recently has the problem and had emailed the developer who got back to me after a couple of weeks.
    09-17-2015 02:34 PM
  6. mrmagic416's Avatar
    Hello -
    I have a Nexus 6 & there is no BadgeProvider in application settings.
    Any ideas?

    Thanks
    Jim
    10-16-2015 10:21 AM
  7. CMeys's Avatar
    Hello -
    I have a Nexus 6 & there is no BadgeProvider in application settings.
    Any ideas?

    Thanks
    Jim
    Do you have both Nova Launcher and Tesla Unread installed (2 separate apps)? Tesla must be installed after Nova. What happens when you run Tesla on it's own -- do you see the settings there?
    10-16-2015 10:28 AM
  8. mrmagic416's Avatar
    Yes, they are both installed.
    My problem is, I got the mail to work fine but messenger always has the number 7 to it.
    There are no unread messages & 25 old messages yet the number remains 7.
    I've tried everything possible.
    10-16-2015 02:22 PM
  9. CMeys's Avatar
    Yes, they are both installed.
    My problem is, I got the mail to work fine but messenger always has the number 7 to it.
    There are no unread messages & 25 old messages yet the number remains 7.
    I've tried everything possible.
    You should try emailing the developer. He found the solution to my problem & replied to me.
    10-16-2015 02:27 PM
  10. mrmagic416's Avatar
    I did. They can't figure it out either.
    Thanks
    10-16-2015 02:49 PM
  11. AndroidUK's Avatar
    I have a very similar problem - no "badgeprovider". Eveythings working fine for some time even after Marshmallow update but no only Gmail count is correct. Other apps no longer show a count and "Messages" has a 2 count permanently even though all are read.
    10-24-2015 09:43 AM

Similar Threads

  1. Minor update?
    By alex217c in forum Samsung Galaxy Note 5
    Replies: 4
    Last Post: 09-20-2015, 08:42 PM
  2. Replies: 1
    Last Post: 09-17-2015, 04:28 PM
  3. How can I update my Zeepad 9XN tablet to 5.1.1?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 09-16-2015, 02:26 PM
  4. Replies: 0
    Last Post: 09-16-2015, 12:46 PM
  5. Replies: 1
    Last Post: 09-16-2015, 12:19 PM
LINK TO POST COPIED TO CLIPBOARD