05-09-2017 05:06 PM
49 12
tools
  1. Planelove's Avatar
    This worked on my S7E for now..
    Thanks
    FirstPost
    11-29-2016 09:49 AM
  2. ndn_native's Avatar
    Disabling Wi-Fi scanning worked for me too. Now my Wi-Fi stays on & I can connect to an SSID. Hopefully my battery drain will stop now too.
    11-29-2016 11:23 AM
  3. Dfried81's Avatar
    No other previous fix mentions in this post is working for my S7 Edge through VZW. This is the only one that worked so far...hitting Wifi Direct really fast, and then hitting the back button. Samsung needs to get their sh-t together
    11-30-2016 12:24 PM
  4. Alanhd's Avatar
    I switched my WiFi scanning back on and it's been OK.
    11-30-2016 01:43 PM
  5. Lepa79's Avatar
    Noticed this problem on my Carol blue S7 Edge today. Just turned wifi scanning off. Let's see
    12-01-2016 07:29 PM
  6. Gary02468's Avatar
    I switched my WiFi scanning back on and it's been OK.
    Not for me (on AT&T). Enabling WiFi scanning still results in the WiFi blinking on every few seconds, accompanied by rapid battery drain.
    12-02-2016 05:13 PM
  7. Trees's Avatar
    I may have the same problem with my Verizon Note 5. The past few weeks have noticed problems connecting to home WiFi (no other devices in the house have a problem), and rapid battery drain and phone getting noticeably warm while at work (not the best signal given large building and many other people competing for signal, but its been relatively way worse recently).

    The drain has been so bad that I have to start recharging around 1400, where in the past under normal usage patterns did not have to go back on charger till 2200 or later. Since I only have a USB cable at work, the charge rate vs. drain is barely enough to regain some battery life, and definitely have to charge in the vehicle on the drive home.

    I have location services set to GPS only, and interestingly I don't see a Location option in the "Privacy and safety" settings. Maybe Verizon removed that feature?

    To connect to home WiFi upon return from work or out and about, have to toggle Airplane Mode several times to work around the WiFi turning itself off and on automatically. Sometimes WiFi is dropped randomly. Again no problems until the last few weeks, and have tried the Cache Wipe and power down/up cycle multiple times. To this point all of those workaround have been temporary.

    The other problem I've noticed along with the above heating and rapid battery drain is garbled or rapid skipping during music playback. This is using the default Samsung Music app with media storage locally. The music playback problem started around the same time as the heating and rapid battery drain.

    I've had this Note 5 since last October, so wondering if it's starting to fail and is being impacted by the apparent WiFi switching issue at the same time.
    12-03-2016 10:19 AM
  8. Vlad Milenski's Avatar
    Same problem with my S7edge. I tried resetting the network settings and it worked: Settings -> Backup and Reset -> Reset network settings.
    After a couple of days without a problem, the issue reappear with no obvious cause, so I did the same resetting network settings and it worked again.
    All in all, three times for the last 2 weeks.
    I am waiting for the update.
    12-04-2016 02:21 PM
  9. Alanhd's Avatar
    Did anyone try clear the system cache, I did in between having the problem and retesting.
    12-04-2016 02:25 PM
  10. tennislvr8's Avatar
    Also, delete the 5g WiFi. That fixed it for me haven't had the problem since.
    12-04-2016 02:33 PM
  11. GregCT2010's Avatar
    I'm having the same problem, sort of.
    My connection issue is limited to my home wifi (Motorola SGB6850 Modem/Router in one). Connects fine to work (2 seperate networks), Xfinity on the telephone pole outside the house, Dunkin, McD's and any other number of free wifi's around town. The weirder part is the wife's S7Edge bought at the same time, has no issues with the connection. Set side my side, hers rocks on, mine constantly connects, says there's no internet available, disconnects...
    The only think I haven't done, yet, is the full factory reset, kind of worried that it might break the wifi connections that are working....
    12-05-2016 12:13 AM
  12. Trees's Avatar
    Just tried the "Reset network settings" option, and rejoined home Wi-Fi. Prior to rejoining home WiFi ran a Speedtest and got 43.7Mbps down, 11.25 up.

    Will see if this makes a difference at work tomorrow for mobile signal and battery drain, along with not seeing the constant Wi-Fi on/off toggling and problems joining home Wi-Fi after returning from work.

    Yesterday when out around town in various locations Speedtest results were at best 13.73 up and 12.38 down. Signal strength was likely varied at the different locations, particularly with many people in the same area. Earlier this year was able to get 74.70 Mbps down 11.97 up at home. Realize that there have been a few OS updates since then, and that Verizon network variances among other factors can influence results.
    12-11-2016 09:22 AM
  13. anon(10119014)'s Avatar
    I dont have
    "Connection Optimizer"
    "Smart WiFi".

    I do have
    everything in wireless turned off
    including the smart network switch
    Under privacy wifi scanning is off as well as bluetooth


    none of the fixes work
    12-26-2016 11:04 AM
  14. Trees's Avatar
    Just tried the "Reset network settings" option, and rejoined home Wi-Fi. Prior to rejoining home WiFi ran a Speedtest and got 43.7Mbps down, 11.25 up.

    Will see if this makes a difference at work tomorrow for mobile signal and battery drain, along with not seeing the constant Wi-Fi on/off toggling and problems joining home Wi-Fi after returning from work.

    Yesterday when out around town in various locations Speedtest results were at best 13.73 up and 12.38 down. Signal strength was likely varied at the different locations, particularly with many people in the same area. Earlier this year was able to get 74.70 Mbps down 11.97 up at home. Realize that there have been a few OS updates since then, and that Verizon network variances among other factors can influence results.
    The "Reset network settings option" did not work. Finally did a Factory Reset (after backing up data). Problems I was encountering before are resolved thus far.
    01-08-2017 08:22 AM
  15. GregCT2010's Avatar
    Even the full factory reset did nothing for me, turned out the whole problem was an error on the router side. Once the DHCP server released and renewed all the 'connection licenses' (for lack of a better term) all has been fine.
    01-09-2017 12:49 AM
  16. Chriswfail's Avatar
    Where is the privacy and safety setting? I have privacy and emergency on my verizon s7 edge and nothing to do with WiFi and/or improving anything there
    01-10-2017 08:54 AM
  17. Ali Tarahani's Avatar
    I've tried everything mentioned here, nothing worked. what fixed it for me (for now) was turning Mobile Hot-Spot on and off i'd suggest trying this out too.
    Settings> Mobile hotspot and tethering> Mobile hotspot.
    02-17-2017 02:56 AM
  18. lewjr1's Avatar
    I can confirm that a FACTORY RESET corrects the Wfi issue
    Galaxy S7 Edge on Verizon (phone updated 3/13/2017)
    03-14-2017 08:33 PM
  19. Jordan Dell's Avatar
    Try disabling Smart Network switch in wifi settings
    Turn off download booster in wifi settings
    03-26-2017 02:51 PM
  20. psychoflute's Avatar
    Where is the privacy and safety setting? I have privacy and emergency on my verizon s7 edge and nothing to do with WiFi and/or improving anything there
    It's under Location->Improve Accuracy on my Verizon S7 Edge running Nougat. So far it has solved this issue for me, but it hasn't even been a full hour since I turned off WiFi scanning.

    *fingers crossed*
    Chriswfail likes this.
    04-18-2017 02:21 PM
  21. magichoward's Avatar
    It's under Location->Improve Accuracy on my Verizon S7 Edge running Nougat. So far it has solved this issue for me, but it hasn't even been a full hour since I turned off WiFi scanning.

    *fingers crossed*
    Working for me too thanks...but needs an update by samsung
    04-19-2017 12:32 PM
  22. magichoward's Avatar
    Working for me too thanks...but needs an update by samsung
    I spoke to soon ...same problem is it hardware ?
    04-20-2017 10:07 AM
  23. ghuss's Avatar
    Well there does need to be an update but I found a temporary fix for my G7 Edge. Go to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. It worked for me, if it doesn't for you then I have no idea.
    S7 Edge, Wifi turns off, Problem solved with : Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning

    Thanks
    05-09-2017 05:43 AM
  24. gary scarborough's Avatar
    S7 Edge, Wifi turns off, Problem solved with : Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning

    Thanks
    I'm having the same problem but I never had WiFi scanning enabled
    05-09-2017 05:06 PM
49 12

Similar Threads

  1. Sony Xperia Z5 Premium Dual E6883 Looking To Replace S7 Edge-Yes or No?
    By 123spongebob123 in forum Sony Xperia Z5 Premium
    Replies: 1
    Last Post: 12-01-2016, 07:11 AM
  2. This phone is starting to grow on me
    By AGC 1906 in forum Samsung Galaxy S7 edge
    Replies: 30
    Last Post: 11-21-2016, 08:36 AM
  3. Chrome on S6 not opening to set home page
    By williamhcraft in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 11-17-2016, 10:44 AM
  4. Why doesn't my BT200 headphones show up on my Nexus 7 tablet?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 11-17-2016, 08:18 AM
  5. proximity sensor not working on galaxy S5.
    By abhi997 in forum Ask a Question
    Replies: 0
    Last Post: 11-17-2016, 07:12 AM
LINK TO POST COPIED TO CLIPBOARD