1. Shippy_92's Avatar
    Hello,

    Long time lurker, first time poster!

    Basically, I have an issue whenever it comes to charging my phone.

    My phone never seems to charge to 100%. I have tried several different chargers and a couple of batteries. I have recently had my phone back from repair from Samsung (great quick service by the way) and I believe they replaced the USB port. The first night that I had my phone back it charged to 100% with the Anker 4400mAH battery in and this is the first time this has ever happened. However for the past three nights the phone has actually been losing charge - even though it has been plugged in.

    Basically I have tried leaving the phone on and switching it off whilst charging overnight and it is losing about 20% battery each time. Do you think that this is going to be a problem with the battery rather than the phone now? Might be worth noting that the stock battery has been branded faulty by Samsung but I hope that it is not the case with the Anker battery as I have had it about two months,

    Any ideas would be appreciated.
    09-27-2013 06:50 AM
  2. Haalcyon's Avatar
    Welcome to posting here in the forums! It sounds like it might be the battery? If possible, I'd want to try an OEM battery and charger to see if that has any effect.
    09-27-2013 07:00 AM
  3. Ichi_Bear's Avatar
    Haalcyon hit the nail on the head. I've had problems with 3rd party batteries before. Not holding a decent charge and such. I only use an OEM battery in my phone now. It's works fine no problem charging or hold a charge. Be careful though as there are a lot of fake ones out there. You're better of with a 3rd party on than a dodgy fake. ;-)

    Sent using a Samsung Galaxy S3 and Tapatalk 4

    I'm usually on Twitter @Ichi_Bear ;-)
    09-27-2013 08:41 AM
  4. yousra sultan's Avatar
    i have the same problem, and can't find a solution for it,However i've just bought my mob a week ago
    09-27-2013 02:09 PM
  5. Shippy_92's Avatar
    Done a bit of investigation using Galaxy Charging current lite. I tried three different chargers and tried both batteries I own.

    First of all for the Anker battery the average results I got was :-

    Maximum - 100
    Now - 999
    Average - 100

    For the stock oem battery I got

    Maximum - 400
    Now - 999
    Average - 400

    The figures should be reading 1000 for maximum and average

    Bear in mind that samsung have told me that the stock battery is faulty but yet it appears to be drawing more charge from the chargers than the Anker. Safe to say I will be getting a replacement from Anker.

    Like I say, three different chargers all yielding same results so appears to be a battery issue more than anything
    09-27-2013 05:51 PM
  6. Faultymango's Avatar
    Done a bit of investigation using Galaxy Charging current lite. I tried three different chargers and tried both batteries I own.

    First of all for the Anker battery the average results I got was :-

    Maximum - 100
    Now - 999
    Average - 100

    For the stock oem battery I got

    Maximum - 400
    Now - 999
    Average - 400

    The figures should be reading 1000 for maximum and average

    Bear in mind that samsung have told me that the stock battery is faulty but yet it appears to be drawing more charge from the chargers than the Anker. Safe to say I will be getting a replacement from Anker.

    Like I say, three different chargers all yielding same results so appears to be a battery issue more than anything
    Id highly recommend using a different cable to charge. I had the same problem. Then I used my spare cable from my HTC ONE SV and it worked wonders. Now I have the following results:
    Max: 1000
    Now: 999
    Average: 1000
    I use the stock oem charger provided by samsung with the S3 but just a different cable.

    Also keep the original cabke for the s3 because that is the only cable that can be used if you need to sync or transfer stuff from pc to S3 or vice versa.
    Hope this helped.

    Sent from my GT-I9300T using Tapatalk 4
    09-28-2013 07:30 PM
  7. Shippy_92's Avatar
    Still not having any luck. Anker battery I'd being refunded so I have bought the official extended battery from Samsung. Also got a new cable (blackberry) to use with oem charger and only getting between 100 and 400 showing in galaxy charging app

    Help

    Posted via Android Central App
    10-02-2013 04:46 PM
  8. Shippy_92's Avatar
    Phone discharged instead of charging again last night. Fuming.

    Posted via Android Central App
    10-04-2013 02:37 AM

Similar Threads

  1. SD Card not recognized on New Blu Vivo 4.65 HD?
    By David Blanton in forum Android 4.0 Ice Cream Sandwich
    Replies: 3
    Last Post: 01-07-2014, 09:42 PM
  2. Sync problem
    By tdc4266 in forum Android Apps
    Replies: 3
    Last Post: 09-28-2013, 10:24 AM
  3. Problems flashing CM 10.1 on my tablet
    By Xufyan in forum Samsung Galaxy Tab 7-inch
    Replies: 1
    Last Post: 09-27-2013, 08:55 AM
  4. SG2 Battery Problem
    By Incredulous16 in forum Samsung Galaxy S II
    Replies: 3
    Last Post: 09-27-2013, 07:21 AM
  5. "Fully Charged" notification sound
    By natehoy in forum LG Optimus G Pro
    Replies: 1
    Last Post: 09-26-2013, 04:17 PM
LINK TO POST COPIED TO CLIPBOARD