Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Post Battery Problem

    Hi,

    I am using Samsung Galaxy S3 GT-I9300 (The international version). I always charge my phone 100% and recharge it once battery goes below 10%. This gives me around 10-12 hours of battery life on WiFi and approx 2.5-3 hours of screen on time. I noticed this recently that once I let my phone battery die and then plug it to the charger it charges upto 40% the moment I plug my charger in. Why does this happen so? Is it the fault of my battery or OS? How do I make maximum utilization of my battery?

    Comments, suggestion and tips are highly appreciated.

    Thanks.

    Edit 1: I am using stock ROM. Now updated to 4.3 Jelly Bean
  2. #2  

    Default Re: Battery Problem

    How old is the battery? You may want to try replacing it.

    Sent from my SM-N900T using AC Forums mobile app
  3. Thread Author  Thread Author    #3  

    Default Re: Battery Problem

    My phone and battery both are 2 years old.
  4. #4  

    Default Re: Battery Problem

    Maybe try a new battery from Samsung. Batteries lose capacity over time.

    Sent from my SM-N900T using AC Forums mobile app
  5. #5  

    Default Re: Battery Problem

    2 x RAVPower® 3.8V 2250mAh Cell phone Rechargeable Battery for Sams... http://www.amazon.com/dp/B009758KK6?...0-20&m1k=vb_ac

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk

Similar Threads

  1. Year and a half old battery is getting tired....
    By kenorian in forum Droid RAZR MAXX HD
    Replies: 3
    Last Post: 07-02-2014, 11:55 AM
  2. Nexus 4 not detecting new battery
    By skypaladin05 in forum Google Nexus 4
    Replies: 2
    Last Post: 06-21-2014, 12:25 PM
  3. Galaxy S5 problems
    By xJokersAngelx in forum Ask a Question
    Replies: 1
    Last Post: 06-19-2014, 10:27 PM
  4. Weird charging problem
    By The Hustleman in forum General News & Discussion
    Replies: 1
    Last Post: 06-19-2014, 08:15 PM
  5. Upgrade to 4.4, Notification tone problems.
    By zinzara in forum Ask a Question
    Replies: 1
    Last Post: 06-19-2014, 08:00 PM

Posting Permissions