1. Eeyorevicky Chow's Avatar
    My tab seems having problem to connect to google play store. Can anyone help?
    09-17-2013 09:35 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is Google Play even opening, or is it crashing before you even see the main page? Or can you open it, but can't install anything?

    If you can open Google Play, tap menu/Settings/Account, and make sure your Google account is selected. If you can't open Google Play, try going to Settings/Apps/All, selecting Google Play Store, and Clearing Data and then Force Stopping. Then try opening Google Play again.

    I noticed that Google Play Services updated today, so I wonder if things might have been a little funny while it was rolling out today. The current Google Play Services version I have is 3.2.25 (761454-34).
    09-18-2013 01:49 AM
  3. richard51zz's Avatar
    Thanks B Diddy. It worked for my Medion (Aldi) phone that I need for work.
    12-18-2013 01:29 AM
  4. richard51zz's Avatar
    Thanks B Diddy. It worked for my Medion (Aldi) phone that I need for work.
    12-18-2013 01:55 AM
  5. elisheva60's Avatar
    Worked for me too....(new Note 3).
    01-16-2014 12:39 AM
  6. DamnAndroid2's Avatar
    Hi I tried what you said but now I have another error coming up instead RPC:S-7:AEC-0???? It will not connect to the server no matter what I try. I have an EZPAD 910C Mid
    03-05-2014 03:09 AM
  7. Stacey Borrelli's Avatar
    I also tried this, but it doesn't work. I'm using a Samsung Galaxy tab 3. It keeps saying I have no connection to the Play store. Any ideas?
    03-05-2014 08:17 AM
  8. brosko's Avatar
    Hi I tried what you said but now I have another error coming up instead RPC:S-7:AEC-0???? It will not connect to the server no matter what I try. I have an EZPAD 910C Mid
    I also tried this, but it doesn't work. I'm using a Samsung Galaxy tab 3. It keeps saying I have no connection to the Play store. Any ideas?
    Is the time and date correct on your devices? If time and/or date are incorrect this will happen too.
    03-05-2014 09:52 AM
  9. Ronald Zreik's Avatar
    My tab seems having problem to connect to google play store. Can anyone help?
    03-21-2014 06:29 AM
  10. Fernando Reyes1's Avatar
    Hi I tried what you said but now I have another error coming up instead It will not connect to the server no matter what I try. I have an Samsung model #m840
    06-29-2014 06:53 AM
  11. giridhar anu's Avatar
    I also tried this, but it doesn't work. I'm using a Samsung Galaxy tab 4. It keeps saying I have no connection to the Play store. Any ideas?
    11-17-2014 07:01 AM
  12. Livia Blackwood's Avatar
    Why I don't have no connection at the kids store
    03-10-2015 09:42 PM
  13. Zerolatency's Avatar
    Is the time and date correct on your devices? If time and/or date are incorrect this will happen too.
    This worked. Fixed time and date and connection came back. Samsung galaxy 2
    04-28-2016 06:51 AM

Similar Threads

  1. Korean Version LG G2 F-320K Running On T-Mobile
    By BOSSY TEXAS CHICK in forum LG G2
    Replies: 4
    Last Post: 11-12-2015, 01:10 PM
  2. Replies: 14
    Last Post: 09-06-2014, 09:24 AM
  3. Types texts on its own
    By BruceP in forum LG Spectrum
    Replies: 1
    Last Post: 09-26-2013, 11:25 PM
  4. Register on Samsung to be notified
    By Raptor007 in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 2
    Last Post: 09-20-2013, 08:45 PM
  5. Volume on calls sucks
    By justin1578 in forum Moto X (2013)
    Replies: 3
    Last Post: 09-17-2013, 08:00 PM
LINK TO POST COPIED TO CLIPBOARD