Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  

    Default Netflix - cannot sign in

    No matter what I do Netflix will not work.

    I enter sign in information and it just sits there.

    I've uninstalled updates numerous times and get the same results each I try to log in again.

    Anybody else have this issue?
  2. Thread Author  Thread Author    #2  

    Default Re: Netflix - cannot sign in

    Anybody?
  3. #3  

    Default Re: Netflix - cannot sign in

    I just set mine up last night, and while I did have issues setting up HBO Go, I eventually got it working. But Netflix worked right away. Are you sure you're entering the right credentials and that the service is not being blocked by your provider (for instance, if you're in a Work network, Netflix traffic might be blocked, but since you're not on the web interface, the app won't tell you that it's blocked or come up with the usual web filter screen).
  4. Thread Author  Thread Author    #4  

    Default Re: Netflix - cannot sign in

    Not at work. Home network.

    As far as login info, using same info I use everywhere. TV, phone etc...

    I'm baffled.
  5. #5  

    Default Re: Netflix - cannot sign in

    Do you know anyone else with a Netflix account? I would try adding theirs instead and see if that works. If it does, then you know that something's wrong with either your info or with your account (in which case you should probably call Netflix). If it doesn't, you know it's something wrong with either the app or the tablet. And since the app works in other tablets, well...

    You can always try to clear data on the app (not uninstalling). That's what cleared my issue with the Netflix app. Oh! And make sure that, on the same tablet, you can access the Netflix SITE, not the app.
  6. Thread Author  Thread Author    #6  

    Default Re: Netflix - cannot sign in

    Tried clearing data.

    Still hangs on sign-in.

    I can access Netflix on the tablet via the Web.

    Since it is a preloaded app, I can't fully delete it in order to start with a clean slate.

    Hmm...
  7. #7  

    Default Re: Netflix - cannot sign in

    But did you update to the latest version? I mean, the preloaded one still had the red Netflix logo. It should have updated itself to the new white one.

    Mine is showing Version 3.7.1 build 1711

    If you can log in through a web browser then it's definitely the app.
  8. Thread Author  Thread Author    #8  

    Default Re: Netflix - cannot sign in

    Yes updated to the latest version. Same as yours.

    So will Netflix point the blame at Samsung? I'll try them first.
  9. #9  

    Default Re: Netflix - cannot sign in

    They probably will. Like most, their tech support is usually very iffy and if there's a chance to blame this on someone else, they will likely go that way.

    I'm assuming you already tried uninstalling updates, rebooting, and re-updating, right? Mention that upfront. It should save you time since these will be the first things they'll ask you to try.

Similar Threads

  1. Frequent contact appearing in speed dial
    By AlfredB in forum Ask a Question
    Replies: 2
    Last Post: 08-28-2014, 09:32 AM
  2. Wifi turns on in Samsung S Duos 2
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-27-2014, 06:36 PM
  3. AC FORUMS log in
    By Jalopiejoe in forum Ask a Question
    Replies: 2
    Last Post: 08-27-2014, 01:57 PM
  4. Compatibility of Binatone Routers for Chromcast in India
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-27-2014, 05:50 AM
  5. Samsung Galaxy Tab 4 in white $174.99 at OfficeMax!
    By saichick04 in forum Samsung Galaxy Tab4 10.1
    Replies: 0
    Last Post: 08-27-2014, 05:28 AM

Posting Permissions