Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  
    Melon Bread's Avatar

    Posts
    65 Posts
    ROM
    AOKP

    Question [SOLVED] Android Source Repo Download Help (Python Issue?)

    NOTE: I Am On Linux Mint 9 32 bit


    Okay So I Have Lately been trying TO Get The Latest Android Source Code From
    Now I Follow The Down To The Wire (The Ones For Ubuntu, But They Should In Theory Work For Mint 9), And Everything Works Up Until I get To This Part:
    Initializing a Repo client

    Run "repo init" to bring down the latest version of Repo with all its most recent bug fixes. You must specify a URL for the manifest:
    $ repo init -u git://android.git.kernel.org/platform/manifest.git

    If you would like to check out a branch other than "master", specify it with -b, like:
    $ repo init -u git://android.git.kernel.org/platform/manifest.git -b cupcake
    When prompted, configure Repo with your real name and email address. If you plan to submit code, use an email address that is associated with a Google account .
    A successful initialization will end with a message such as
    repo initialized in /mydroid

    Your client directory should now contain a.repodirectory where files such as the manifest will be kept.
    And When I Try To Run That Line Through The Terminal I Get This Error:
    Code:
    Traceback (most recent call last):
      File "/bin/repo", line 91, in ?
        import readline
    ImportError: No module named readline
    Now I Know What The Problem is, It Is Looking For The readline.so in the the lib folder, Yet Even Though It Is There It Still Wont Work.
    Now I Have Tried All 2.x.x Versions Of Python (2.4.6, 2.5.5, & 2.6.4) and None Of Them Work.
    Also With Each Version I Run:
    Code:
    $ ./configure --enable-readline
    And Still the Same Error.

    i Have Been working On this For About 3 Hours Now And Still Now Luck.
    I Tried A Google Search But Every Topic Get Close To Helping Someone Get It Then Stops.

    Please Help Me Out Here ?
    Last edited by Melon Bread; 07-01-2010 at 03:51 PM.
  2. Thread Author  Thread Author    #2  
    Melon Bread's Avatar

    Posts
    65 Posts
    ROM
    AOKP

    Exclamation Solution

    Okay So I Found The Solution.
    repo runs STRICTLY off of 2.4.x and for some reason when I installed Python 2.4.6 readline.so was never put into:

    Code:
    /usr/local/lib/python2.4/lib-dynload/
    So I copied the readline.so from my Python 2.6.4 folder (File Download Below)
    and put it into:

    Code:
    /usr/local/lib/python2.4/lib-dynload/

    Then I ran repo again and it worked fine.

    Although it withh give you an API mismatch warning, but so far it has worked fine
    Attached Files Attached Files
    Last edited by Melon Bread; 07-01-2010 at 03:48 PM.

Posting Permissions

B