Hi Everyone,

I'm new to the Android community so bear with me! I recently bought a used Unlocked Galaxy S3. The phone works great and my SIM card worked right away. My problem is I believe the phone is rooted, but its not rooted correctly. I began trying to update the OS but it said it was modified and sure enough it was. So I booted it up in the "downloading" mode which came up with "odin mode" and said the binary and system status are custom and a custom binary has been downloaded 3 times. The phone also has SuperSU installed which my research tells me is a super user application. When I used SuperSU and tried to update the binaries like it wanted me to it failed. So I later decided to use a "Root Checker" app to determine what was going on. This app was telling me that I didn't have root access! So clearly the phone isn't actually rooted but it appears to have a custom ROM on it.

Would anyone be able to tell me what is going on here?

I would like to remove any traces of a root if possible - or at least fix the current one. I was looking into using Triangle Away and an official ROM with odin but I don't know what the original carrier is (if there was one, it could have never been locked to a carrier) so I didn't know which ROM to choose. Perhaps someone could help me here too?

Normally I would just search this kind of stuff up but with all these warnings about bricking the device I don't want to just start trying things till I get it working.

Thank you for reading my post, I look forward to any help that you may be able to offer me.

Here's some phone information:
Model: SGH-I747M (Canada version)
Android V: 4.1.1
Baseband: I747MVLDLK4
Build #: JRO03L.I747MVLDLK4

Thanks!