1. Marwan Hamze's Avatar
    Guys I heard that this app has come to Xperia Z, but when I try to download it this sentence appears :"this app is not compatible with your device"(I have Xperia Z)
    So what's the problem? BTW I still have 4.2.2 and waiting for 4.3 , does this app need the 4.3 update?

    Posted via Android Central App
    01-24-2014 05:45 AM
  2. Jamie Menzies's Avatar
    Yes you need 4.3 I recently updated to 4.3 on voda UK and it works a treat

    Posted via Android Central App
    Marwan Hamze likes this.
    01-25-2014 12:39 PM
  3. zotirinel's Avatar
    Hi,
    please tel me, it is there any way to install on Galaxy Note 3 (Android 4.4.2) the timeshift burst?
    thank you very much
    03-16-2014 01:40 AM

Similar Threads

  1. Can't download apps on Pantech Burst
    By Dasia Wilson in forum Misc. Android Phones
    Replies: 3
    Last Post: 04-20-2016, 09:51 AM
  2. Burst mode camera
    By Gil0202 in forum Android 4.4 KitKat
    Replies: 6
    Last Post: 08-11-2014, 01:33 AM
  3. Burst Shot doesn't work...
    By THEPRFCT10 in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 04-12-2014, 09:17 AM
  4. [Arcade][2.3+] Burst em Up [Free]
    By ddhhiirreenn in forum Android Games
    Replies: 1
    Last Post: 12-24-2013, 07:52 AM
  5. Google Nexus 4 - randomly bursting in to life...
    By Yorkshirebandit in forum General Help and How To
    Replies: 3
    Last Post: 12-09-2013, 01:12 PM
LINK TO POST COPIED TO CLIPBOARD